summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Minka2015-08-09 17:51:50 +0200
committerMartin Minka2015-08-09 17:51:50 +0200
commit60b6701f6dba094af3460b523d9a02495d695f30 (patch)
treef9a79a2d07eb3abddf0c96718d7638eb3fdc447c
downloadaur-60b6701f6dba094af3460b523d9a02495d695f30.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD59
-rw-r--r--wxlua.install12
4 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2f67ccc10ba6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = wxlua-svn
+ pkgdesc = WxLua - SVN version
+ pkgver = 248
+ pkgrel = 1
+ url = http://wxlua.sourceforge.net
+ install = wxlua.install
+ arch = i686
+ arch = x86_64
+ license = custom:wxWindows
+ makedepends = subversion
+ makedepends = cmake
+ depends = desktop-file-utils
+ depends = wxgtk
+ depends = webkitgtk2
+ provides = wxlua
+ provides = wxstedit
+ conflicts = wxlua
+ conflicts = wxstedit
+ source = wxlua::svn+http://svn.code.sf.net/p/wxlua/svn/trunk
+ md5sums = SKIP
+
+pkgname = wxlua-svn
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cbabbde4c3c4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+# ignore everything
+*.pkg.tar
+*.src.tar.gz
+*.zip \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f93ca9c16545
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Martin Minka <https://github.com/bigm>
+# Contributor: migerh <https://github.com/migerh>
+# Submitter: hollunder <murks at tuxfamily dot org>
+
+pkgname=wxlua-svn
+pkgver=248
+pkgrel=1
+pkgdesc="WxLua - SVN version"
+arch=('i686' 'x86_64')
+url="http://wxlua.sourceforge.net"
+license=('custom:wxWindows')
+depends=('desktop-file-utils' 'wxgtk' 'webkitgtk2')
+makedepends=('subversion' 'cmake')
+provides=('wxlua' 'wxstedit')
+conflicts=('wxlua' 'wxstedit')
+install="wxlua.install"
+source="wxlua::svn+http://svn.code.sf.net/p/wxlua/svn/trunk"
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/wxlua/wxLua/"
+
+ # wxstedit doc folder fix
+ sed -i 's|doc/|share/&|' modules/wxstedit/CMakeLists.txt
+
+ cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config \
+ -DwxLua_LUA_INCLUDE_DIR=/usr/include/lua5.2 \
+ -DwxLua_LUA_LIBRARY=/usr/lib/liblua.so.5.2 \
+ -DwxLua_LUA_LIBRARY_USE_BUILTIN=0 \
+ -DwxLua_LUA_LIBRARY_VERSION=5.2 \
+ -DBUILD_SHARED_LIBS=TRUE
+ make
+}
+
+package() {
+ cd "$srcdir/wxlua/wxLua/build"
+ make DESTDIR="$pkgdir/" install
+
+ # mv lua module
+ install -d "$pkgdir/usr/lib/lua/5.2"
+ mv "$pkgdir/usr/lib/libwx.so" "$pkgdir/usr/lib/lua/5.2/wx.so"
+
+ # desktop file
+ install -Dm644 ../distrib/autopackage/wxlua.desktop \
+ "$pkgdir/usr/share/applications/wxlua.desktop"
+
+ # mime file
+ install -Dm644 ../distrib/autopackage/wxlua.xml \
+ "$pkgdir/usr/share/mime/packages/wxlua.xml"
+
+ # license
+ install -Dm 644 ../docs/licence.txt \
+ "$pkgdir/usr/share/licenses/wxlua/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: \ No newline at end of file
diff --git a/wxlua.install b/wxlua.install
new file mode 100644
index 000000000000..32bd4537c6f5
--- /dev/null
+++ b/wxlua.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-desktop-database -q
+ update-mime-database usr/share/mime
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+} \ No newline at end of file