summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2022-04-01 20:53:01 +0200
committerAntonio Rojas2022-04-01 20:53:01 +0200
commita0af4eaa07d3f0c850211453392abc21dc1144e2 (patch)
tree92ef74439d3617d796a48aa6728e5ae08adbffd3
downloadaur-a0af4eaa07d3f0c850211453392abc21dc1144e2.tar.gz
import from community
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b8d87c4da30d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = wxmaxima
+ pkgdesc = A wxWidgets GUI for the computer algebra system Maxima
+ pkgver = 22.03.0
+ pkgrel = 1
+ url = https://wxmaxima-developers.github.io/wxmaxima/
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ depends = maxima
+ depends = wxgtk3
+ source = https://github.com/wxMaxima-developers/wxmaxima/archive/Version-22.03.0/wxmaxima-22.03.0.tar.gz
+ sha256sums = 2192f804588511e9a796ad0b677e6f4721bb2cf2a52766f3d47f4528ad0ce0a4
+
+pkgname = wxmaxima
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7a6b989da683
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Ronald van Haren <ronald.archlinux.org>
+# Contributor: Angelo Theodorou <encelo@users.sourceforge.net>
+# Contributor: Vinay S Shastry <vinayshastry@gmail.com>
+
+pkgname=wxmaxima
+pkgver=22.03.0
+pkgrel=1
+pkgdesc="A wxWidgets GUI for the computer algebra system Maxima"
+arch=('x86_64')
+url="https://wxmaxima-developers.github.io/wxmaxima/"
+license=('GPL2')
+depends=('maxima' 'wxgtk3')
+makedepends=('cmake')
+source=(https://github.com/wxMaxima-developers/wxmaxima/archive/Version-$pkgver/$pkgname-$pkgver.tar.gz)
+sha256sums=('2192f804588511e9a796ad0b677e6f4721bb2cf2a52766f3d47f4528ad0ce0a4')
+
+build() {
+ cmake -B build -S ${pkgname}-Version-${pkgver} \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-gtk3
+ cmake --build build
+}
+
+#check() {
+# cd ${pkgname}-Version-${pkgver}
+# ./src/wxmaxima test/testbench_simple.wxmx
+#}
+
+package() {
+ DESTDIR="${pkgdir}" cmake --install build
+}