summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2017-07-12 09:17:56 +0200
committerhaawda2017-07-12 09:17:56 +0200
commitc790e1766a5217715643ad8f79ce17dedfef0e2c (patch)
tree997cc4f7637dd283377c6c43b959912ed6a98ebf
parent619753308d84939f2dbd2173217b95ac2952ea0f (diff)
downloadaur-c790e1766a5217715643ad8f79ce17dedfef0e2c.tar.gz
switch to cmake
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD17
2 files changed, 9 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 047678199cd0..1a6718be5d76 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Mon Jul 3 23:38:33 UTC 2017
pkgbase = wxmaxima-git
pkgdesc = A document based interface for the computer algebra system Maxima.
- pkgver = r4695.be4a20c2
+ pkgver = r4748.1e2bafbe
pkgrel = 1
url = http://andrejv.github.io/wxmaxima/index.html
arch = i686
@@ -10,6 +8,7 @@ pkgbase = wxmaxima-git
license = GPL2
makedepends = git
makedepends = texi2html
+ makedepends = cmake
depends = maxima
depends = wxgtk
provides = wxmaxima
diff --git a/PKGBUILD b/PKGBUILD
index a8d1c7f8571b..7b841d70edc9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=wxmaxima-git
-pkgver=r4695.be4a20c2
+pkgver=r4748.1e2bafbe
pkgrel=1
pkgdesc="A document based interface for the computer algebra system Maxima."
arch=('i686' 'x86_64')
url="http://andrejv.github.io/wxmaxima/index.html"
license=('GPL2')
depends=('maxima' 'wxgtk')
-makedepends=('git' 'texi2html')
+makedepends=('git' 'texi2html' 'cmake')
conflicts=('wxmaxima')
provides=('wxmaxima')
source=("git+https://github.com/andrejv/wxmaxima.git")
@@ -21,16 +21,13 @@ pkgver() {
build() {
cd "$srcdir/wxmaxima"
- export WX_CONFIG_PATH=/usr/bin/wx-config
- export CXXFLAGS+=" -fno-delete-null-pointer-checks"
- LANG=C
- ./bootstrap
- ./configure --with-wx-config=/usr/bin/wx-config --prefix=/usr
- make
- make allmo
+ [ -d build ] || mkdir build
+ cd build
+ cmake ..
+ cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr --build .
}
package() {
- cd "$srcdir/wxmaxima"
+ cd "$srcdir/wxmaxima/build"
make DESTDIR="$pkgdir" install
}