summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJingbei Li2021-02-22 15:40:17 +0800
committerJingbei Li2021-02-22 15:42:36 +0800
commit223889431e05c303b9e5b9220e721b19b150eca3 (patch)
tree267609c906b338619b9cf795d4e1d61d5990f347
parent8498ff6ec459c2ee02f0e26d4b2629d9e58ed037 (diff)
downloadaur-223889431e05c303b9e5b9220e721b19b150eca3.tar.gz
fixed build for wxgtk2
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f8d075f18865..b0e7552a4608 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = wxmedit
pkgdesc = Cross-platform Text/Hex Editor, a fork of MadEdit with bug fixes and improvements
pkgver = 3.1_FIX1
- pkgrel = 2
+ pkgrel = 3
url = https://wxmedit.github.io/
arch = i686
arch = x86_64
license = GPL
makedepends = boost
depends = curl
- depends = wxgtk
+ depends = wxgtk2
source = https://github.com/hltj/wxMEdit/archive/3.1_FIX1.tar.gz
sha256sums = 51dd81ddd44c83017d2e54f8b0a11a50e56075e8edc01d738865478fdddd8017
diff --git a/PKGBUILD b/PKGBUILD
index 0c2a43340e33..ee041a6b6728 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
pkgname=wxmedit
pkgver=3.1_FIX1
-pkgrel=2
+pkgrel=3
pkgdesc="Cross-platform Text/Hex Editor, a fork of MadEdit with bug fixes and improvements"
arch=("i686" "x86_64")
url="https://wxmedit.github.io/"
license=('GPL')
-depends=('curl' 'wxgtk')
+depends=('curl' 'wxgtk2')
makedepends=('boost')
source=("https://github.com/hltj/wxMEdit/archive/$pkgver.tar.gz")
sha256sums=('51dd81ddd44c83017d2e54f8b0a11a50e56075e8edc01d738865478fdddd8017')
@@ -25,7 +25,7 @@ build() {
sed 's/Locale/icu::Locale/g' -i src/wxmedit/wxm_lines.cpp src/wxmedit/wxmedit.cpp
./configure --prefix=/usr --with-wx-config=/usr/bin/wx-config
- make
+ make CXXFLAGS="-DU_DEFINE_FALSE_AND_TRUE=1 -I/usr/include/wx-3.0 -I/usr/lib/wx/include/gtk2-unicode-3.0"
}
package() {