summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Bruguera2022-01-20 00:52:30 +0100
committerJoan Bruguera2022-01-20 00:52:30 +0100
commit8a763cbcfbccb2c7850889dfe11805c23f204dd2 (patch)
tree5c749124b8e82851ef8a113dba6ebe017e2d5daa
parent821bfe19fe885e7b14c535c5a3c1273d0bf6dabd (diff)
downloadaur-8a763cbcfbccb2c7850889dfe11805c23f204dd2.tar.gz
Update to 4.10.10.20220119.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
-rw-r--r--wxparaver-Build-fix-for-GCC-11-invocable-as-const.patch13
3 files changed, 13 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59f641d7c7ae..8e939cade6cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wxparaver
pkgdesc = Expressive powerful and flexible trace visualizer for post-mortem trace analysis (from BSC).
- pkgver = 4.9.2.20210302
- pkgrel = 2
+ pkgver = 4.10.0.20220119
+ pkgrel = 1
url = https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools
arch = i686
arch = x86_64
@@ -11,11 +11,9 @@ pkgbase = wxparaver
depends = boost
depends = libxml2
depends = zlib
- source = https://ftp.tools.bsc.es/wxparaver/wxparaver-4.9.2-src.tar.bz2
- source = wxparaver-Build-fix-for-GCC-11-invocable-as-const.patch
+ source = https://ftp.tools.bsc.es/wxparaver/wxparaver-4.10.0-src.tar.bz2
source = wxParaver.desktop
- sha512sums = f1fbe6dbd467f38a1d50bd8108ab2174128c337206b304644f57d966d1d67b7e159a60756dce0976bdaabe10170d7862eb2bfdf10437f5d8ef599066f2fad152
- sha512sums = a42b6481594cbab6bf4018f09bb83578cfd2fb06ad80766ece509fd48b0af76f77fd9b4b1d15129b7d1fe9b15c53e1efaea1e47bb7e76c1442f8089c0e0904b3
+ sha512sums = 6a3e74326eb93ba99af02d134611eb60a630c20a713d5767f12a623777b4041306369636279a2f9592297866c9ea7cda070a075187136e7f8a53a90bc41ad054
sha512sums = f1b000ea660765bbd454d9ae54d360233389121e54f8bcab241420b42aefa4f679735500efd43afdcd932f3a7bd339f00ff299f755a62163c1c3e34bd6920f6e
pkgname = wxparaver
diff --git a/PKGBUILD b/PKGBUILD
index 675eaec9e464..b8daf6609046 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,27 @@
# Maintainer: Joan Bruguera Micó <joanbrugueram@gmail.com>
pkgname='wxparaver'
pkgdesc='Expressive powerful and flexible trace visualizer for post-mortem trace analysis (from BSC).'
-pkgver='4.9.2.20210302'
-pkgrel='2'
+pkgver='4.10.0.20220119'
+pkgrel='1'
arch=('i686' 'x86_64')
url='https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools'
license=('LGPL2.1')
depends=(wxgtk3 webkit2gtk boost libxml2 zlib)
source=("https://ftp.tools.bsc.es/$pkgname/$pkgname-${pkgver%.*}-src.tar.bz2"
- "wxparaver-Build-fix-for-GCC-11-invocable-as-const.patch"
"wxParaver.desktop")
-sha512sums=(f1fbe6dbd467f38a1d50bd8108ab2174128c337206b304644f57d966d1d67b7e159a60756dce0976bdaabe10170d7862eb2bfdf10437f5d8ef599066f2fad152
- a42b6481594cbab6bf4018f09bb83578cfd2fb06ad80766ece509fd48b0af76f77fd9b4b1d15129b7d1fe9b15c53e1efaea1e47bb7e76c1442f8089c0e0904b3
+sha512sums=(6a3e74326eb93ba99af02d134611eb60a630c20a713d5767f12a623777b4041306369636279a2f9592297866c9ea7cda070a075187136e7f8a53a90bc41ad054
f1b000ea660765bbd454d9ae54d360233389121e54f8bcab241420b42aefa4f679735500efd43afdcd932f3a7bd339f00ff299f755a62163c1c3e34bd6920f6e)
prepare() {
cd "$srcdir/$pkgname-${pkgver%.*}"
- # Fix build for GCC 11
- patch -Np1 -i "${srcdir}/wxparaver-Build-fix-for-GCC-11-invocable-as-const.patch"
-
# WORKAROUND: By default, it seems that the wxParaver depends on an existing -kernel/-api installation
+ # We want to use the ones we just built, so replace the references to point to them instead
cd src/wxparaver
- sed -i 's|-lparaver-kernel -lparaver-api|-L../../paraver-kernel/src/.libs -L../../paraver-kernel/api/.libs -lparaver-kernel -lparaver-api|g' src/Makefile.am
- sed -i 's|^wxparaver_bin_CXXFLAGS =.*|& -I../../paraver-kernel -I../../paraver-kernel/api|' src/Makefile.am
+ sed -i \
+ -e 's|-lparaver-api -lparaver-kernel|-L../../paraver-kernel/src/.libs -L../../paraver-kernel/api/.libs -lparaver-api -lparaver-kernel|g' \
+ -e '$awxparaver_bin_CXXFLAGS = @CXXFLAGS@ -I../../paraver-kernel -I../../paraver-kernel/api' \
+ src/Makefile.am
# shellcheck disable=SC2016
sed -i 's| -L$PARAVER_LIBDIR||g' configure.ac
@@ -49,4 +47,4 @@ package() {
# Create a shortcut to execute the application easily from the user's desktop environment
mkdir -p "$pkgdir/usr/share/applications"
install -o root -g root -m 644 "$srcdir/wxParaver.desktop" "$pkgdir/usr/share/applications/wxParaver.desktop"
-} \ No newline at end of file
+}
diff --git a/wxparaver-Build-fix-for-GCC-11-invocable-as-const.patch b/wxparaver-Build-fix-for-GCC-11-invocable-as-const.patch
deleted file mode 100644
index 4ee8c3c90cb8..000000000000
--- a/wxparaver-Build-fix-for-GCC-11-invocable-as-const.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/api/recordlist.h b/api/recordlist.h
-index 892ae6c..31e0c20 100644
---- a/src/paraver-kernel/api/recordlist.h
-+++ b/src/paraver-kernel/api/recordlist.h
-@@ -142,7 +142,7 @@ private:
- // r1 is less than r2?
- struct ltrecord
- {
-- bool operator()( const RLRecord& r1, const RLRecord& r2 )
-+ bool operator()( const RLRecord& r1, const RLRecord& r2 ) const
- {
- if ( r1.getTime() < r2.getTime() )
- return true;