summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederic Van Assche2018-03-03 17:42:59 +0100
committerFrederic Van Assche2018-03-03 17:42:59 +0100
commit255eb2d552946177721bdcbbc8e91ecedcb11cd5 (patch)
tree459435f5ea5f981e8793a1a186285903d3a8b2d9
parent71598657e970a589b456c10ca3356c226673e294 (diff)
downloadaur-255eb2d552946177721bdcbbc8e91ecedcb11cd5.tar.gz
Use github upstream instead of sourceforge upstream
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 741ab8fc8022..11fce662146f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,9 +11,9 @@ pkgbase = wxpython-gtk2
depends = python2
provides = wxpython
conflicts = wxpython
- source = https://downloads.sourceforge.net/wxpython/wxPython-src-3.0.2.0.tar.bz2
+ source = https://github.com/wxWidgets/wxPython/archive/wxPy-3.0.2.0.tar.gz
source = fix-plot.patch
- sha256sums = d54129e5fbea4fb8091c87b2980760b72c22a386cb3b9dd2eebc928ef5e8df61
+ sha256sums = b068d76e9773c5b0cb0620a66827fca35b8ab9364a2fc8b865ef125720b26afc
sha256sums = 2d8b2bdbf55172738c7bf93955e552aac61842800c3b8b0a2e1f07f4314abc65
pkgname = wxpython-gtk2
diff --git a/PKGBUILD b/PKGBUILD
index bab7cb7a3a60..1d286fc79277 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,21 +12,21 @@ depends=('wxgtk2' 'python2')
makedepends=('mesa' 'glu')
provides=('wxpython')
conflicts=('wxpython')
-source=("https://downloads.sourceforge.net/wxpython/wxPython-src-${pkgver}.tar.bz2"
+source=("https://github.com/wxWidgets/wxPython/archive/wxPy-${pkgver}.tar.gz"
"fix-plot.patch")
-sha256sums=('d54129e5fbea4fb8091c87b2980760b72c22a386cb3b9dd2eebc928ef5e8df61'
+sha256sums=('b068d76e9773c5b0cb0620a66827fca35b8ab9364a2fc8b865ef125720b26afc'
'2d8b2bdbf55172738c7bf93955e552aac61842800c3b8b0a2e1f07f4314abc65')
prepare() {
find . -type f -exec sed -i 's/env python/env python2/' {} \;
- cd wxPython-src-${pkgver}/wxPython
+ cd wxPython-wxPy-${pkgver}/wxPython
# Fix plot library (FS#42807)
patch -Np1 -i ../../fix-plot.patch
}
build() {
- cd wxPython-src-${pkgver}
+ cd wxPython-wxPy-${pkgver}
./configure \
--prefix=/usr \
--libdir=/usr/lib \
@@ -43,11 +43,12 @@ build() {
--with-libtiff=sys
# --with-wx-config=/usr/bin/wx-config-gtk3
cd wxPython
+ bin/subrepos-make
python2 setup.py WXPORT=gtk2 UNICODE=1 build
}
package() {
- cd wxPython-src-${pkgver}/wxPython
+ cd wxPython-wxPy-${pkgver}/wxPython
python2 setup.py WXPORT=gtk2 UNICODE=1 install --root="${pkgdir}"
install -Dm644 ../docs/licence.txt "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
}