summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 21:13:46 +0200
committersl1pkn072015-06-08 21:13:46 +0200
commit570418ace9b89f28e39c4a47a402c9c340fbba88 (patch)
tree629e89d09f39127c72a243d4fbe288b46017d215
downloadaur-570418ace9b89f28e39c4a47a402c9c340fbba88.tar.gz
Initial commit
-rw-r--r--.SRCINFO33
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD64
3 files changed, 101 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b817dfe8c8c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = wxpython-light
+ pkgdesc = A wxWidgets GUI toolkit for Python (GNOME/GStreamer free!)
+ pkgver = 3.0.2.0
+ pkgrel = 1
+ url = http://www.wxpython.org
+ arch = i686
+ arch = x86_64
+ license = custom:wxWindows
+ makedepends = git
+ makedepends = svn
+ makedepends = mesa
+ depends = wxgtk-light
+ depends = python2-opengl
+ depends = python2-cairo
+ provides = wxpython
+ conflicts = wxpython
+ source = git+https://github.com/wxWidgets/wxPython.git#tag=wxPy-3.0.2.0
+ source = svn+http://svn.wxwidgets.org/svn/wx/wxPython/3rdParty/AGW/agw
+ source = svn+http://svn.wxwidgets.org/svn/wx/wxPython/3rdParty/FloatCanvas/floatcanvas
+ source = svn+http://svn.wxwidgets.org/svn/wx/wxPython/3rdParty/PDFViewer/pdfviewer
+ source = svn+http://svn.wxwidgets.org/svn/wx/wxPython/3rdParty/PubSub/pubsub
+ source = svn+http://svn.wxwidgets.org/svn/wx/wxPython/3rdParty/XRCed
+ source = svn+http://svn.wxwidgets.org/svn/wx/wxPython/3rdParty/Editra
+ sha1sums = SKIP
+ sha1sums = SKIP
+ sha1sums = SKIP
+ sha1sums = SKIP
+ sha1sums = SKIP
+ sha1sums = SKIP
+ sha1sums = SKIP
+
+pkgname = wxpython-light
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c2d77004da2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Contributor: Eric BĂ©langer <eric@archlinux.org>
+
+pkgname=wxpython-light
+pkgver=3.0.2.0
+pkgrel=1
+pkgdesc="A wxWidgets GUI toolkit for Python (GNOME/GStreamer free!)"
+arch=('i686' 'x86_64')
+license=('custom:wxWindows')
+url="http://www.wxpython.org"
+depends=('wxgtk-light' 'python2-opengl' 'python2-cairo')
+makedepends=('git' 'svn' 'mesa')
+provides=('wxpython')
+conflicts=('wxpython')
+source=("git+https://github.com/wxWidgets/wxPython.git#tag=wxPy-${pkgver}"
+ 'svn+http://svn.wxwidgets.org/svn/wx/wxPython/3rdParty/AGW/agw'
+ 'svn+http://svn.wxwidgets.org/svn/wx/wxPython/3rdParty/FloatCanvas/floatcanvas'
+ 'svn+http://svn.wxwidgets.org/svn/wx/wxPython/3rdParty/PDFViewer/pdfviewer'
+ 'svn+http://svn.wxwidgets.org/svn/wx/wxPython/3rdParty/PubSub/pubsub'
+ 'svn+http://svn.wxwidgets.org/svn/wx/wxPython/3rdParty/XRCed'
+ 'svn+http://svn.wxwidgets.org/svn/wx/wxPython/3rdParty/Editra')
+sha1sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+
+prepare() {
+ cd wxPython/wxPython/wx/lib
+ cp -R ${srcdir}/agw .
+ cp -R ${srcdir}/floatcanvas .
+ cp -R ${srcdir}/pdfviewer .
+ cp -R ${srcdir}/pubsub .
+ cd ../tools
+ cp -R ${srcdir}/XRCed .
+ cp -R ${srcdir}/Editra .
+ sed 's|sys.exit(1)||' -i "Editra/setup.py"
+ cd "${srcdir}"
+ # Make sure really use python2
+ find . -type f -exec sed -i 's/env python/env python2/' {} \;
+}
+
+build() {
+ cd wxPython
+ ./configure --prefix=/usr --libdir=/usr/lib \
+ --with-{gtk=2,libjpeg=sys,libpng=sys,libtiff=sys,libxpm=sys,regex=builtin,opengl,sdl} \
+ --without-{libnotify,gnomevfs,gnomeprint} \
+ --enable-{graphics_ctx,unicode} \
+ --disable-{mediactrl,precomp-headers,webview}
+ cd wxPython
+ python2 setup.py WXPORT=gtk2 UNICODE=1 BUILD_GLCANVAS=1 build
+}
+
+package() {
+ cd wxPython/wxPython
+ python2 setup.py WXPORT=gtk2 UNICODE=1 BUILD_GLCANVAS=1 install --root="${pkgdir}"
+ install -D -m644 ../docs/licence.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ cd wx/tools/Editra
+ python2 setup.py install --root="${pkgdir}"
+ rm -r "${pkgdir}/usr/lib/python2.7/site-packages/wx-3.0-gtk2/wx/tools/Editra"
+}