summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortdy2017-02-06 14:21:13 -0600
committertdy2017-02-06 14:21:13 -0600
commit66ebda698eb0312db9ac2fe586e7edfabb479932 (patch)
tree7bcc6b7953299835a0e967ac0a8cffc0636c8a8e
downloadaur-66ebda698eb0312db9ac2fe586e7edfabb479932.tar.gz
Migrate from [extra]
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD53
-rw-r--r--wxGTK-collision.patch82
-rw-r--r--wxpython-cairo.patch52
-rw-r--r--wxpython-fpb_default_style.patch18
-rw-r--r--wxpython2.8.install11
6 files changed, 241 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..129203a217aa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = wxpython2.8
+ pkgdesc = A wxWidgets GUI toolkit for Python
+ pkgver = 2.8.12.1
+ pkgrel = 3
+ url = http://www.wxpython.org
+ install = wxpython2.8.install
+ arch = i686
+ arch = x86_64
+ license = custom:wxWindows
+ makedepends = mesa
+ makedepends = glu
+ depends = wxgtk2.8
+ depends = wxpython
+ depends = python2
+ source = http://downloads.sourceforge.net/wxpython/wxPython-src-2.8.12.1.tar.bz2
+ source = wxGTK-collision.patch
+ source = wxpython-cairo.patch
+ source = wxpython-fpb_default_style.patch
+ sha256sums = 1f3f153d9f1504c6ce2d2c4b23e940b8f58b81f4cba35cda1a5bb31142243cd0
+ sha256sums = e5e2af0d0649ddfcb401b4dd32362b41dc1b49fdb4d3974b39700f7d811f09f3
+ sha256sums = b2c8870336c4215646c760f9ae9c2a5ede9c9e4d6cb29f1a5763a4240db87f74
+ sha256sums = 57729f843d589c4890fd5f2fddb48e1d2f4a09d609188b4a744554daf0b2b246
+
+pkgname = wxpython2.8
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9ef6ea73964
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: archlinux.info:tdy
+# Contributor: Laurent Carlier <lordheavym@gmail.com>
+
+pkgname=wxpython2.8
+pkgver=2.8.12.1
+pkgrel=3
+pkgdesc="A wxWidgets GUI toolkit for Python"
+arch=(i686 x86_64)
+license=(custom:wxWindows)
+url=http://www.wxpython.org
+depends=(wxgtk2.8 wxpython python2)
+makedepends=(mesa glu)
+install=$pkgname.install
+source=(http://downloads.sourceforge.net/wxpython/wxPython-src-$pkgver.tar.bz2
+ wxGTK-collision.patch
+ wxpython-cairo.patch
+ wxpython-fpb_default_style.patch)
+sha256sums=(1f3f153d9f1504c6ce2d2c4b23e940b8f58b81f4cba35cda1a5bb31142243cd0
+ e5e2af0d0649ddfcb401b4dd32362b41dc1b49fdb4d3974b39700f7d811f09f3
+ b2c8870336c4215646c760f9ae9c2a5ede9c9e4d6cb29f1a5763a4240db87f74
+ 57729f843d589c4890fd5f2fddb48e1d2f4a09d609188b4a744554daf0b2b246)
+
+prepare() {
+ cd wxPython-src-$pkgver
+ patch -Np1 -i ../wxGTK-collision.patch
+ patch -Np0 -i ../../wxpython-cairo.patch
+ patch -Np0 -i ../../wxpython-fpb_default_style.patch
+ find . -type f -exec sed -i 's/env python/&2/' '{}' \;
+
+ export WXPORT=gtk2
+ export UNICODE=1
+ export WX_CONFIG=/usr/bin/wx-config-2.8
+}
+
+build() {
+ cd wxPython-src-$pkgver
+ ./configure --prefix=/usr --libdir=/usr/lib --with-gtk=2 --with-opengl \
+ --enable-unicode --enable-graphics_ctx --disable-optimize --enable-mediactrl \
+ --with-regex=sys --with-libpng=sys --with-libxpm=sys --with-libjpeg=sys \
+ --with-libtiff=sys --disable-precomp-headers
+
+ cd wxPython
+ python2 setup.py build
+}
+
+package() {
+ cd wxPython-src-$pkgver/wxPython
+ python2 setup.py install --root="$pkgdir"
+ install ../docs/licence.txt -m 644 -Dt "$pkgdir"/usr/share/licenses/$pkgname/
+
+ rm -rf "$pkgdir"/usr/bin
+ rm "$pkgdir"/usr/lib/python2.7/site-packages/{wx.pth,wxversion.py*}
+}
diff --git a/wxGTK-collision.patch b/wxGTK-collision.patch
new file mode 100644
index 000000000000..f6e02d87634b
--- /dev/null
+++ b/wxGTK-collision.patch
@@ -0,0 +1,82 @@
+diff -Naur wxPython-src-2.8.12.1.orig/build/bakefiles/wx.bkl wxPython-src-2.8.12.1/build/bakefiles/wx.bkl
+--- wxPython-src-2.8.12.1.orig/build/bakefiles/wx.bkl 2014-01-04 22:28:16.491774907 -0500
++++ wxPython-src-2.8.12.1/build/bakefiles/wx.bkl 2014-01-04 22:37:39.610020870 -0500
+@@ -128,7 +128,7 @@
+ <using module="gettext"/>
+ <gettext-catalogs id="locale">
+ <srcdir>$(SRCDIR)/locale</srcdir>
+- <catalog-name>wxstd</catalog-name>
++ <catalog-name>wxstd$(WX_RELEASE_NODOT)</catalog-name>
+ <linguas>
+ ca cs da de el es fi fr hu id it ja nl pl ru sl sv tr uk
+ zh zh_CN zh_TW
+diff -Naur wxPython-src-2.8.12.1.orig/Makefile.in wxPython-src-2.8.12.1/Makefile.in
+--- wxPython-src-2.8.12.1.orig/Makefile.in 2014-01-04 22:28:16.545107766 -0500
++++ wxPython-src-2.8.12.1/Makefile.in 2014-01-04 22:40:27.191813403 -0500
+@@ -11695,10 +11695,11 @@
+ all: $(__wxregex___depname) $(__wxzlib___depname) $(__wxpng___depname) $(__wxjpeg___depname) $(__wxtiff___depname) $(__wxodbc___depname) $(__wxexpat___depname) $(__monodll___depname) $(__monolib___depname) $(__basedll___depname) $(__baselib___depname) $(__netdll___depname) $(__netlib___depname) $(__coredll___depname) $(__corelib___depname) $(__advdll___depname) $(__advlib___depname) $(__mediadll___depname) $(__medialib___depname) $(__odbcdll___depname) $(__odbclib___depname) $(__dbgriddll___depname) $(__dbgridlib___depname) $(__htmldll___depname) $(__htmllib___depname) $(__qadll___depname) $(__qalib___depname) $(__xmldll___depname) $(__xmllib___depname) $(__xrcdll___depname) $(__xrclib___depname) $(__auidll___depname) $(__auilib___depname) $(__richtextdll___depname) $(__richtextlib___depname) $(__gldll___depname) $(__gllib___depname) $(__sound_sdl___depname) $(__wxrc___depname) $(__cocoa_res___depname)
+
+ install: $(__install_wxregex___depname) $(__install_wxzlib___depname) $(__install_wxpng___depname) $(__install_wxjpeg___depname) $(__install_wxtiff___depname) $(__install_wxodbc___depname) $(__install_wxexpat___depname) $(__install_monodll___depname) $(__install_monolib___depname) $(__install_basedll___depname) $(__install_baselib___depname) $(__install_netdll___depname) $(__install_netlib___depname) $(__install_coredll___depname) $(__install_corelib___depname) $(__install_advdll___depname) $(__install_advlib___depname) $(__install_mediadll___depname) $(__install_medialib___depname) $(__install_odbcdll___depname) $(__install_odbclib___depname) $(__install_dbgriddll___depname) $(__install_dbgridlib___depname) $(__install_htmldll___depname) $(__install_htmllib___depname) $(__install_qadll___depname) $(__install_qalib___depname) $(__install_xmldll___depname) $(__install_xmllib___depname) $(__install_xrcdll___depname) $(__install_xrclib___depname) $(__install_auidll___depname) $(__install_auilib___depname) $(__install_richtextdll___depname) $(__install_richtextlib___depname) $(__install_gldll___depname) $(__install_gllib___depname) $(__install_sound_sdl___depname) $(__install_wxrc___depname) install-wxconfig locale_install locale_msw_install $(__cocoa_res_install___depname)
+- $(INSTALL_DIR) $(DESTDIR)$(datadir)/aclocal
+- (cd $(srcdir) ; $(INSTALL_DATA) wxwin.m4 $(DESTDIR)$(datadir)/aclocal)
++
+ $(INSTALL_DIR) $(DESTDIR)$(datadir)/bakefile/presets
+- (cd $(srcdir)/build/bakefiles/wxpresets/presets ; $(INSTALL_DATA) wx.bkl wx_unix.bkl wx_win32.bkl $(DESTDIR)$(datadir)/bakefile/presets)
++ (cd $(srcdir)/build/bakefiles/wxpresets/presets ; \
++ for i in wx.bkl wx_unix.bkl wx_win32.bkl ; do \
++ $(INSTALL_DATA) $$i $(DESTDIR)$(datadir)/bakefile/presets/wx$(WX_RELEASE_NODOT)$${i##wx} ; done)
+ $(INSTALL_DIR) $(DESTDIR)$(libdir)/wx/include/$(TOOLCHAIN_FULLNAME)/wx
+ for f in setup.h $(RCDEFS_H); do \
+ if test ! -d $(DESTDIR)$(libdir)/wx/include/$(TOOLCHAIN_FULLNAME)/wx/`dirname $$f` ; then \
+@@ -12455,7 +12456,8 @@
+ $(INSTALL_DIR) $(DESTDIR)$(bindir)
+ $(INSTALL_DIR) $(DESTDIR)$(libdir)/wx/config
+ $(INSTALL_PROGRAM) lib/wx/config/$(TOOLCHAIN_FULLNAME) $(DESTDIR)$(libdir)/wx/config
+- (cd $(DESTDIR)$(bindir) && rm -f wx-config && $(LN_S) $(libdir)/wx/config/$(TOOLCHAIN_FULLNAME) wx-config)
++ (cd $(DESTDIR)$(bindir) && rm -f wx-config-$(WX_RELEASE) \
++ && $(LN_S) ../lib/wx/config/$(TOOLCHAIN_FULLNAME) wx-config-$(WX_RELEASE))
+
+ locale_install:
+ $(INSTALL_DIR) $(DESTDIR)$(datadir)/locale
+@@ -12463,7 +12465,8 @@
+ $(INSTALL_DIR) $(DESTDIR)$(datadir)/locale/$$l ; \
+ $(INSTALL_DIR) $(DESTDIR)$(datadir)/locale/$$l/LC_MESSAGES ; \
+ if test -f $(srcdir)/locale/$$l.mo ; then \
+- $(INSTALL_DATA) $(srcdir)/locale/$$l.mo $(DESTDIR)$(datadir)/locale/$$l/LC_MESSAGES/wxstd.mo ; \
++ $(INSTALL_DATA) $(srcdir)/locale/$$l.mo \
++ $(DESTDIR)$(datadir)/locale/$$l/LC_MESSAGES/wxstd$(WX_RELEASE_NODOT).mo ; \
+ fi ; \
+ done
+
+@@ -12480,7 +12483,7 @@
+ $(INSTALL_DIR) $(DESTDIR)$(datadir)/locale/$$l ; \
+ $(INSTALL_DIR) $(DESTDIR)$(datadir)/locale/$$l/LC_MESSAGES ; \
+ if test -f $(srcdir)/locale/msw/$$l.mo ; then \
+- $(INSTALL_DATA) $(srcdir)/locale/msw/$$l.mo $(DESTDIR)$(datadir)/locale/$$l/LC_MESSAGES/wxmsw.mo ; \
++ $(INSTALL_DATA) $(srcdir)/locale/msw/$$l.mo $(DESTDIR)$(datadir)/locale/$$l/LC_MESSAGES/wxmsw$(WX_RELEASE_NODOT).mo ; \
+ fi ; \
+ done
+
+diff -Naur wxPython-src-2.8.12.1.orig/src/common/intl.cpp wxPython-src-2.8.12.1/src/common/intl.cpp
+--- wxPython-src-2.8.12.1.orig/src/common/intl.cpp 2014-01-04 22:28:16.675106608 -0500
++++ wxPython-src-2.8.12.1/src/common/intl.cpp 2014-01-04 22:47:49.523526232 -0500
+@@ -1597,7 +1597,7 @@
+ bool bOk = true;
+ if ( bLoadDefault )
+ {
+- bOk = AddCatalog(wxT("wxstd"));
++ bOk = AddCatalog(wxT("wxstd" wxSTRINGIZE(wxMAJOR_VERSION) wxSTRINGIZE(wxMINOR_VERSION)));
+
+ // there may be a catalog with toolkit specific overrides, it is not
+ // an error if this does not exist
+diff -Naur wxPython-src-2.8.12.1.orig/utils/wxrc/Makefile.in wxPython-src-2.8.12.1/utils/wxrc/Makefile.in
+--- wxPython-src-2.8.12.1.orig/utils/wxrc/Makefile.in 2014-01-04 22:28:16.335109635 -0500
++++ wxPython-src-2.8.12.1/utils/wxrc/Makefile.in 2014-01-04 22:37:34.410068493 -0500
+@@ -120,7 +120,6 @@
+ @COND_USE_XRC_1@ rm -f $(DESTDIR)$(bindir)/wxrc$(EXEEXT) $(DESTDIR)$(bindir)/wxrc-$(WX_RELEASE)
+ @COND_USE_XRC_1@ $(INSTALL_PROGRAM) wxrc$(EXEEXT) $(DESTDIR)$(bindir)
+ @COND_USE_XRC_1@ mv -f $(DESTDIR)$(bindir)/wxrc$(EXEEXT) $(DESTDIR)$(bindir)/wxrc-$(WX_RELEASE)
+-@COND_USE_XRC_1@ (cd $(DESTDIR)$(bindir) && $(LN_S) wxrc-$(WX_RELEASE) wxrc$(EXEEXT))
+
+ @COND_USE_XRC_1@uninstall_wxrc:
+ @COND_USE_XRC_1@ rm -f $(DESTDIR)$(bindir)/wxrc$(EXEEXT)
diff --git a/wxpython-cairo.patch b/wxpython-cairo.patch
new file mode 100644
index 000000000000..53c4d30c5f95
--- /dev/null
+++ b/wxpython-cairo.patch
@@ -0,0 +1,52 @@
+--- wxPython/wx/lib/wxcairo.py 2011/08/25 18:50:02 68894
++++ wxPython/wx/lib/wxcairo.py 2011/09/22 00:30:25 69181
+@@ -401,6 +401,48 @@
+ ctypes.py_object)),
+ ('Check_Status', ctypes.PYFUNCTYPE(ctypes.c_int, ctypes.c_int))]
+
++ # This structure is known good with pycairo 1.10.0. The keep adding stuff
++ # to the middle of the structure instead of only adding to the end!
++ elif cairo.version_info < (1,11):
++ _fields_ = [
++ ('Context_Type', ctypes.py_object),
++ ('Context_FromContext', ctypes.PYFUNCTYPE(ctypes.py_object,
++ ctypes.c_void_p,
++ ctypes.py_object,
++ ctypes.py_object)),
++ ('FontFace_Type', ctypes.py_object),
++ ('ToyFontFace_Type', ctypes.py_object), #** new in 1.8.4
++ ('FontFace_FromFontFace', ctypes.PYFUNCTYPE(ctypes.py_object, ctypes.c_void_p)),
++ ('FontOptions_Type', ctypes.py_object),
++ ('FontOptions_FromFontOptions', ctypes.PYFUNCTYPE(ctypes.py_object, ctypes.c_void_p)),
++ ('Matrix_Type', ctypes.py_object),
++ ('Matrix_FromMatrix', ctypes.PYFUNCTYPE(ctypes.py_object, ctypes.c_void_p)),
++ ('Path_Type', ctypes.py_object),
++ ('Path_FromPath', ctypes.PYFUNCTYPE(ctypes.py_object, ctypes.c_void_p)),
++ ('Pattern_Type', ctypes.py_object),
++ ('SolidPattern_Type', ctypes.py_object),
++ ('SurfacePattern_Type', ctypes.py_object),
++ ('Gradient_Type', ctypes.py_object),
++ ('LinearGradient_Type', ctypes.py_object),
++ ('RadialGradient_Type', ctypes.py_object),
++ ('Pattern_FromPattern', ctypes.PYFUNCTYPE(ctypes.py_object, ctypes.c_void_p,
++ ctypes.py_object)), #** changed in 1.8.4
++ ('ScaledFont_Type', ctypes.py_object),
++ ('ScaledFont_FromScaledFont', ctypes.PYFUNCTYPE(ctypes.py_object, ctypes.c_void_p)),
++ ('Surface_Type', ctypes.py_object),
++ ('ImageSurface_Type', ctypes.py_object),
++ ('PDFSurface_Type', ctypes.py_object),
++ ('PSSurface_Type', ctypes.py_object),
++ ('SVGSurface_Type', ctypes.py_object),
++ ('Win32Surface_Type', ctypes.py_object),
++ ('Win32PrintingSurface_Type', ctypes.py_object),
++ ('XCBSurface_Type', ctypes.py_object),
++ ('XlibSurface_Type', ctypes.py_object),
++ ('Surface_FromSurface', ctypes.PYFUNCTYPE(ctypes.py_object,
++ ctypes.c_void_p,
++ ctypes.py_object)),
++ ('Check_Status', ctypes.PYFUNCTYPE(ctypes.c_int, ctypes.c_int))]
++
+
+ def _loadPycairoAPI():
+ global pycairoAPI
+
diff --git a/wxpython-fpb_default_style.patch b/wxpython-fpb_default_style.patch
new file mode 100644
index 000000000000..eb0768210bd5
--- /dev/null
+++ b/wxpython-fpb_default_style.patch
@@ -0,0 +1,18 @@
+--- wxPython/wx/tools/XRCed/plugins/xh_wxlib.py (revision 50185)
++++ wxPython/wx/tools/XRCed/plugins/xh_wxlib.py (revision 69431)
+@@ -18,5 +18,4 @@
+ self.AddWindowStyles()
+ # Custom styles
+- self.AddStyle('FPB_DEFAULT_STYLE', fpb.FPB_DEFAULT_STYLE)
+ self.AddStyle('FPB_SINGLE_FOLD', fpb.FPB_SINGLE_FOLD)
+ self.AddStyle('FPB_COLLAPSE_TO_BOTTOM', fpb.FPB_COLLAPSE_TO_BOTTOM)
+--- wxPython/wx/tools/XRCed/plugins/wxlib.py (revision 57250)
++++ wxPython/wx/tools/XRCed/plugins/wxlib.py (revision 69431)
+@@ -20,5 +20,5 @@
+ implicit_attributes=['label', 'collapsed'],
+ implicit_params={'collapsed': params.ParamBool})
+-c.addStyles('FPB_DEFAULT_STYLE', 'FPB_SINGLE_FOLD', 'FPB_COLLAPSE_TO_BOTTOM',
++c.addStyles('FPB_SINGLE_FOLD', 'FPB_COLLAPSE_TO_BOTTOM',
+ 'FPB_EXCLUSIVE_FOLD', 'FPB_HORIZONTAL', 'FPB_VERTICAL')
+ component.Manager.register(c)
+
diff --git a/wxpython2.8.install b/wxpython2.8.install
new file mode 100644
index 000000000000..ca3178bce33f
--- /dev/null
+++ b/wxpython2.8.install
@@ -0,0 +1,11 @@
+post_install() {
+ cat <<EOF
+
+ Use this code snippet to force 2.8 usage:
+ import wxversion
+ wxversion.select("2.8")
+
+ http://wiki.wxpython.org/MultiVersionInstalls
+
+EOF
+}