summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072017-05-24 23:18:37 +0200
committersL1pKn072017-05-24 23:18:37 +0200
commit08b9aa939a29d03ac55afa5879cf44491d8dda71 (patch)
treed6952fb36e8f87b40fddb7227d36fdc4d906ee67
parent7bbffb16985e0f13b44b392fc957244f8986cfa7 (diff)
downloadaur-08b9aa939a29d03ac55afa5879cf44491d8dda71.tar.gz
Update to 3.0.3
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD38
2 files changed, 30 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 41a5980ff266..c3630a62d86e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Jul 31 20:45:54 UTC 2016
+# Wed May 24 21:18:26 UTC 2017
pkgbase = wxwidgets-light
pkgdesc = wxWidgets suite for Base and GTK2 and GTK3 toolkits (GNOME/GStreamer free!)
- pkgver = 3.0.2
- pkgrel = 7
+ pkgver = 3.0.3
+ pkgrel = 1
url = http://wxwidgets.org
arch = i686
arch = x86_64
@@ -15,21 +15,21 @@ pkgbase = wxwidgets-light
makedepends = gtk3
makedepends = libsm
makedepends = libgl
- source = wxwidgets::git+https://github.com/wxWidgets/wxWidgets.git#tag=v3.0.2
+ source = wxwidgets::git+https://github.com/wxWidgets/wxWidgets.git#tag=v3.0.3
source = config.conf
source = wx-config.sh
source = make-abicheck-non-fatal.patch
- sha1sums = SKIP
- sha1sums = fed3ad06526f2bccd3f3197c2b1fd3e96bf05685
- sha1sums = 47df8d82e6c9671212428ea769ff4a3e3f725917
- sha1sums = dfe38650c655395b90bf082b5734c4093508bfa3
+ sha256sums = SKIP
+ sha256sums = 770b976681e7b5fe513b1b6dcabc1472802eb67fc777a07e903a77772825120f
+ sha256sums = 55a54da8396923f413bdf0c582ade281e014dc6f7ab65854b0f0fe24d4697c2a
+ sha256sums = 46a1bb97d69163547da13d5e23a4c73e68de27ee601da5d2fb5bc5c417931453
pkgname = wxbase-light
pkgdesc = wxWidgets Base (GNOME/GStreamer free!)
depends = wxcommon-light
depends = expat
depends = zlib
- provides = wxbase=3.0.2
+ provides = wxbase=3.0.3
conflicts = wxbase
options = !emptydirs
@@ -40,7 +40,7 @@ pkgname = wxgtk-light
depends = gtk3
depends = libsm
depends = sdl
- provides = wxgtk=3.0.2
+ provides = wxgtk=3.0.3
conflicts = wxgtk
options = !emptydirs
@@ -48,7 +48,7 @@ pkgname = wxcommon-light
pkgdesc = wxWidgets common (GNOME/GStreamer free!)
arch = any
depends = bash
- provides = wxcommon=3.0.2
+ provides = wxcommon=3.0.3
conflicts = wxcommon
options = !emptydirs
backup = etc/wx/config
diff --git a/PKGBUILD b/PKGBUILD
index 77fa6c3058fe..e31469cb8fc3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,12 @@
# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
pkgbase=wxwidgets-light
-pkgname=('wxbase-light' 'wxgtk-light' 'wxcommon-light')
-pkgver=3.0.2
-pkgrel=7
+pkgname=('wxbase-light'
+ 'wxgtk-light'
+ 'wxcommon-light'
+ )
+pkgver=3.0.3
+pkgrel=1
pkgdesc="wxWidgets suite for Base and GTK2 and GTK3 toolkits (GNOME/GStreamer free!)"
arch=('i686' 'x86_64')
url='http://wxwidgets.org'
@@ -21,23 +24,20 @@ source=("wxwidgets::git+https://github.com/wxWidgets/wxWidgets.git#tag=v${pkgver
'wx-config.sh'
'make-abicheck-non-fatal.patch'
)
-sha1sums=('SKIP'
- 'fed3ad06526f2bccd3f3197c2b1fd3e96bf05685'
- '47df8d82e6c9671212428ea769ff4a3e3f725917'
- 'dfe38650c655395b90bf082b5734c4093508bfa3'
- )
+sha256sums=('SKIP'
+ '770b976681e7b5fe513b1b6dcabc1472802eb67fc777a07e903a77772825120f'
+ '55a54da8396923f413bdf0c582ade281e014dc6f7ab65854b0f0fe24d4697c2a'
+ '46a1bb97d69163547da13d5e23a4c73e68de27ee601da5d2fb5bc5c417931453'
+ )
prepare() {
mkdir -p build-{base,gtk{2,3}}
cd wxwidgets
- # Fix build with GCC 6.1.1
- git cherry-pick 73e9e18ea09ffffcaac50237def0d9728a213c02
-
# C++ ABI check is too strict and breaks with GCC 5.1
# https://bugzilla.redhat.com/show_bug.cgi?id=1200611
- patch -Np1 -i ../make-abicheck-non-fatal.patch
+ patch -Np1 -i "${srcdir}/make-abicheck-non-fatal.patch"
}
build() {
@@ -45,7 +45,7 @@ build() {
../wxwidgets/configure \
--prefix=/usr \
--libdir=/usr/lib \
- --with-regex='builtin' \
+ --with-regex=builtin \
--enable-unicode \
--disable-{precomp-headers,gui}
make
@@ -55,9 +55,9 @@ build() {
../wxwidgets/configure \
--prefix=/usr \
--libdir=/usr/lib \
- --with-gtk='2' \
- --with-lib{jpeg,png,tiff,xpm}='sys' \
- --with-regex='builtin' \
+ --with-gtk=2 \
+ --with-lib{jpeg,png,tiff,xpm}=sys \
+ --with-regex=builtin \
--with-{opengl,sdl} \
--enable-{unicode,graphics_ctx} \
--without-{libnotify,gnome{vfs,print}} \
@@ -69,9 +69,9 @@ build() {
../wxwidgets/configure \
--prefix=/usr \
--libdir=/usr/lib \
- --with-gtk='3' \
- --with-lib{jpeg,png,tiff,xpm}='sys' \
- --with-regex='builtin' \
+ --with-gtk=3 \
+ --with-lib{jpeg,png,tiff,xpm}=sys \
+ --with-regex=builtin \
--with-{opengl,sdl} \
--enable-{unicode,graphics_ctx} \
--without-{libnotify,gnome{vfs,print}} \