summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072023-06-14 19:40:51 +0200
committersL1pKn072023-06-14 19:40:51 +0200
commit17e30791d9274da73d3fb0d8654e1baa614465c1 (patch)
tree672ec40f50c1dcfe02b22c452d00d48e7cd0cc89
parentec35f60d4f803c4f0c399bf1e714d1e7c2a88e5f (diff)
downloadaur-17e30791d9274da73d3fb0d8654e1baa614465c1.tar.gz
cosmwtics
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD181
2 files changed, 93 insertions, 93 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0197e7b4a9d2..fd1f926ecc82 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -37,8 +37,6 @@ pkgname = wxwidgets-common-light
conflicts = wxbase-light
conflicts = wxgtk-common
conflicts = wxwidgets-common
- replaces = wxcommon-light
- replaces = wxgtk-common
pkgname = wxwidgets-gtk3-light
pkgdesc = wxWidgets GTK3 Toolkit (GNOME/GStreamer free!)
@@ -55,8 +53,6 @@ pkgname = wxwidgets-gtk3-light
provides = wxgtk3
conflicts = wxwidgets-gtk3
conflicts = wxgtk3
- replaces = wxgtk3-light
- replaces = wxgtk3
pkgname = wxwidgets-qt5-light
pkgdesc = wxWidgets Qt5 Toolkit (GNOME/GStreamer free!)
@@ -66,4 +62,3 @@ pkgname = wxwidgets-qt5-light
depends = libmspack.so
provides = wxwidgets-qt5
provides = wxwidgets
- conflicts = wxwidgets-qt5
diff --git a/PKGBUILD b/PKGBUILD
index a89700f61c03..ded061b6d9d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,41 @@
# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
pkgbase=wxwidgets-light
-pkgname=('wxwidgets-common-light'
- 'wxwidgets-gtk3-light'
-# 'wxwidgets-gtk4-light'
- 'wxwidgets-qt5-light'
- )
+pkgname=(
+ 'wxwidgets-common-light'
+ 'wxwidgets-gtk3-light'
+# 'wxwidgets-gtk4-light'
+ 'wxwidgets-qt5-light'
+)
pkgver=3.2.2.1
pkgrel=3
pkgdesc="wxWidgets suite for Base, Qt5 and GTK3 toolkits (GNOME/GStreamer free!)"
arch=('x86_64')
url='http://wxwidgets.org'
license=('custom:wxWindows')
-makedepends=('git'
- 'cmake'
- 'glu'
- 'webkit2gtk'
- 'gtk3'
-# 'gtk4'
- 'libnotify'
- 'qt5-base'
- 'sdl2'
- 'libmspack'
- 'libsecret'
- 'sh'
- 'gspell'
- )
-source=("wxwidgets::git+https://github.com/wxWidgets/wxWidgets.git#tag=v${pkgver}"
- 'git+https://github.com/wxWidgets/nanosvg.git'
- )
-sha256sums=('SKIP'
- 'SKIP'
- )
+makedepends=(
+ 'git'
+ 'cmake'
+ 'glu'
+ 'webkit2gtk'
+ 'gtk3'
+# 'gtk4'
+ 'libnotify'
+ 'qt5-base'
+ 'sdl2'
+ 'libmspack'
+ 'libsecret'
+ 'sh'
+ 'gspell'
+)
+source=(
+ "wxwidgets::git+https://github.com/wxWidgets/wxWidgets.git#tag=v${pkgver}"
+ 'git+https://github.com/wxWidgets/nanosvg.git'
+)
+sha256sums=(
+ 'SKIP'
+ 'SKIP'
+)
options=('debug')
prepare() {
@@ -146,15 +150,16 @@ build() {
package_wxwidgets-qt5-light() {
pkgdesc="wxWidgets Qt5 Toolkit (GNOME/GStreamer free!)"
- depends=('wxwidgets-common-light'
- 'qt5-base'
- 'sdl2'
- 'libmspack.so'
- )
- provides=('wxwidgets-qt5'
- 'wxwidgets'
- )
- conflicts=('wxwidgets-qt5')
+ depends=(
+ 'wxwidgets-common-light'
+ 'qt5-base'
+ 'sdl2'
+ 'libmspack.so'
+ )
+ provides=(
+ 'wxwidgets-qt5'
+ 'wxwidgets'
+ )
make -C build-qt5 DESTDIR="${pkgdir}" install
@@ -174,25 +179,25 @@ pkgdesc="wxWidgets Qt5 Toolkit (GNOME/GStreamer free!)"
package_wxwidgets-gtk3-light() {
pkgdesc="wxWidgets GTK3 Toolkit (GNOME/GStreamer free!)"
- depends=('wxwidgets-common-light'
- 'sdl2'
- 'libgspell-1.so'
- 'libgtk-3.so'
- 'libmspack.so'
- 'libnotify.so'
- 'libtiff.so'
- )
+ depends=(
+ 'wxwidgets-common-light'
+ 'sdl2'
+ 'libgspell-1.so'
+ 'libgtk-3.so'
+ 'libmspack.so'
+ 'libnotify.so'
+ 'libtiff.so'
+ )
optdepends=('webkit2gtk: for webview support')
- provides=('wxwidgets'
- 'wxwidgets-gtk3'
- 'wxgtk3'
- )
- conflicts=('wxwidgets-gtk3'
- 'wxgtk3'
- )
- replaces=('wxgtk3-light'
- 'wxgtk3'
- )
+ provides=(
+ 'wxwidgets'
+ 'wxwidgets-gtk3'
+ 'wxgtk3'
+ )
+ conflicts=(
+ 'wxwidgets-gtk3'
+ 'wxgtk3'
+ )
make -C build-gtk3 DESTDIR="${pkgdir}" install
@@ -213,25 +218,25 @@ package_wxwidgets-gtk3-light() {
package_wxwidgets-gtk4-light() {
pkgdesc="wxWidgets GTK4 Toolkit (GNOME/GStreamer free!)"
- depends=('wxwidgets-common-light'
- 'sdl2'
- 'libgspell-1.so'
- 'libgtk-4.so'
- 'libmspack.so'
- 'libnotify.so'
- 'libtiff.so'
- )
+ depends=(
+ 'wxwidgets-common-light'
+ 'sdl2'
+ 'libgspell-1.so'
+ 'libgtk-4.so'
+ 'libmspack.so'
+ 'libnotify.so'
+ 'libtiff.so'
+)
optdepends=('webkit2gtk: for webview support')
- provides=('wxwidgets'
- 'wxwidgets-gtk4'
- 'wxgtk4'
- )
- conflicts=('wxwidgets-gtk4'
- 'wxgtk4'
- )
- replaces=('wxgtk4-light'
- 'wxgtk4'
- )
+ provides=(
+ 'wxwidgets'
+ 'wxwidgets-gtk4'
+ 'wxgtk4'
+ )
+ conflicts=(
+ 'wxwidgets-gtk4'
+ 'wxgtk4'
+ )
make -C build-gtk4 DESTDIR="${pkgdir}" install
@@ -252,24 +257,24 @@ package_wxwidgets-gtk4-light() {
package_wxwidgets-common-light() {
pkgdesc="wxWidgets common & base (GNOME/GStreamer free!)"
- depends=('sh'
- 'libexpat.so'
- 'libsecret-1.so'
- 'libpcre2-32.so'
- )
- provides=('wxbase'
- 'wxbase-light'
- 'wxgtk-common'
- 'wxwidgets-common'
- )
- conflicts=('wxbase'
- 'wxbase-light'
- 'wxgtk-common'
- 'wxwidgets-common'
- )
- replaces=('wxcommon-light'
- 'wxgtk-common'
- )
+ depends=(
+ 'sh'
+ 'libexpat.so'
+ 'libsecret-1.so'
+ 'libpcre2-32.so'
+ )
+ provides=(
+ 'wxbase'
+ 'wxbase-light'
+ 'wxgtk-common'
+ 'wxwidgets-common'
+ )
+ conflicts=(
+ 'wxbase'
+ 'wxbase-light'
+ 'wxgtk-common'
+ 'wxwidgets-common'
+ )
make -C build-qt5 DESTDIR="${pkgdir}" install
make -C build-gtk3 DESTDIR="${pkgdir}" install