summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-12-11 19:19:28 +0100
committersl1pkn072015-12-11 19:19:28 +0100
commitafa9cd5b7d36daf74e832a3fbdb846b9d0850ac4 (patch)
treef7743263d3a2c2c85533a112718a9b74592ed9bc
parentea20ee39f1e1f010911e74b94ddd52ff4cda6551 (diff)
downloadaur-afa9cd5b7d36daf74e832a3fbdb846b9d0850ac4.tar.gz
gcc (abi) rebuild)
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06d4afb7ec24..0d06aa6195cc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wxwidgets-light
pkgdesc = wxWidgets suite for Base and GTK2 toolkits (GNOME/GStreamer free!)
pkgver = 3.0.2
- pkgrel = 5
+ pkgrel = 6
url = http://wxwidgets.org
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 2647f981007d..56b883a02d54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,18 @@
pkgbase="wxwidgets-light"
pkgname=('wxbase-light' 'wxgtk-light' 'wxcommon-light')
pkgver=3.0.2
-pkgrel=5
+pkgrel=6
pkgdesc="wxWidgets suite for Base and GTK2 toolkits (GNOME/GStreamer free!)"
arch=('i686' 'x86_64')
-url="http://wxwidgets.org"
+url='http://wxwidgets.org'
license=('custom:wxWindows')
-makedepends=('git' 'glu' 'bash' 'gtk2' 'libsm' 'libgl')
+makedepends=('git'
+ 'glu'
+ 'bash'
+ 'gtk2'
+ 'libsm'
+ 'libgl'
+ )
source=("wxwidgets::git+https://github.com/wxWidgets/wxWidgets.git#tag=v${pkgver}"
'config.conf'
'wx-config.sh'
@@ -19,6 +25,10 @@ sha1sums=('SKIP'
'dfe38650c655395b90bf082b5734c4093508bfa3')
prepare() {
+
+ export CC=clang
+ export CXX=clang++
+
# C++ ABI check is too strict and breaks with GCC 5.1
# https://bugzilla.redhat.com/show_bug.cgi?id=1200611
patch -d wxwidgets -Np1 -i ../make-abicheck-non-fatal.patch
@@ -107,4 +117,4 @@ package_wxcommon-light() {
install -Dm644 config.conf "${pkgdir}/etc/wx/config"
install -Dm755 wx-config.sh "${pkgdir}/usr/bin/wx-config"
-} \ No newline at end of file
+}