summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis A. AltoƩ Falqueto2018-03-13 22:12:59 -0300
committerDenis A. AltoƩ Falqueto2018-03-13 22:12:59 -0300
commit75e4ebe050fa9a36c25d8c5f60fc8946e248e4e1 (patch)
tree08d3a1c500ce036af4b479444f1161b5b132e0e5
parent9ff6a6fe41277297bcb2201571100fb1360a1a9d (diff)
downloadaur-wxwidgets2.8-light.tar.gz
Configure specific ABI version for library
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0fe8a812c5e..61318a641b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wxwidgets2.8-light
pkgdesc = wxWidgets suite for Base and GTK2 toolkits (GNOME/GStreamer free!)
pkgver = 2.8.12.1
- pkgrel = 10
+ pkgrel = 11
url = http://wxwidgets.org
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 264c703d3fc..96ecaee2166 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgbase="wxwidgets2.8-light"
pkgname=('wxbase2.8-light' 'wxgtk2.8-light' 'wxcommon2.8-light')
pkgver=2.8.12.1
-pkgrel=10
+pkgrel=11
pkgdesc="wxWidgets suite for Base and GTK2 toolkits (GNOME/GStreamer free!)"
arch=('i686' 'x86_64')
url="http://wxwidgets.org"
@@ -24,6 +24,10 @@ sha1sums=('SKIP'
'dfe38650c655395b90bf082b5734c4093508bfa3'
'f1a3bc30ec8139d97ca239dc1bf6cbc2ceb5c5d9')
+# This flag will set a fixed ABI version. That's needed for safesignidentityclient,
+# so it can load this lib without warnings
+CXXFLAGS="-fabi-version=2"
+
prepare() {
patch -d wxwidgets -p1 -i ../wxwidgets-2.8-collision.patch