summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis A. AltoƩ Falqueto2022-08-12 11:26:17 -0300
committerDenis A. AltoƩ Falqueto2022-08-12 11:55:14 -0300
commit0ef643a838444197e554c44ebe268171fea7a472 (patch)
treef572cd207520ee275b81db4146bd4f78c9ff2b98
downloadaur-0ef643a838444197e554c44ebe268171fea7a472.tar.gz
Create package for 3.0
-rw-r--r--.SRCINFO21
-rw-r--r--LICENSE50
-rw-r--r--PKGBUILD26
3 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..42b5ad90727d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = wxwidgets3.0
+ pkgdesc = GTK+3 implementation of wxWidgets API for GUI
+ pkgver = 3.0.5
+ pkgrel = 1
+ url = https://wxwidgets.org/
+ arch = x86_64
+ license = custom:wxWindows
+ depends = gtk3
+ depends = gst-plugins-base-libs
+ depends = libsm
+ depends = wxwidgets-common
+ depends = libnotify
+ depends = libmspack
+ depends = sdl2
+ optdepends = webkit2gtk: for webview support
+ provides = wxgtk3
+ provides = wxwidgets
+ source = https://github.com/wxWidgets/wxWidgets/releases/download/v3.0.5/wxWidgets-3.0.5.tar.bz2
+ sha256sums = 8aacd56b462f42fb6e33b4d8f5d40be5abc3d3b41348ea968aa515cc8285d813
+
+pkgname = wxwidgets3.0
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..0878f6e516dd
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,50 @@
+ wxWindows Library Licence, Version 3.1
+ ======================================
+
+Copyright (c) 1998-2005 Julian Smart, Robert Roebling et al
+
+Everyone is permitted to copy and distribute verbatim copies
+of this licence document, but changing it is not allowed.
+
+ WXWINDOWS LIBRARY LICENCE
+ TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION
+
+This library is free software; you can redistribute it and/or modify it
+under the terms of the GNU Library General Public Licence as published by
+the Free Software Foundation; either version 2 of the Licence, or (at your
+option) any later version.
+
+This library is distributed in the hope that it will be useful, but WITHOUT
+ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+FITNESS FOR A PARTICULAR PURPOSE. See the GNU Library General Public
+Licence for more details.
+
+You should have received a copy of the GNU Library General Public Licence
+along with this software, usually in a file named COPYING.LIB. If not,
+write to the Free Software Foundation, Inc., 51 Franklin Street, Fifth
+Floor, Boston, MA 02110-1301 USA.
+
+EXCEPTION NOTICE
+
+1. As a special exception, the copyright holders of this library give
+permission for additional uses of the text contained in this release of the
+library as licenced under the wxWindows Library Licence, applying either
+version 3.1 of the Licence, or (at your option) any later version of the
+Licence as published by the copyright holders of version 3.1 of the Licence
+document.
+
+2. The exception is that you may use, copy, link, modify and distribute
+under your own terms, binary object code versions of works based on the
+Library.
+
+3. If you copy code from files distributed under the terms of the GNU
+General Public Licence or the GNU Library General Public Licence into a
+copy of this library, as this licence permits, the exception does not apply
+to the code that you add in this way. To avoid misleading anyone as to the
+status of such modified files, you must delete this exception notice from
+such code and/or adjust the licensing conditions notice accordingly.
+
+4. If you write modifications of your own for this library, it is your
+choice whether to permit this exception to apply to your modifications. If
+you do not wish that, you must delete the exception notice from such code
+and/or adjust the licensing conditions notice accordingly. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3be9c1327f04
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Denis Falqueto <denisfalqueto@gmail.com>
+__pkgbasename=wxWidgets
+pkgbase=wxwidgets3.0
+pkgname=${pkgbase}
+pkgver=3.0.5
+pkgrel=1
+pkgdesc="GTK+3 implementation of wxWidgets API for GUI"
+arch=('x86_64')
+url="https://wxwidgets.org/"
+license=('custom:wxWindows')
+depends=('gtk3' 'gst-plugins-base-libs' 'libsm' 'wxwidgets-common' 'libnotify' 'libmspack' 'sdl2')
+optdepends=('webkit2gtk: for webview support')
+provides=('wxgtk3' 'wxwidgets')
+source=("https://github.com/${__pkgbasename}/${__pkgbasename}/releases/download/v${pkgver}/wxWidgets-${pkgver}.tar.bz2")
+sha256sums=('8aacd56b462f42fb6e33b4d8f5d40be5abc3d3b41348ea968aa515cc8285d813')
+
+build() {
+ cd "$__pkgbasename-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$__pkgbasename-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}