summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjun72018-05-30 02:51:51 +0900
committerjun72018-05-30 02:51:51 +0900
commiteb144ddac08ac7375c5a03500073759a4e9d51c5 (patch)
tree750b8023e955f289ec6de09038e0f51aa9bd433a
downloadaur-eb144ddac08ac7375c5a03500073759a4e9d51c5.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD36
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..95266565f9d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = wyebab-git
+ pkgdesc = An adblock command using the easylist.txt.
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://github.com/jun7/wyebadblock
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = glib2
+ conflicts = wyebadblock-git
+ source = git://github.com/jun7/wyebadblock.git#branch=master
+ md5sums = SKIP
+
+pkgname = wyebab-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe880013ff04
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: jun7 <jun7@hush.com>
+pkgname=wyebab-git
+pkgver=1.1
+pkgrel=1
+pkgdesc="An adblock command using the easylist.txt."
+arch=('x86_64')
+url="https://github.com/jun7/wyebadblock"
+license=('GPL3')
+depends=('glib2')
+conflicts=('wyebadblock-git')
+makedepends=('git')
+_branch=master
+source=("git://github.com/jun7/wyebadblock.git#branch=$_branch")
+md5sums=('SKIP')
+
+pkgver(){
+ cd "$srcdir/wyebadblock"
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/wyebadblock"
+ git pull --rebase origin $_branch
+ make clean
+}
+
+build() {
+ cd "$srcdir/wyebadblock"
+ DEBUG=0
+ make wyebab
+}
+
+package() {
+ cd "$srcdir/wyebadblock"
+ install -Dm755 wyebab "$pkgdir/usr/bin/wyebab"
+}