summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Karmanov2022-02-09 12:33:52 +0300
committerAnton Karmanov2022-02-09 12:33:52 +0300
commit37dda430d37ffcd7f6674d221dc551a5e2c733a3 (patch)
treed22539d418a948b452016c4edf735fd7c595a0bf
parentc7cca16d3242cb64a97fe0a84515f04794fbea13 (diff)
downloadaur-37dda430d37ffcd7f6674d221dc551a5e2c733a3.tar.gz
Update to 5.3.4
-rw-r--r--.SRCINFO12
-rw-r--r--5_3_4_source_location.patch13
-rw-r--r--PKGBUILD27
3 files changed, 38 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7487754af2b4..17a4bcf744ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wyrmsun
pkgdesc = Real-time strategy game based on history, mythology and fiction
- pkgver = 5.0.1
+ pkgver = 5.3.4
pkgrel = 1
url = http://andrettin.github.io/
arch = i686
@@ -14,9 +14,11 @@ pkgbase = wyrmsun
depends = qt5-multimedia
depends = sdl_mixer
depends = tolua++
- source = wyrmsun-5.0.1.tar.gz::https://github.com/Andrettin/Wyrmsun/archive/v5.0.1.tar.gz
- source = wyrmgus-5.0.1.tar.gz::https://github.com/Andrettin/Wyrmgus/archive/v5.0.1.tar.gz
- md5sums = f65843589884dfcdc3b7cd15ed3ee4b3
- md5sums = aca08095bc898463237604153c225050
+ source = wyrmsun-5.3.4.tar.gz::https://github.com/Andrettin/Wyrmsun/archive/v5.3.4.tar.gz
+ source = wyrmgus-5.3.4.tar.gz::https://github.com/Andrettin/Wyrmgus/archive/v5.3.4.tar.gz
+ source = 5_3_4_source_location.patch
+ md5sums = ce43520e9b2020fa1c341df4a8d4272d
+ md5sums = 7b578710922a10b807b3b56d144a76d6
+ md5sums = 530da5bea60ef115e66a7c491d99f9ce
pkgname = wyrmsun
diff --git a/5_3_4_source_location.patch b/5_3_4_source_location.patch
new file mode 100644
index 000000000000..79ea6684c51c
--- /dev/null
+++ b/5_3_4_source_location.patch
@@ -0,0 +1,13 @@
+diff --color --unified --recursive --text Wyrmgus-5.3.4/src/util/assert_util.h Wyrmgus-5.3.4_fix/src/util/assert_util.h
+--- Wyrmgus-5.3.4/src/util/assert_util.h 2022-02-02 00:56:57.000000000 +0300
++++ Wyrmgus-5.3.4_fix/src/util/assert_util.h 2022-02-09 12:17:11.199389421 +0300
+@@ -26,6 +26,9 @@
+
+ #pragma once
+
++#include <source_location>
++#include <string>
++
+ namespace wyrmgus {
+
+ inline std::string get_source_relative_filepath_string(const std::string &filepath)
diff --git a/PKGBUILD b/PKGBUILD
index e3ce7b7c97ab..d8296da9e444 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: MCMic <come@chilliet.eu>
pkgname=wyrmsun
-pkgver=5.0.1
+pkgver=5.3.4
pkgrel=1
pkgdesc="Real-time strategy game based on history, mythology and fiction"
arch=('i686' 'x86_64')
@@ -16,13 +16,22 @@ depends=(
'tolua++'
)
makedepends=('boost' 'cmake' 'glu')
-source=("wyrmsun-${pkgver}.tar.gz::https://github.com/Andrettin/Wyrmsun/archive/v${pkgver}.tar.gz"
- "wyrmgus-${pkgver}.tar.gz::https://github.com/Andrettin/Wyrmgus/archive/v${pkgver}.tar.gz")
-md5sums=('f65843589884dfcdc3b7cd15ed3ee4b3'
- 'aca08095bc898463237604153c225050')
+source=("wyrmsun-${pkgver}.tar.gz::https://github.com/Andrettin/Wyrmsun/archive/v${pkgver}.tar.gz"
+ "wyrmgus-${pkgver}.tar.gz::https://github.com/Andrettin/Wyrmgus/archive/v${pkgver}.tar.gz"
+ '5_3_4_source_location.patch')
+md5sums=('ce43520e9b2020fa1c341df4a8d4272d'
+ '7b578710922a10b807b3b56d144a76d6'
+ '530da5bea60ef115e66a7c491d99f9ce')
+
+prepare() {
+ cd "${srcdir}/Wyrmgus-${pkgver}"
+
+ # https://github.com/Andrettin/Wyrmgus/issues/179
+ patch --forward --strip=1 --input="${srcdir}/5_3_4_source_location.patch"
+}
build() {
- cd ${srcdir}/Wyrmgus-${pkgver}
+ cd "${srcdir}/Wyrmgus-${pkgver}"
cmake . \
-DCMAKE_BUILD_TYPE=Release \
-DOpenGL_GL_PREFERENCE=GLVND \
@@ -40,16 +49,16 @@ build() {
}
check() {
- cd ${srcdir}/Wyrmgus-${pkgver}
+ cd "${srcdir}/Wyrmgus-${pkgver}"
cmake --build . --target wyrmgus_test
./wyrmgus_test
}
package() {
- cd ${srcdir}/Wyrmgus-${pkgver}
+ cd "${srcdir}/Wyrmgus-${pkgver}"
mkdir -p "${pkgdir}/usr/bin/"
cp wyrmgus "${pkgdir}/usr/bin/"
- cd ${srcdir}/Wyrmsun-${pkgver}
+ cd "${srcdir}/Wyrmsun-${pkgver}"
cmake --install . --prefix "${pkgdir}/usr/"
}