summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLawrence González2022-05-10 13:05:35 -0400
committerLawrence González2022-05-10 13:05:35 -0400
commit645c0ba7706993c7bd754a1b84be338d5ccb3a69 (patch)
tree461c9d7c5c798708953a10bb7e102bcddd9c703d
parent3ad82e71f5a372a334994100572f20542f558c08 (diff)
downloadaur-645c0ba7706993c7bd754a1b84be338d5ccb3a69.tar.gz
Added workaround for -Werror=format-security
"/etc/makepkg.conf" includes "-Werror=format-security" in CFLAGS and and CXXFLAGS, this causes Wyrmgus (Wyrmsun engine) can't be compiled, so I added an option that negates that flag, but this is only a workaround while we wait for upstream to fix the incompatibility with the flag (if they want).
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore12
-rw-r--r--PKGBUILD30
3 files changed, 34 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 539a17a6701e..548be5a32033 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wyrmsun
pkgdesc = Real-time strategy game based on history, mythology and fiction
pkgver = 5.3.5
- pkgrel = 1
+ pkgrel = 2
url = http://andrettin.github.io/
arch = i686
arch = x86_64
@@ -10,9 +10,12 @@ pkgbase = wyrmsun
makedepends = cmake
makedepends = glu
depends = hicolor-icon-theme
+ depends = qt5-graphicaleffects
depends = qt5-location
depends = qt5-multimedia
- depends = sdl_mixer
+ depends = qt5-quickcontrols
+ depends = qt5-quickcontrols2
+ depends = sdl2_mixer
depends = tolua++
source = wyrmsun-5.3.5.tar.gz::https://github.com/Andrettin/Wyrmsun/archive/v5.3.5.tar.gz
source = wyrmgus-5.3.5.tar.gz::https://github.com/Andrettin/Wyrmgus/archive/v5.3.5.tar.gz
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4e4707ee6df2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,12 @@
+# Directories
+pkg/
+src/
+
+# File formats
+*.bz2
+*.gz
+*.log
+*.pkg.*
+*.tar.*
+*.xz
+*.zst
diff --git a/PKGBUILD b/PKGBUILD
index 06ce49ee84ad..6bbcfb4a125a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,22 @@
# Maintainer: Anton Karmanov <a.karmanov@inventati.org>
+# Maintainer: GalaxyLJGD <pentestian [AT] airmail [DOT] cc>
# Contributor: MCMic <come@chilliet.eu>
pkgname=wyrmsun
pkgver=5.3.5
-pkgrel=1
+pkgrel=2
pkgdesc="Real-time strategy game based on history, mythology and fiction"
arch=('i686' 'x86_64')
url="http://andrettin.github.io/"
license=('GPL2')
-depends=(
- 'hicolor-icon-theme'
- 'qt5-location'
- 'qt5-multimedia'
- 'sdl_mixer'
- 'tolua++'
-)
+depends=('hicolor-icon-theme'
+ 'qt5-graphicaleffects'
+ 'qt5-location'
+ 'qt5-multimedia'
+ 'qt5-quickcontrols'
+ 'qt5-quickcontrols2'
+ 'sdl2_mixer'
+ 'tolua++')
makedepends=('boost' 'cmake' 'glu')
source=("wyrmsun-${pkgver}.tar.gz::https://github.com/Andrettin/Wyrmsun/archive/v${pkgver}.tar.gz"
"wyrmgus-${pkgver}.tar.gz::https://github.com/Andrettin/Wyrmgus/archive/v${pkgver}.tar.gz")
@@ -24,18 +26,20 @@ md5sums=('f519b26169499e52517196b24813d2ac'
build() {
cd "${srcdir}/Wyrmgus-${pkgver}"
cmake . \
- -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_BUILD_TYPE=None \
-DOpenGL_GL_PREFERENCE=GLVND \
-DWITH_GEOJSON=OFF \
- ;
+ -DCMAKE_C_FLAGS="$CFLAGS -Wno-error=format-security -DNDEBUG" \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS -Wno-error=format-security -DNDEBUG" \
+ -Wno-dev
cmake --build . --target wyrmgus_main
cd "${srcdir}/Wyrmsun-${pkgver}"
cmake . \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX='/usr/' \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
-DBIN_DIR='bin/' \
- ;
+ -Wno-dev
cmake --build .
}