summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmy Wilson2019-01-17 19:41:28 +1100
committerAmy Wilson2019-01-17 19:41:28 +1100
commit41bef713a0496380fa87e346078bcc20e2703b1e (patch)
treecfab523a636da08162027170280816ccd0296fc0
downloadaur-41bef713a0496380fa87e346078bcc20e2703b1e.tar.gz
Initial PKGBUILD
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9260590940cd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = wyvern
+ pkgdesc = Command-line tool written in rust that is meant to make downloading GOG games and associated activities easier and faster on linux.
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://git.sr.ht/%7Enicohman/wyvern/
+ arch = x86_64
+ license = GPL
+ makedepends = rust
+ depends = openssl
+ source = https://git.sr.ht/%7Enicohman/wyvern/archive/1.0.1.tar.gz
+ sha256sums = e18830237037d2c3d0cf911e8be4e8dbeb2ac4cbe5d954cfca2f57435da0cc61
+
+pkgname = wyvern
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d148b69c336b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Amy Wilson <awils_1 at xsmail dot com>
+pkgname="wyvern"
+pkgver="1.0.1"
+pkgrel="1"
+pkgdesc="Command-line tool written in rust that is meant to make downloading GOG games and associated activities easier and faster on linux."
+arch=("x86_64")
+url="https://git.sr.ht/%7Enicohman/wyvern/"
+license=("GPL")
+makedepends=("rust")
+depends=("openssl")
+source=("https://git.sr.ht/%7Enicohman/$pkgname/archive/${pkgver}.tar.gz")
+sha256sums=('e18830237037d2c3d0cf911e8be4e8dbeb2ac4cbe5d954cfca2f57435da0cc61')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ cargo build --release
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ install -Dm 755 "target/release/${pkgname}" -t "$pkgdir/usr/bin"
+}
+