summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMees Luten2020-10-05 17:31:31 +0200
committerMees Luten2020-10-05 17:31:31 +0200
commitd50c884da28c8a55a707f57e61ce30ec14462a48 (patch)
treee7541c89986f74ac397754f11eae13e9174294fb
parent1ed68fa99ab8efe0b8a01b6170ad9019b3ff1e56 (diff)
downloadaur-d50c884da28c8a55a707f57e61ce30ec14462a48.tar.gz
Add MODIS decoder and new dependency
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f796ff08e9..6b60bdca70e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = x-band-decoders-git
pkgdesc = A project aimed at decoding various X-Band satellites
- pkgver = r31.62e592d
+ pkgver = r52.f8d2295
pkgrel = 1
url = https://github.com/altillimity/X-Band-Decoders
arch = x86_64
@@ -8,6 +8,8 @@ pkgbase = x-band-decoders-git
makedepends = libfec-git
makedepends = libcorrect-git
makedepends = git
+ makedepends = libccsds-git
+ depends = libaec
source = x-band-decoders-git::git+https://github.com/altillimity/X-Band-Decoders.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index a5227f58bae..e77dade388f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Mees Luten <mees [dot] luten [at] gmail [dot] com>
pkgname=x-band-decoders-git
-pkgver=r31.62e592d
+pkgver=r52.f8d2295
pkgrel=1
pkgdesc="A project aimed at decoding various X-Band satellites"
arch=('x86_64')
url="https://github.com/altillimity/X-Band-Decoders"
license=('GPLv3')
-depends=()
-makedepends=('libfec-git' 'libcorrect-git' 'git')
+depends=(libaec)
+makedepends=('libfec-git' 'libcorrect-git' 'git' 'libccsds-git')
provides=()
conflicts=()
replaces=()
@@ -41,4 +41,5 @@ package() {
install -Dm755 FengYun\ MPT\ Decoder/FengYun-MPT-Decoder "${pkgdir}"/usr/bin/FengYun-MPT-Decoder
install -Dm755 FengYun\ MERSI-2\ Decoder/FengYun-MERSI-2-Decoder "${pkgdir}"/usr/bin/FengYun-MERSI-2-Decoder
install -Dm755 FengYun\ MERSI-1\ Decoder/FengYun-MERSI-1-Decoder "${pkgdir}"/usr/bin/FengYun-MERSI-1-Decoder
+ install -Dm755 MODIS\ Decoder/MODIS-Decoder "${pkgdir}"/usr/bin/MODIS-Decoder
}