summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Reuße2015-10-25 16:19:59 +0100
committerSebastian Reuße2015-10-25 16:20:29 +0100
commit1763e64fe9c7c9c3f3ab620d6b85748a5c5b5bfa (patch)
tree43eae21e9659ae7e53e77900f17d127ca12f9e6a
downloadaur-1763e64fe9c7c9c3f3ab620d6b85748a5c5b5bfa.tar.gz
Init.
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD27
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..213f95627896
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = x-highlight-region-git
+ pkgdesc = Dims everything but a selected region of the screen.
+ pkgver = 0.1.0.0.r0.gf8666c3
+ pkgrel = 1
+ url = https://github.com/eigengrau/x-highlight-region
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = python-gobject
+ depends = python3-keybinder
+ depends = gtk3
+ provides = x-highlight-region
+ conflicts = x-highlight-region
+ source = git+https://github.com/eigengrau/x-highlight-region
+ md5sums = SKIP
+
+pkgname = x-highlight-region-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..468cd87d3ce8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b07b807b4f45
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Sebastian Reuße <seb@wirrsal.net>
+pkgname=x-highlight-region-git
+_gitname=x-highlight-region
+pkgver=0.1.0.0.r0.gf8666c3
+pkgrel=1
+pkgdesc="Dims everything but a selected region of the screen."
+arch=(any)
+url=https://github.com/eigengrau/x-highlight-region
+license=(GPL)
+depends=(python-gobject python3-keybinder gtk3)
+makedepends=(git)
+provides=(x-highlight-region)
+conflicts=(x-highlight-region)
+source=(git+https://github.com/eigengrau/x-highlight-region)
+md5sums=(SKIP)
+
+
+pkgver() {
+ cd "$_gitname"
+ git describe --long --tags | \
+ sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//;'
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}