summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjuju21432019-09-20 18:18:33 -0400
committerjuju21432019-09-20 18:18:33 -0400
commit4411070940c6c8bd49468c7353ea9ae181ad4b7e (patch)
treea9c8560e67d8dd833252862858ab954a7a87e827
downloadaur-4411070940c6c8bd49468c7353ea9ae181ad4b7e.tar.gz
Add docs
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD41
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f167b2e50b10
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = x16-docs-git
+ pkgdesc = Documentation not found in other packages for The 8-Bit Guy's Commander X16
+ pkgver = r32.2f77157
+ pkgrel = 1
+ url = http://commanderx16.com/
+ arch = any
+ groups = commander-x16
+ license = unknown
+ makedepends = git
+ makedepends = pandoc
+ optdepends = x16-emulator: X16 emulator
+ optdepends = x16-rom: X16 ROMs
+ provides = x16-docs
+ conflicts = x16-docs
+ source = git+https://github.com/commanderx16/x16-docs.git
+ source = https://raw.githubusercontent.com/commanderx16/x16-emulator/master/github-pandoc.css
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = x16-docs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b05f8475814
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Julien Savard <juju@juju2143.ca>
+pkgname=x16-docs-git
+pkgver=r32.2f77157
+pkgrel=1
+pkgdesc="Documentation not found in other packages for The 8-Bit Guy's Commander X16"
+arch=('any')
+url="http://commanderx16.com/"
+license=('unknown')
+groups=('commander-x16')
+depends=()
+makedepends=('git' 'pandoc')
+optdepends=('x16-emulator: X16 emulator'
+ 'x16-rom: X16 ROMs')
+provides=('x16-docs')
+conflicts=('x16-docs')
+replaces=()
+options=()
+install=
+changelog=
+source=("git+https://github.com/commanderx16/x16-docs.git"
+ "https://raw.githubusercontent.com/commanderx16/x16-emulator/master/github-pandoc.css")
+md5sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${pkgname%-git}"
+ pandoc --from gfm --to html -c ../github-pandoc.css --standalone --metadata pagetitle="Commander X16 Programmer's Reference Guide" Commander\ X16\ Programmer\'s\ Reference\ Guide.md --output Programmer\'s\ Reference\ Guide.html
+ pandoc --from gfm --to html -c ../github-pandoc.css --standalone --metadata pagetitle="VERA Programmer's Reference.md" VERA\ Programmer\'s\ Reference.md --output VERA\ Programmer\'s\ Reference.html
+}
+
+package() {
+ cd "${pkgname%-git}"
+ install -Dm644 ../github-pandoc.css "$pkgdir/usr/share/doc/${pkgname%-git}/github-pandoc.css"
+ install -Dm644 Programmer\'s\ Reference\ Guide.html "$pkgdir/usr/share/doc/${pkgname%-git}/Programmer's Reference Guide.html"
+ install -Dm644 VERA\ Programmer\'s\ Reference.html "$pkgdir/usr/share/doc/${pkgname%-git}/VERA Programmer's Reference.html"
+}