summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjuju21432019-09-23 13:46:58 -0400
committerjuju21432019-09-23 13:46:58 -0400
commitdb1c9777feddeb8b41ae289475cc684911ab6140 (patch)
tree5bbc44973e676787db354addb41e71461449d69e
parent02d72b7520b231402a9f88fa80643d7d65a4460c (diff)
downloadaur-db1c9777feddeb8b41ae289475cc684911ab6140.tar.gz
Add Lua script for the links
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 840647fda219..324a3bc7114a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = x16-docs-git
pkgdesc = Documentation not found in other packages for The 8-Bit Guy's Commander X16
- pkgver = r32.2f77157
- pkgrel = 2
+ pkgver = r33.6fee76f
+ pkgrel = 1
url = http://commanderx16.com/
arch = any
groups = commander-x16
@@ -14,6 +14,8 @@ pkgbase = x16-docs-git
conflicts = x16-docs
source = git+https://github.com/commanderx16/x16-docs.git
source = https://raw.githubusercontent.com/commanderx16/x16-emulator/master/github-pandoc.css
+ source = https://raw.githubusercontent.com/commanderx16/x16-emulator/master/mdtohtml.lua
+ md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index f2fdc3158e8e..ebab6a95a856 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Julien Savard <juju@juju2143.ca>
pkgname=x16-docs-git
-pkgver=r32.2f77157
-pkgrel=2
+pkgver=r33.6fee76f
+pkgrel=1
pkgdesc="Documentation not found in other packages for The 8-Bit Guy's Commander X16"
arch=('any')
url="http://commanderx16.com/"
@@ -18,8 +18,10 @@ options=()
install=
changelog=
source=("git+https://github.com/commanderx16/x16-docs.git"
- "https://raw.githubusercontent.com/commanderx16/x16-emulator/master/github-pandoc.css")
+ "https://raw.githubusercontent.com/commanderx16/x16-emulator/master/github-pandoc.css"
+ "https://raw.githubusercontent.com/commanderx16/x16-emulator/master/mdtohtml.lua")
md5sums=('SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -29,7 +31,7 @@ pkgver() {
build() {
cd "${pkgname%-git}"
- pandoc --from gfm --to html -c github-pandoc.css --standalone --metadata pagetitle="Commander X16 Programmer's Reference Guide" Commander\ X16\ Programmer\'s\ Reference\ Guide.md --output Programmer\'s\ Reference\ Guide.html
+ pandoc --from gfm --to html -c github-pandoc.css --standalone --metadata pagetitle="Commander X16 Programmer's Reference Guide" Commander\ X16\ Programmer\'s\ Reference\ Guide.md --output Programmer\'s\ Reference\ Guide.html --lua-filter=../mdtohtml.lua
pandoc --from gfm --to html -c github-pandoc.css --standalone --metadata pagetitle="VERA Programmer's Reference.md" VERA\ Programmer\'s\ Reference.md --output VERA\ Programmer\'s\ Reference.html
}