summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjuju21432019-09-20 16:42:50 -0400
committerjuju21432019-09-20 16:42:50 -0400
commit5c728bd388bc6e6eb6821c44035e39fe32ab4ca7 (patch)
tree2987a9ed7deada72ca53f9ea6643bfd76fdb429d
parent5c6afea28adb815bbbb32a82392bfc423f9fefeb (diff)
downloadaur-5c728bd388bc6e6eb6821c44035e39fe32ab4ca7.tar.gz
Change default ROM path
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--modify-base-path.patch11
3 files changed, 24 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0c1635598be..386fc402a0e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = x16-emulator
pkgdesc = An emulator for The 8-Bit Guy's Commander X16
pkgver = r31
- pkgrel = 1
+ pkgrel = 2
url = http://commanderx16.com/
arch = x86_64
groups = commander-x16
@@ -10,7 +10,9 @@ pkgbase = x16-emulator
depends = sdl2
optdepends = x16-rom: ROMs for the emulator
source = https://github.com/commanderx16/x16-emulator/archive/r31.tar.gz
+ source = modify-base-path.patch
md5sums = abeffe30fea892e7494e105bb070999b
+ md5sums = 5cd0550d2af1b4267c9b9f30eed9691e
pkgname = x16-emulator
diff --git a/PKGBUILD b/PKGBUILD
index 8a79da371957..babb209abb5a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Julien Savard <juju@juju2143.ca>
pkgname=x16-emulator
pkgver=r31
-pkgrel=1
+pkgrel=2
pkgdesc="An emulator for The 8-Bit Guy's Commander X16"
arch=('x86_64')
url="http://commanderx16.com/"
@@ -16,8 +16,15 @@ replaces=()
options=()
install=
changelog=
-source=("https://github.com/commanderx16/$pkgname/archive/$pkgver.tar.gz")
-md5sums=('abeffe30fea892e7494e105bb070999b')
+source=("https://github.com/commanderx16/$pkgname/archive/$pkgver.tar.gz"
+ "modify-base-path.patch")
+md5sums=('abeffe30fea892e7494e105bb070999b'
+ '5cd0550d2af1b4267c9b9f30eed9691e')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -uN main.c ../modify-base-path.patch
+}
build() {
cd "$pkgname-$pkgver"
diff --git a/modify-base-path.patch b/modify-base-path.patch
new file mode 100644
index 000000000000..00a356f0b305
--- /dev/null
+++ b/modify-base-path.patch
@@ -0,0 +1,11 @@
+--- main.c.old 2019-09-20 16:32:26.460096000 -0400
++++ main.c 2019-09-20 16:32:10.830095139 -0400
+@@ -303,7 +303,7 @@
+
+ run_after_load = false;
+
+- char *base_path = SDL_GetBasePath();
++ char *base_path = "/usr/share/x16-rom/";
+
+ // This causes the emulator to load ROM data from the executable's directory when
+ // no ROM file is specified on the command line.