summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjuju21432019-12-20 16:01:49 -0500
committerjuju21432019-12-20 16:01:49 -0500
commitdfe538f7d6ea485b44a0008a887d1017f2e6a08c (patch)
treeecd769dee10b60c40ba09c05313c4e94b5f6acf7
parent571c121cfa8043e9042a6d2d6cd2484f66c9128a (diff)
downloadaur-dfe538f7d6ea485b44a0008a887d1017f2e6a08c.tar.gz
Update to r35
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 9 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6551c4a5f32c..9e3a42228704 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = x16-emulator-bin
pkgdesc = An emulator for The 8-Bit Guy's Commander X16 (release package)
- pkgver = r34
+ pkgver = r35
pkgrel = 1
url = http://commanderx16.com/
arch = any
@@ -9,10 +9,8 @@ pkgbase = x16-emulator-bin
optdepends = x16-emulator-bin: X16 emulator
optdepends = x16-rom-bin: X16 ROMs
optdepends = x16-docs-bin: X16 documentation
- source = https://github.com/commanderx16/x16-emulator/releases/download/r34/x16emu_linux-r34.zip
- source = https://raw.githubusercontent.com/commanderx16/x16-emulator/r34/github-pandoc.css
- md5sums = bab658e13f98644719a121c1fcc61825
- md5sums = 3accdbadaf70264c743b1f655f5dc146
+ source = https://github.com/commanderx16/x16-emulator/releases/download/r35/x16emu_linux-r35.zip
+ md5sums = f53fb45268d7ad79860901298e99b0b7
pkgname = x16-emulator-bin
pkgdesc = An emulator for The 8-Bit Guy's Commander X16 (release package)
diff --git a/PKGBUILD b/PKGBUILD
index 9541bf039fc0..73edea5816ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Julien Savard <juju@juju2143.ca>
pkgname=('x16-emulator-bin' 'x16-rom-bin' 'x16-docs-bin')
pkgbase=x16-emulator-bin
-pkgver=r34
+pkgver=r35
pkgrel=1
pkgdesc="An emulator for The 8-Bit Guy's Commander X16 (release package)"
arch=('any')
@@ -19,10 +19,8 @@ replaces=()
options=()
install=
changelog=
-source=("https://github.com/commanderx16/x16-emulator/releases/download/$pkgver/x16emu_linux-$pkgver.zip"
- "https://raw.githubusercontent.com/commanderx16/x16-emulator/$pkgver/github-pandoc.css")
-md5sums=('bab658e13f98644719a121c1fcc61825'
- '3accdbadaf70264c743b1f655f5dc146')
+source=("https://github.com/commanderx16/x16-emulator/releases/download/$pkgver/x16emu_linux-$pkgver.zip")
+md5sums=('f53fb45268d7ad79860901298e99b0b7')
package_x16-emulator-bin() {
pkgdesc="An emulator for The 8-Bit Guy's Commander X16 (release package)"
@@ -33,7 +31,7 @@ package_x16-emulator-bin() {
conflicts=('x16-emulator')
install -Dm755 x16emu "$pkgdir/usr/bin/x16emu"
- install -Dm644 github-pandoc.css "$pkgdir/usr/share/doc/$pkgname/github-pandoc.css"
+ install -Dm644 docs/github-pandoc.css "$pkgdir/usr/share/doc/$pkgname/github-pandoc.css"
install -Dm644 docs/README.html "$pkgdir/usr/share/doc/$pkgname/README.html"
}
@@ -44,7 +42,7 @@ package_x16-rom-bin() {
install -Dm644 rom.bin "$pkgdir/usr/share/x16-rom/rom.bin"
install -Dm644 rom.sym "$pkgdir/usr/share/x16-rom/rom.sym"
- install -Dm644 github-pandoc.css "$pkgdir/usr/share/doc/x16-rom/github-pandoc.css"
+ install -Dm644 docs/github-pandoc.css "$pkgdir/usr/share/doc/x16-rom/github-pandoc.css"
install -Dm644 docs/KERNAL-BASIC.html "$pkgdir/usr/share/doc/x16-rom/KERNAL-BASIC.html"
}
@@ -53,7 +51,7 @@ package_x16-docs-bin() {
provides=('x16-docs')
conflicts=('x16-docs')
- install -Dm644 github-pandoc.css "$pkgdir/usr/share/doc/x16-docs/github-pandoc.css"
+ install -Dm644 docs/github-pandoc.css "$pkgdir/usr/share/doc/x16-docs/github-pandoc.css"
install -Dm644 docs/Programmer\'s\ Reference\ Guide.html "$pkgdir/usr/share/doc/x16-docs/Programmer's Reference Guide.html"
install -Dm644 docs/VERA\ Programmer\'s\ Reference.html "$pkgdir/usr/share/doc/x16-docs/VERA Programmer's Reference.html"
}