summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjuju21432019-09-20 15:31:09 -0400
committerjuju21432019-09-20 15:31:09 -0400
commitfe7a3ee681782fec61594a933979370b22aead50 (patch)
tree5cd77e55fc3f902058870580e446c1391fb9028a
parent5f84a108f2f24b6539fddc16349e83e0cc1a0830 (diff)
downloadaur-fe7a3ee681782fec61594a933979370b22aead50.tar.gz
Update to r31
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3a246d1cf33e..d937865add09 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = x16-rom
pkgdesc = ROM files for The 8-Bit Guy's Commander X16
- pkgver = r30
+ pkgver = r31
pkgrel = 1
url = http://commanderx16.com/
arch = any
@@ -9,10 +9,11 @@ pkgbase = x16-rom
license = GPL3
makedepends = cc65
makedepends = pandoc
- source = https://github.com/commanderx16/x16-rom/archive/r30.tar.gz
+ optdepends = x16-emulator: emulator for the ROMs
+ source = https://github.com/commanderx16/x16-rom/archive/r31.tar.gz
source = https://raw.githubusercontent.com/commanderx16/x16-emulator/4f1c937cd296c8f5cde8e463b672696d5fbd9b8c/github-pandoc.css
source = https://raw.githubusercontent.com/mobluse/chargen-maker/6bb59c1859e7c37397a464444d208072aac83b81/chargen.txt
- md5sums = a48185f8243c6eba1460801963dfe536
+ md5sums = e45226c67087580c6dff83da0a27ca8a
md5sums = 3accdbadaf70264c743b1f655f5dc146
md5sums = 9a579aff9633b7ffbb6d27335d193cef
diff --git a/PKGBUILD b/PKGBUILD
index d57e14452952..d9593fe4a4bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Julien Savard <juju@juju2143.ca>
pkgname=x16-rom
-pkgver=r30
+pkgver=r31
pkgrel=1
pkgdesc="ROM files for The 8-Bit Guy's Commander X16"
arch=('any')
@@ -9,7 +9,7 @@ license=('unknown' 'GPL3')
groups=('commander-x16')
depends=()
makedepends=('cc65' 'pandoc')
-optdepends=()
+optdepends=('x16-emulator: emulator for the ROMs')
provides=()
conflicts=()
replaces=()
@@ -19,14 +19,14 @@ changelog=
source=("https://github.com/commanderx16/$pkgname/archive/$pkgver.tar.gz"
"https://raw.githubusercontent.com/commanderx16/x16-emulator/4f1c937cd296c8f5cde8e463b672696d5fbd9b8c/github-pandoc.css"
"https://raw.githubusercontent.com/mobluse/chargen-maker/6bb59c1859e7c37397a464444d208072aac83b81/chargen.txt")
-md5sums=('a48185f8243c6eba1460801963dfe536'
+md5sums=('e45226c67087580c6dff83da0a27ca8a'
'3accdbadaf70264c743b1f655f5dc146'
'9a579aff9633b7ffbb6d27335d193cef')
build() {
cd "$pkgname-$pkgver"
make
- # Stolen from https://github.com/mobluse/chargen-maker, under GPL3
+ # Stolen from https://github.com/mobluse/chargen-maker, code is under GPL3, the font itself might be public domain
sed '/^#/d;/^[[:space:]]*$/d;s/\\/0/g;s/@/1/g;' < ../chargen.txt | perl -ne 'print pack("B8", $_)' > chargen.bin
pandoc --from gfm --to html -c ../github-pandoc.css --standalone --metadata pagetitle="X16 KERNAL/BASIC/DOS ROM" README.md --output KERNAL-BASIC.html
}