summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederic Bezies2023-06-15 20:06:48 +0200
committerFrederic Bezies2023-06-15 20:06:48 +0200
commit313a2e20f7d6432aadc4748aad9516a1a598517a (patch)
treeff572b782f88a545a1410b926c9a7d15a1fbccb1
parente7eed846e013ffe0d8bd6b01efac177e07c0c866 (diff)
downloadaur-313a2e20f7d6432aadc4748aad9516a1a598517a.tar.gz
June 15th, 2023 update
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 5 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 74939e1d5464..10790a6337a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = x16-rom-git
pkgdesc = ROM files for The 8-Bit Guy's Commander X16
- pkgver = r43.r1.g1866bb7
+ pkgver = r43.r13.g2cc4c95
pkgrel = 1
url = http://commanderx16.com/
install = x16-rom.install
@@ -14,8 +14,6 @@ pkgbase = x16-rom-git
provides = x16-rom
conflicts = x16-rom
source = git+https://github.com/X16Community/x16-rom.git
- source = https://raw.githubusercontent.com/commanderx16/x16-emulator/master/github-pandoc.css
sha256sums = SKIP
- sha256sums = 43e06186556036c7a40db6b743892b2cd7f150ffed5ea1e9fe3db0a6ceb23ff5
pkgname = x16-rom-git
diff --git a/PKGBUILD b/PKGBUILD
index adf62d0a56e8..d6c8c2c82772 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
# Contributor: Julien Savard <juju@juju2143.ca>
pkgname=x16-rom-git
-pkgver=r43.r1.g1866bb7
+pkgver=r43.r13.g2cc4c95
pkgrel=1
pkgdesc="ROM files for The 8-Bit Guy's Commander X16"
arch=('any')
@@ -17,10 +17,8 @@ replaces=()
options=()
install=x16-rom.install
changelog=
-source=("git+https://github.com/X16Community/x16-rom.git"
- "https://raw.githubusercontent.com/commanderx16/x16-emulator/master/github-pandoc.css")
-sha256sums=('SKIP'
- '43e06186556036c7a40db6b743892b2cd7f150ffed5ea1e9fe3db0a6ceb23ff5')
+source=("git+https://github.com/X16Community/x16-rom.git")
+sha256sums=('SKIP')
pkgver() {
cd "${pkgname%-git}"
@@ -30,15 +28,12 @@ pkgver() {
build() {
cd "${pkgname%-git}"
_pkgver1=${pkgver#r}
- make PRERELEASE_VERSION=${_pkgver1%%[^0-9]*}
- pandoc --from gfm --to html -c github-pandoc.css --standalone --metadata pagetitle="X16 KERNAL/BASIC/DOS ROM" README.md --output KERNAL-BASIC.html
+ make PRERELEASE_VERSION=${_pkgver1%%[^0-9]*} -j1
}
package() {
cd "${pkgname%-git}"
install -Dm644 build/x16/rom.bin "$pkgdir/usr/share/${pkgname%-git}/rom.bin"
install -Dm644 build/x16/rom_labels.h "$pkgdir/usr/include/x16/rom_labels.h"
- install -Dm644 ../github-pandoc.css "$pkgdir/usr/share/doc/${pkgname%-git}/github-pandoc.css"
- install -Dm644 KERNAL-BASIC.html "$pkgdir/usr/share/doc/${pkgname%-git}/KERNAL-BASIC.html"
}