summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 21:14:14 +0200
committersl1pkn072015-06-08 21:14:14 +0200
commitb0e19c88d197bcbee44ad507a04aeb77b2935332 (patch)
treeba9f4e80456859c8f1926cd9811056fed83a01be
downloadaur-b0e19c88d197bcbee44ad507a04aeb77b2935332.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD36
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..054028566a33
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = x262-git
+ pkgdesc = x264 with MPEG-2 video support (GIT version)
+ pkgver = 0.142.2633.bb887aa
+ pkgrel = 1
+ url = http://git.videolan.org/?p=x262.git
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = yasm
+ depends = glibc
+ depends = ffms2
+ provides = x262
+ conflicts = x262
+ source = git://git.videolan.org/x262.git
+ sha1sums = SKIP
+
+pkgname = x262-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6de75bc27f8e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Contributor: DrZaius <lou[at]fakeoutdoorsman.com>
+
+pkgname=x262-git
+pkgver=0.142.2633.bb887aa
+pkgrel=1
+pkgdesc="x264 with MPEG-2 video support (GIT version)"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('glibc' 'ffms2')
+makedepends=('git' 'yasm')
+url="http://git.videolan.org/?p=x262.git"
+source=('git://git.videolan.org/x262.git')
+provides=('x262')
+conflicts=('x262')
+sha1sums=('SKIP')
+
+pkgver() {
+ cd x262
+ echo "$(sh version.sh | grep 'X264_POINTVER' | cut -d '"' -f2 | tr M m | tr ' ' .)"
+}
+
+build() {
+ cd x262
+ ./configure \
+ --prefix=/usr \
+ --disable-lsmash
+
+ make
+}
+
+package() {
+ make -C x262 DESTDIR="${pkgdir}" install
+ rm -fr "${pkgdir}/usr/bin/x262"
+ mv "${pkgdir}/usr/bin/x264" "${pkgdir}/usr/bin/x262"
+}