summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvlad2015-07-08 15:46:38 +0300
committervlad2015-07-08 15:46:38 +0300
commit02e00243bc1bd352d51c5588a175d126f175f0b1 (patch)
tree3d6e357836d0ba358e378e0a90b6b0843d90b4eb
downloadaur-02e00243bc1bd352d51c5588a175d126f175f0b1.tar.gz
Initial import
-rw-r--r--.AURINFO19
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD41
3 files changed, 80 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..e1ecbac25b55
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,19 @@
+pkgbase = x264-git
+ pkgdesc = H.264 video encoder and library
+ pkgver = 0.r2377.1ca7bb9
+ pkgrel = 2
+ url = http://www.videolan.org/developers/x264.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = yasm
+ depends = glibc
+ provides = x264
+ provides = libx264
+ conflicts = x264
+ conflicts = libx264
+ source = git://git.videolan.org/x264.git
+
+pkgname = x264-git
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2aa27f73fffa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = x264-git
+ pkgdesc = H.264 video encoder and library
+ pkgver = 0.r2377.1ca7bb9
+ pkgrel = 2
+ url = http://www.videolan.org/developers/x264.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = yasm
+ depends = glibc
+ provides = x264
+ provides = libx264
+ conflicts = x264
+ conflicts = libx264
+ source = git://git.videolan.org/x264.git
+ md5sums = SKIP
+
+pkgname = x264-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83bb1a7399bd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: PelPix <kylebloss[at]pelpix[dot]info>
+# Contributor: DrZaius <lou[at]fakeoutdoorsman.com>
+# Contributor: zhuqin <zhuqin83[at]gmail>
+# Contributor: pressh <pressh[at]gmail>
+
+pkgname=x264-git
+_gitname="x264"
+pkgver=0.r2377.1ca7bb9
+pkgrel=2
+pkgdesc="H.264 video encoder and library"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('glibc')
+makedepends=('git' 'yasm')
+url="http://www.videolan.org/developers/x264.html"
+conflicts=('x264' 'libx264')
+provides=('x264' 'libx264')
+source=('git://git.videolan.org/x264.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_gitname
+ printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $_gitname
+
+ ./configure --enable-shared
+ make
+}
+
+package() {
+ cd $_gitname
+
+ make DESTDIR="$pkgdir" \
+ bindir=/usr/bin \
+ libdir=/usr/lib \
+ includedir=/usr/include \
+ install
+}