summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArch Nous2015-06-11 15:51:36 +0300
committerArch Nous2015-06-11 15:51:36 +0300
commit36e7edc3d39f1a70fa0fb8199ce6e76f36cf683f (patch)
treeecab2f9737a9fa4852d74f1f228cffd68b917448
downloadaur-36e7edc3d39f1a70fa0fb8199ce6e76f36cf683f.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD25
-rw-r--r--x264transcode.install16
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d5e72c039a8a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = x264transcode
+ pkgdesc = Script for automated backup of DVDs, SD VOB and HD M2TS files. Rips ALL subtitles, ALL audio tracks and chapter info into a MKV container. Video stream is cropped to get rid of black borders.
+ pkgver = 0.3.1
+ pkgrel = 1
+ url = http://www2.warwick.ac.uk/fac/sci/csc/people/computingstaff/jaroslaw_zachwieja/x264transcode
+ install = x264transcode.install
+ arch = any
+ license = GPL3
+ depends = ogmtools
+ depends = lsdvd
+ depends = mkvtoolnix
+ depends = dbus-python
+ depends = pygobject
+ optdepends = crswallow
+ source = https://github.com/downloads/jzachwieja/x264transcode/x264transcode-0.3.1.tar.gz
+ sha256sums = 301ce6b198c1580b777712711d3b59af08f5932dc263e3a01c51e886d85a8dce
+
+pkgname = x264transcode
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fedd91d5bd8b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Christos Nouskas <nous at archlinux dot us>
+
+pkgname=x264transcode
+pkgver=0.3.1
+pkgrel=1
+pkgdesc="Script for automated backup of DVDs, SD VOB and HD M2TS files. Rips ALL subtitles, ALL audio tracks and chapter info into a MKV container. Video stream is cropped to get rid of black borders."
+arch=(any)
+url="http://www2.warwick.ac.uk/fac/sci/csc/people/computingstaff/jaroslaw_zachwieja/x264transcode"
+license=('GPL3')
+depends=('ogmtools' 'lsdvd' 'mkvtoolnix' 'dbus-python' 'pygobject')
+optdepends=('crswallow')
+source=(https://github.com/downloads/jzachwieja/$pkgname/$pkgname-$pkgver.tar.gz)
+install=$pkgname.install
+
+package() {
+ cd $srcdir/$pkgname
+ sed -i s/python/python2/ autorip.py
+ install -d -m755 $pkgdir/usr/bin
+ install -d -m755 $pkgdir/usr/share/$pkgname
+ install -D -m755 ./*.sh ./*.py $pkgdir/usr/bin/
+ install -D -m644 CHANGELOG COPYING README autoripper.conf $pkgdir/usr/share/$pkgname
+}
+
+#
+sha256sums=('301ce6b198c1580b777712711d3b59af08f5932dc263e3a01c51e886d85a8dce')
diff --git a/x264transcode.install b/x264transcode.install
new file mode 100644
index 000000000000..0a39b951f151
--- /dev/null
+++ b/x264transcode.install
@@ -0,0 +1,16 @@
+post_install() {
+cat << EOF
+Copy /usr/share/x264transcode/autoripper.conf to ~/.autoripper.conf
+and edit to suit your setup.
+
+=====
+In the rare case you have a mplayer variant without the mencoder
+binary (e.g mplayer-minimal), you'll have to install the mencoder
+package separately (or use either extra/mplayer or AUR/mplayer-svn)
+=====
+EOF
+}
+
+post_upgrade() {
+ post_install $1
+}