summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorReibax2022-08-16 00:35:05 +0200
committerReibax2022-10-17 23:46:26 +0200
commitec4986d9f13ebd1076d18b5ebd21bc9ba7092cd6 (patch)
tree04fc318bfd3935803028da4da51540db5f51ee4c
parente2a74c029bd77ff8a68d376ab3d66f3ddb55723b (diff)
downloadaur-ec4986d9f13ebd1076d18b5ebd21bc9ba7092cd6.tar.gz
Use linux mount.h instead of sys mount.h
This patch fixes compilation on ArchLinux. Using sys/mount.h instead of linux/mount.h resulted in compilation errors due to redefinition of fsconfig_command and mount_attr.
-rw-r--r--0001-Fix-redefinition-compile-error.patch25
-rw-r--r--PKGBUILD9
2 files changed, 32 insertions, 2 deletions
diff --git a/0001-Fix-redefinition-compile-error.patch b/0001-Fix-redefinition-compile-error.patch
new file mode 100644
index 000000000000..14db694fe5e3
--- /dev/null
+++ b/0001-Fix-redefinition-compile-error.patch
@@ -0,0 +1,25 @@
+From b6d591bf246f65aba75a822364215b8bcb08fafe Mon Sep 17 00:00:00 2001
+From: Reibax <reibax@gmail.com>
+Date: Tue, 16 Aug 2022 00:13:36 +0200
+Subject: [PATCH] Fix redefinition compile error
+
+---
+ src/onmainwindow_privat.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/onmainwindow_privat.h b/src/onmainwindow_privat.h
+index d37f4c9..f4002bd 100644
+--- a/src/onmainwindow_privat.h
++++ b/src/onmainwindow_privat.h
+@@ -84,7 +84,7 @@
+ #include "contest.h"
+
+ #if !defined Q_OS_WIN
+-#include <sys/mount.h>
++#include <linux/mount.h>
+ #ifdef Q_OS_LINUX
+ #include <X11/Xatom.h>
+ #include <X11/xpm.h>
+--
+2.37.2
+
diff --git a/PKGBUILD b/PKGBUILD
index 5cf0fac82d86..81ced9728699 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,13 +15,17 @@ depends=('qt5-x11extras' 'qt5-svg'
# FS#48088
optdepends=('xorg-xauth: may be required by X2goservers running a different linux distribution giving MIT-COOKIE errors')
source=(https://code.x2go.org/releases/source/${pkgname}/${pkgname}-${pkgver}.tar.gz{,.asc}
- reproducible-man-gzip.patch)
+ reproducible-man-gzip.patch 0001-Fix-redefinition-compile-error.patch)
sha256sums=('c9953267c40fa67119ad96a73bacb1f266196da2059f0cdcd1b8d5199421d12a'
'SKIP'
- '8b309f0cc99d89737f47e57b79afdc9cccdd36ca3d0772040b1c3fdc0399a4d2')
+ '8b309f0cc99d89737f47e57b79afdc9cccdd36ca3d0772040b1c3fdc0399a4d2'
+ 'afdb3a67d3ab875dbd924112350cc662f354e6dd6a6159c8349cad369f86f30d')
validpgpkeys=('9BFBAEE86C0AA5FFBF2207829AF46B3025771B31' # Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
'1AD23D1B8F087A35AB74BDE9F4A7678C9C6B0B2B') # "X2go Git Administrator <git-admin@x2go.org>"
+export CFLAGS+=' -fcommon'
+export CXXFLAGS+=' -fcommon'
+
prepare() {
cd ${pkgname}-${pkgver}
sed -i "s:-o root -g root ::" Makefile
@@ -29,6 +33,7 @@ prepare() {
# remove timestamp to solve reproducible build
patch -Np1 -i ../reproducible-man-gzip.patch
+ patch -Np1 -i ../0001-Fix-redefinition-compile-error.patch
}
build() {