summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpezcurrel2015-10-19 17:26:18 +0200
committerpezcurrel2015-10-19 17:26:18 +0200
commita8d6a9b0f4f923444df3d950e998d60207e41b37 (patch)
tree67418bb3bbf6320ad3473fefeebcb29db60948dd
downloadaur-a8d6a9b0f4f923444df3d950e998d60207e41b37.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD38
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1f5b6d3298c8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = x2vnc-no-xinerama
+ pkgdesc = Lets you use a monitor on a different computer as if it was connected to the one you are using. This version disables xinerama, fixing two related bugs.
+ pkgver = 1.7.2
+ pkgrel = 4
+ url = http://fredrik.hubbe.net/x2vnc.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libxss
+ depends = libxrandr
+ depends = libxxf86dga
+ conflicts = x2vnc
+ source = http://fredrik.hubbe.net/x2vnc/x2vnc-1.7.2.tar.gz
+ md5sums = f23f86bcfa12a80eaeb886ab9b3ee447
+
+pkgname = x2vnc-no-xinerama
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a09e373440a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: pezcurrel <pezcurrel [at] tiscali.it>
+# Contributor: SpepS <dreamspepser [at] yahoo.it>
+# Contributor: simo <simo [at] archlinux.org>
+# Contributor: Tom Newsom <Jeepster [at] gmx.co.uk>
+
+# This version disables xinerama support, fixing two bugs: the impossibility
+# to drag objects on the remote screen and the mouse pointer showing up in an
+# unexpected position on the remote screen soon after crossing the defined
+# border on the local one.
+# See also https://bugzilla.redhat.com/show_bug.cgi?id=627164
+# The patch proposed there, that disables dga support, does work too, but makes
+# the mouse pointer move clumsily on the remote screen; disabling xinerama
+# support seems to work better)
+
+pkgname=x2vnc-no-xinerama
+_realpkgname=x2vnc
+pkgver=1.7.2
+pkgrel=4
+pkgdesc="Lets you use a monitor on a different computer as if it was connected to the one you are using. This version disables xinerama, fixing two related bugs."
+arch=('i686' 'x86_64')
+url="http://fredrik.hubbe.net/x2vnc.html"
+license=('GPL')
+conflicts=('x2vnc')
+depends=('libxss' 'libxrandr' 'libxxf86dga')
+source=("http://fredrik.hubbe.net/x2vnc/$_realpkgname-$pkgver.tar.gz")
+md5sums=('f23f86bcfa12a80eaeb886ab9b3ee447')
+
+build() {
+ cd "$srcdir/$_realpkgname-$pkgver"
+ xmkmf
+ make
+}
+
+package() {
+ cd "$srcdir/$_realpkgname-$pkgver"
+ install -d "$pkgdir"/usr/{bin,share/man/man1}
+ make DESTDIR="$pkgdir/" install
+}