summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhil Sidler2017-12-03 12:46:34 -0600
committerPhil Sidler2017-12-03 12:46:34 -0600
commita2f053ca0d092f005bef8053347b2e132e819a59 (patch)
treef6aa480e0489b6f12ed8f4693ab9f5d650cbc926
downloadaur-a2f053ca0d092f005bef8053347b2e132e819a59.tar.gz
initial
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD50
-rw-r--r--x3270.desktop8
-rw-r--r--x3270.fontpath3
-rw-r--r--x3270.install36
5 files changed, 128 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..748316724fb9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = x3270-git
+ pkgdesc = IBM 3270 terminal emulator for the X Window System
+ pkgver = 3.6alpha1.r1814
+ pkgrel = 1
+ url = http://x3270.bgp.nu/
+ install = x3270.install
+ arch = x86_64
+ license = BSD
+ license = MIT
+ makedepends = imake
+ makedepends = openssl
+ makedepends = libx11
+ makedepends = libxaw
+ makedepends = libxt
+ makedepends = xbitmaps
+ makedepends = xorg-bdftopcf
+ depends = libxaw
+ provides = x3270
+ conflicts = x3270
+ backup = etc/x3270/ibm_hosts
+ source = x3270-git::git+https://git.code.sf.net/p/x3270/code
+ source = x3270.install
+ source = x3270.fontpath
+ source = x3270.desktop
+ sha256sums = SKIP
+ sha256sums = 1007f7a7a5ad41749dbc70cc7ca6e259ec7c272dd82d210d2dd0f2fca6c18444
+ sha256sums = 3cbd44463bf70a5a5983f4fa2ef51adaf4d3e0217638fc1f7fc12c1566c31d2b
+ sha256sums = c45ded78fe9a2fe2acff1a5df53366647310165931b39bab942ab06296e13b1c
+
+pkgname = x3270-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bac3e795d28c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: # Maintainer: Phil Sidler <phil_sidler@hotmail.com>
+# Parts copied from x3270 package by tuftedocelot <tuftedocelot@fastmail.fm>
+pkgname=x3270-git
+pkgver=3.6alpha1.r1814
+pkgrel=1
+pkgdesc="IBM 3270 terminal emulator for the X Window System"
+arch=('x86_64')
+url="http://x3270.bgp.nu/"
+license=('BSD' 'MIT')
+depends=('libxaw')
+makedepends=('imake' 'openssl' 'libx11' 'libxaw' 'libxt' 'xbitmaps' 'xorg-bdftopcf')
+provides=("x3270")
+conflicts=("x3270")
+backup=(etc/x3270/ibm_hosts)
+install=x3270.install
+source=("$pkgname::git+https://git.code.sf.net/p/x3270/code"
+ x3270.install
+ x3270.fontpath
+ x3270.desktop)
+sha256sums=('SKIP'
+ '1007f7a7a5ad41749dbc70cc7ca6e259ec7c272dd82d210d2dd0f2fca6c18444'
+ '3cbd44463bf70a5a5983f4fa2ef51adaf4d3e0217638fc1f7fc12c1566c31d2b'
+ 'c45ded78fe9a2fe2acff1a5df53366647310165931b39bab942ab06296e13b1c')
+pkgver() {
+ cd "${srcdir}/${pkgbase}"
+ printf "%s.r%s" "$(sed -n 's/^version=\"\([^\"]*\)\"/\1/p' Common/version.txt)" "$(git rev-list --count HEAD)"
+}
+build() {
+ cd "${pkgname}"
+ ./configure --enable-x3270 --prefix=/usr --sysconfdir=/etc --with-fontdir=/usr/share/fonts/3270
+ make || return 1
+ }
+package() {
+ cd ${pkgname}
+ make DESTDIR="${pkgdir}" install || return 1
+
+ chmod 644 "${pkgdir}"/etc/x3270/ibm_hosts
+
+ mkdir -pm755 "${pkgdir}/etc/X11/xorg.conf.d"
+ mkdir -pm755 "${pkgdir}/usr/share/fonts/3270"
+ mkdir -pm755 "${pkgdir}/usr/share/applications"
+ mkdir -pm755 "${pkgdir}/usr/share/pixmaps"
+ mkdir -pm755 "${pkgdir}/usr/share/licenses/${pkgname}"
+
+ install -m644 "${srcdir}/x3270.fontpath" "${pkgdir}/etc/X11/xorg.conf.d/60-${pkgname}.conf"
+ install -m644 "${srcdir}/x3270.desktop" "${pkgdir}/usr/share/applications/"
+ install -m644 "${srcdir}/${pkgname}/x3270/x3270-icon2.xpm" "${pkgdir}/usr/share/pixmaps/"
+ install -m644 "${srcdir}/${pkgname}/x3270/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
+
diff --git a/x3270.desktop b/x3270.desktop
new file mode 100644
index 000000000000..5fe505ed6d7b
--- /dev/null
+++ b/x3270.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=x3270
+Comment=IBM 3270 terminal emulator for the X Window System
+Icon=/usr/share/pixmaps/x3270-icon2.xpm
+Exec=/usr/bin/x3270
+Terminal=false
+Type=Application
+Categories=Application;Utility;
diff --git a/x3270.fontpath b/x3270.fontpath
new file mode 100644
index 000000000000..4675ff85b4ed
--- /dev/null
+++ b/x3270.fontpath
@@ -0,0 +1,3 @@
+Section "Files"
+ FontPath "/usr/share/fonts/3270/"
+EndSection
diff --git a/x3270.install b/x3270.install
new file mode 100644
index 000000000000..5b25ff098f32
--- /dev/null
+++ b/x3270.install
@@ -0,0 +1,36 @@
+# arg 1: the new package version
+post_install() {
+ /usr/bin/fc-cache
+ # the following is ineffective unless install is done in the foreground, locally
+ /usr/bin/xset fp+ /usr/share/fonts/3270 fp rehash
+ /bin/true
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+pre_upgrade() {
+ pre_remove $1
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ post_install $1
+}
+
+# arg 1: the old package version
+pre_remove() {
+ # the following is ineffective unless uninstall is done in the foreground, locally
+ /usr/bin/xset fp- /usr/share/fonts/3270 fp rehash
+ /bin/true
+}
+
+# arg 1: the old package version
+post_remove() {
+ /usr/bin/fc-cache
+}
+
+op=$1
+shift
+$op $*
+