summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Waller2016-03-31 07:55:48 -0700
committerEric Waller2016-03-31 07:55:48 -0700
commitffd6dbfa82735b8a199b781b1cc0daaae54db617 (patch)
tree8ed259dcbdbc800c6f989afef2f7eb0ccb5c1f1d
downloadaur-ffd6dbfa82735b8a199b781b1cc0daaae54db617.tar.gz
Initial Release
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD40
-rw-r--r--x48.install28
3 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3ba6349c6fd9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = x48
+ pkgdesc = An HP 48 x/sx/g/gx Emulator
+ pkgver = 0.6.4
+ pkgrel = 1
+ url = http://sourceforge.net/projects
+ install = x48.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = readline
+ depends = libxext
+ provides = x48=0.6.4
+ conflicts = x48
+ options = !emptydirs
+ source = source::http://sourceforge.net/projects/x48.berlios/files/x48-0.6.4.tar.bz2/download
+ source = sxrom::http://sourceforge.net/projects/x48.berlios/files/sxrom-d.bz2/download
+ source = gxrom::http://sourceforge.net/projects/x48.berlios/files/gxrom-r.bz2/download
+ md5sums = 700e631f8924a991b35d8a86ce60aab7
+ md5sums = a1adf17500c61774160afaa72894e936
+ md5sums = a08249c9a75d52671045dbb9c35321fa
+
+pkgname = x48
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..157058c16d2b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Eric Waller <ewwaller+aur@gmail.com>
+
+pkgname=x48
+pkgver=0.6.4
+pkgrel=1
+pkgdesc="An HP 48 x/sx/g/gx Emulator"
+arch=(i686 x86_64)
+url="http://sourceforge.net/projects"
+license=(GPL3)
+depends=(readline libxext)
+makedepends=()
+
+provides=(${pkgname%-*}=$pkgver)
+conflicts=(${pkgname%-*})
+options=(!emptydirs)
+install=$pkgname.install
+source=(source::${url}/${pkgname%-*}.berlios/files/${pkgname}-${pkgver}.tar.bz2/download
+ sxrom::${url}/${pkgname%-*}.berlios/files/sxrom-d.bz2/download
+ gxrom::${url}/${pkgname%-*}.berlios/files/gxrom-r.bz2/download)
+
+
+md5sums=('700e631f8924a991b35d8a86ce60aab7'
+ 'a1adf17500c61774160afaa72894e936'
+ 'a08249c9a75d52671045dbb9c35321fa')
+
+build() {
+ aclocal
+ autoheader
+ automake --add-missing --copy -Wno-portability
+ autoconf
+ ./configure --prefix /usr
+ make
+}
+
+package() {
+ install -Dm644 ../gxrom ${pkgdir}/usr/share/${pkgname}/gxrom
+ install -Dm644 ../sxrom ${pkgdir}/usr/share/${pkgname}/sxrom
+ make DESTDIR="$pkgdir/" install
+ rm -r ${pkgdir}/usr/share/X11
+}
diff --git a/x48.install b/x48.install
new file mode 100644
index 000000000000..fb7e6e5cca0e
--- /dev/null
+++ b/x48.install
@@ -0,0 +1,28 @@
+post_install() {
+ cat <<EOF
+
+To make use of X48 you will need a HP-48 ROM.
+
+In 2000 Hewlett-Packard released the 48SX/GX ROMS to the
+public. The roms for the hp48sx and the hp48gx are included in
+this package.
+
+The first the time program is run, use either
+ x48 -rom /usr/share/x48/gxrom -initialize
+or
+ x48 -rom /usr/share/x48/sxrom -initialize
+to have X48 place the ROM for the desired emulator in \$HOME/.hp48
+for subsequent use.
+
+EOF
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+op=$1
+shift
+$op $*
+
+# vim:set ts=2 sw=2 et: