summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatMoul2023-10-08 04:27:15 +0200
committerMatMoul2023-10-08 04:27:15 +0200
commit33428b375db7b6e89807af4108a8233d4be260ae (patch)
tree61b901a288962b86f255ec20c7aa6e1e261028ea
parent7efc6e77bcf6b1da9b1b6fab4f26fe9109f0a2a6 (diff)
downloadaur-33428b375db7b6e89807af4108a8233d4be260ae.tar.gz
Version 0.30.0.r1.9f2e2fc-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD20
-rw-r--r--runtime_options.c_1.patch13
-rw-r--r--ui_text.c_1.patch13
4 files changed, 52 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 262aba3f92fb..4d383775c6e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,29 @@
pkgbase = x48ng-git
pkgdesc = A reboot of the x48 HP 48 emulator
- pkgver = 0.22.0.r2.5263a13
+ pkgver = 0.30.0.r1.9f2e2fc
pkgrel = 1
url = https://github.com/gwenhael-le-moine/x48ng
install = x48ng-git.install
arch = any
license = GPL2
makedepends = git
+ makedepends = lua
+ depends = readline
+ depends = ncurses
depends = sdl12-compat
depends = sdl_gfx
- depends = readline
+ depends = libx11
+ depends = libxext
+ depends = xterm
+ depends = xorg-mkfontscale
+ depends = xorg-fonts-misc
provides = x48ng
conflicts = x48ng
- source = git+https://github.com/gwenhael-le-moine/x48ng.git#commit=5263a13833362ab3d1ad889eeb4369c40c60ca04
+ source = git+https://github.com/gwenhael-le-moine/x48ng.git#commit=9f2e2fc6747fc8e2608756d2d885496e89787320
+ source = runtime_options.c_1.patch
+ source = ui_text.c_1.patch
sha256sums = SKIP
+ sha256sums = 995ede538e1a5aecabdfe2d7d0fa45277f8cfc5c16ed467d2a74a7375a5d1e3d
+ sha256sums = 94550704486e179bf0e1495b5fb6fc55c9663fe61d6e44dd45cff8bfe840f301
pkgname = x48ng-git
diff --git a/PKGBUILD b/PKGBUILD
index bb5e7f1219ee..a7e98d49c9a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,31 @@
_githubuser=gwenhael-le-moine
_githubrepo=x48ng
-#_gitcommit=a8724da1b7e68693102afce2395414a340ac9748
-_gitcommit=5263a13833362ab3d1ad889eeb4369c40c60ca04
+_gitcommit=9f2e2fc6747fc8e2608756d2d885496e89787320
pkgname=x48ng-git
-pkgver=0.22.0.r2.5263a13
+pkgver=0.30.0.r1.9f2e2fc
pkgrel=1
pkgdesc='A reboot of the x48 HP 48 emulator'
arch=('any')
url="https://github.com/${_githubuser}/${_githubrepo}"
license=('GPL2')
-depends=('sdl12-compat' 'sdl_gfx' 'readline')
-makedepends=('git')
+depends=('readline' 'ncurses' 'sdl12-compat' 'sdl_gfx' 'libx11' 'libxext' 'xterm' 'xorg-mkfontscale' 'xorg-fonts-misc')
+makedepends=('git' 'lua')
install="${pkgname}.install"
provides=('x48ng')
conflicts=('x48ng')
-source=("git+https://github.com/${_githubuser}/${_githubrepo}.git#commit=${_gitcommit}")
-sha256sums=('SKIP')
+source=("git+https://github.com/${_githubuser}/${_githubrepo}.git#commit=${_gitcommit}" 'runtime_options.c_1.patch' 'ui_text.c_1.patch')
+sha256sums=('SKIP'
+ '995ede538e1a5aecabdfe2d7d0fa45277f8cfc5c16ed467d2a74a7375a5d1e3d'
+ '94550704486e179bf0e1495b5fb6fc55c9663fe61d6e44dd45cff8bfe840f301')
build() {
cd "${_githubrepo}"
- make
+ # sed -i 's|<ncursesw/curses.h>|<curses.h>|g' src/ui_text.c
+ patch --forward --strip=1 --input="${srcdir}/runtime_options.c_1.patch"
+ patch --forward --strip=1 --input="${srcdir}/ui_text.c_1.patch"
+ make clean-all && make GUI=x11
}
package() {
diff --git a/runtime_options.c_1.patch b/runtime_options.c_1.patch
new file mode 100644
index 000000000000..b4ee0b6c61b0
--- /dev/null
+++ b/runtime_options.c_1.patch
@@ -0,0 +1,13 @@
+diff --git a/src/runtime_options.c b/src/runtime_options.c
+index 742ec0d..854d160 100644
+--- a/src/runtime_options.c
++++ b/src/runtime_options.c
+@@ -429,7 +429,7 @@ int parse_args( int argc, char* argv[] )
+ }
+
+ lua_getglobal( config_lua_values, "config_dir" );
+- configDir = ( char* )luaL_optstring( config_lua_values, -1, ".config/x48ng" );
++ configDir = ( char* )luaL_optstring( config_lua_values, -1, "x48ng" );
+
+ lua_getglobal( config_lua_values, "rom" );
+ romFileName = ( char* )luaL_optstring( config_lua_values, -1, "rom" );
diff --git a/ui_text.c_1.patch b/ui_text.c_1.patch
new file mode 100644
index 000000000000..7e82f49ebb01
--- /dev/null
+++ b/ui_text.c_1.patch
@@ -0,0 +1,13 @@
+diff --git a/src/ui_text.c b/src/ui_text.c
+index 9fad6e3..9505a38 100644
+--- a/src/ui_text.c
++++ b/src/ui_text.c
+@@ -10,7 +10,7 @@
+ #include <unistd.h>
+ #include <locale.h>
+
+-#include <ncursesw/curses.h>
++#include <curses.h>
+
+ #include "emulator.h"
+ #include "romio.h"