summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatMoul2024-04-12 22:13:16 +0200
committerMatMoul2024-04-12 22:13:16 +0200
commit9e73f14dada35e70440afab941c66042201ba1e2 (patch)
tree98d4b1c086d11654d3fa9ae017e869f96900a9d8
parent4f2d32b0017c3426660793c0704607d5dd24b300 (diff)
downloadaur-9e73f14dada35e70440afab941c66042201ba1e2.tar.gz
Version 0.37.0.r1.91f6bbe-1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--PKGBUILD.back.236
-rw-r--r--PKGBUILD.bak33
4 files changed, 74 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f88dd34f7fa..e9365c365b7b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = x48ng-git
pkgdesc = A reboot of the x48 HP 48 emulator
- pkgver = 0.36.90.r6.14a7d63
+ pkgver = 0.37.0.r1.91f6bbe
pkgrel = 1
url = https://github.com/gwenhael-le-moine/x48ng
install = x48ng-git.install
@@ -19,7 +19,7 @@ pkgbase = x48ng-git
depends = xorg-fonts-misc
provides = x48ng
conflicts = x48ng
- source = git+https://github.com/gwenhael-le-moine/x48ng.git#commit=14a7d63fb59c85910a03adad7b86b676975f0c1a
+ source = git+https://github.com/gwenhael-le-moine/x48ng.git#commit=91f6bbe0ce832968c2cc7fd38f2126364e14803a
source = ui_text.c_1.patch
sha256sums = SKIP
sha256sums = 94550704486e179bf0e1495b5fb6fc55c9663fe61d6e44dd45cff8bfe840f301
diff --git a/PKGBUILD b/PKGBUILD
index a263304c42d6..e7592b51885d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
_githubuser=gwenhael-le-moine
_githubrepo=x48ng
-_gitcommit=14a7d63fb59c85910a03adad7b86b676975f0c1a
+_gitcommit=91f6bbe0ce832968c2cc7fd38f2126364e14803a
pkgname=x48ng-git
-pkgver=0.36.90.r6.14a7d63
+pkgver=0.37.0.r1.91f6bbe
pkgrel=1
pkgdesc='A reboot of the x48 HP 48 emulator'
arch=('any')
@@ -29,5 +29,5 @@ build() {
package() {
cd "${_githubrepo}"
make DESTDIR="${pkgdir}/" install
- install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/x48ng/LICENSE"
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/x48ng/LICENSE"
}
diff --git a/PKGBUILD.back.2 b/PKGBUILD.back.2
new file mode 100644
index 000000000000..080b0fefe0e8
--- /dev/null
+++ b/PKGBUILD.back.2
@@ -0,0 +1,36 @@
+# Maintainer: MatMoul <matmoul at the google email domain which is .com>
+
+_githubuser=gwenhael-le-moine
+_githubrepo=x48ng
+_gitcommit=e7e31f72ccb7bd9d821b30aaf4cc8954c02d4e52
+
+pkgname=x48ng-git
+pkgver=0.36.90.r9.e7e31f7
+pkgrel=1
+pkgdesc='A reboot of the x48 HP 48 emulator'
+arch=('any')
+url="https://github.com/${_githubuser}/${_githubrepo}"
+license=('GPL2')
+depends=('readline' 'ncurses' 'sdl12-compat' 'sdl_gfx' 'libx11' 'libxext' 'xterm' 'xorg-mkfontscale' 'xorg-fonts-misc')
+makedepends=('git' 'lua')
+install="${pkgname}.install"
+provides=('x48ng')
+conflicts=('x48ng')
+source=("git+https://github.com/${_githubuser}/${_githubrepo}.git#commit=${_gitcommit}" 'ui_text.c_1.patch')
+sha256sums=('SKIP'
+ '94550704486e179bf0e1495b5fb6fc55c9663fe61d6e44dd45cff8bfe840f301')
+
+build() {
+ cd "${_githubrepo}"
+ patch --forward --strip=1 --input="${srcdir}/ui_text.c_1.patch"
+ # must be discussed on the upstream ...
+ sed -i '/--print-config/d' Makefile
+ # end temp sed
+ make clean-all && make GUI=x11
+}
+
+package() {
+ cd "${_githubrepo}"
+ make DESTDIR="${pkgdir}/" install
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/x48ng/LICENSE"
+}
diff --git a/PKGBUILD.bak b/PKGBUILD.bak
new file mode 100644
index 000000000000..d3be758e1d1c
--- /dev/null
+++ b/PKGBUILD.bak
@@ -0,0 +1,33 @@
+# Maintainer: MatMoul <matmoul at the google email domain which is .com>
+
+_githubuser=gwenhael-le-moine
+_githubrepo=x48ng
+_gitcommit=e7e31f72ccb7bd9d821b30aaf4cc8954c02d4e52
+
+pkgname=x48ng-git
+pkgver=0.36.90.r9.e7e31f7
+pkgrel=1
+pkgdesc='A reboot of the x48 HP 48 emulator'
+arch=('any')
+url="https://github.com/${_githubuser}/${_githubrepo}"
+license=('GPL2')
+depends=('readline' 'ncurses' 'sdl12-compat' 'sdl_gfx' 'libx11' 'libxext' 'xterm' 'xorg-mkfontscale' 'xorg-fonts-misc')
+makedepends=('git' 'lua')
+install="${pkgname}.install"
+provides=('x48ng')
+conflicts=('x48ng')
+source=("git+https://github.com/${_githubuser}/${_githubrepo}.git#commit=${_gitcommit}" 'ui_text.c_1.patch')
+sha256sums=('SKIP'
+ '94550704486e179bf0e1495b5fb6fc55c9663fe61d6e44dd45cff8bfe840f301')
+
+build() {
+ cd "${_githubrepo}"
+ patch --forward --strip=1 --input="${srcdir}/ui_text.c_1.patch"
+ make clean-all && make GUI=x11
+}
+
+package() {
+ cd "${_githubrepo}"
+ make DESTDIR="${pkgdir}/" install
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/x48ng/LICENSE"
+}