summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatMoul2023-05-02 22:16:38 +0200
committerMatMoul2023-05-02 22:16:38 +0200
commita9f5216a2ca74c303cc23d0bf81fcc14b7f7d295 (patch)
treed502495235a6279f3b19968043a26264dcad50bd
downloadaur-a9f5216a2ca74c303cc23d0bf81fcc14b7f7d295.tar.gz
Version 0.9.9.r1.1bdffaf-1
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD33
-rw-r--r--patch-desktop-file-019
-rw-r--r--x48ng-git.install25
4 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f00a714dd1bd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = x48ng-git
+ pkgdesc = A reboot of the x48 HP 48 emulator
+ pkgver = 0.9.9.r1.1bdffaf
+ pkgrel = 1
+ url = https://github.com/gwenhael-le-moine/x48ng
+ install = x48ng-git.install
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = readline
+ depends = libxext
+ depends = xterm
+ provides = x48
+ provides = checkrom
+ provides = dump2rom
+ provides = mkcard
+ source = git+https://github.com/gwenhael-le-moine/x48ng.git#commit=1bdffaf18c8279089ff50a67ed09252263dc7c73
+ source = patch-desktop-file-01
+ sha256sums = SKIP
+ sha256sums = e18c85ecf9d451e77a6ea764e356182bc6af11c46a91ff28b0d48cb8d8b0c644
+
+pkgname = x48ng-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..31fdda7f7b26
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: MatMoul <matmoul at the google email domain which is .com>
+
+_githubuser=gwenhael-le-moine
+_githubrepo=x48ng
+_gitcommit=1bdffaf18c8279089ff50a67ed09252263dc7c73
+
+pkgname=x48ng-git
+pkgver=0.9.9.r1.1bdffaf
+pkgrel=1
+pkgdesc='A reboot of the x48 HP 48 emulator'
+arch=('any')
+url="https://github.com/${_githubuser}/${_githubrepo}"
+license=('GPL2')
+depends=('readline' 'libxext' 'xterm')
+makedepends=('git')
+install="${pkgname}.install"
+provides=('x48' 'checkrom' 'dump2rom' 'mkcard')
+source=("git+https://github.com/${_githubuser}/${_githubrepo}.git#commit=${_gitcommit}"
+ 'patch-desktop-file-01')
+sha256sums=('SKIP'
+ 'e18c85ecf9d451e77a6ea764e356182bc6af11c46a91ff28b0d48cb8d8b0c644')
+
+build() {
+ cd "${_githubrepo}"
+ patch x48ng.desktop ../patch-desktop-file-01
+ make
+}
+
+package() {
+ cd "${_githubrepo}"
+ make DESTDIR="${pkgdir}/" install
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/x48ng/LICENSE"
+}
diff --git a/patch-desktop-file-01 b/patch-desktop-file-01
new file mode 100644
index 000000000000..9f3e5e9f1462
--- /dev/null
+++ b/patch-desktop-file-01
@@ -0,0 +1,9 @@
+6,8c6,9
+< Exec=@PREFIX@/bin/x48
+< Name=x48
+< Icon=@PREFIX@/share/x48/hplogo.png
+---
+> Exec=@PREFIX@/bin/x48ng -smallFont fixed -mediumFont fixed -largeFont fixed -connFont fixed
+> Name=x48ng
+> Icon=@PREFIX@/share/x48ng/hplogo.png
+> Categories=Utility;
diff --git a/x48ng-git.install b/x48ng-git.install
new file mode 100644
index 000000000000..15082ccd2181
--- /dev/null
+++ b/x48ng-git.install
@@ -0,0 +1,25 @@
+post_install() {
+ cat <<EOF
+
+To make use of X48 you will need a HP-48 ROM.
+
+In 2000 Hewlett-Packard released the 48SX/GX ROMS to the
+public. The roms for the hp48sx and the hp48gx are included in
+this package.
+
+The first the time program is run, as user, use either
+ x48ng -smallFont fixed -mediumFont fixed -largeFont fixed -connFont fixed -rom /usr/share/x48ng/ROMs/gxrom-r -initialize
+or
+ x48ng -smallFont fixed -mediumFont fixed -largeFont fixed -connFont fixed -rom /usr/share/x48ng/ROMs/sxrom-j -initialize
+to have X48 place the ROM for the desired emulator in \$HOME/.hp48
+for subsequent use.
+
+On ArchLinux with KDE (Not test with other DE), You need to use this cmd line to start x48ng
+ x48ng -smallFont fixed -mediumFont fixed -largeFont fixed -connFont fixed
+
+EOF
+}
+
+post_upgrade() {
+ post_install
+}