summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarc Boocha2017-09-19 10:59:05 +0800
committerMarc Boocha2017-09-19 10:59:05 +0800
commit9c7d98baf640fbe83e24b05c77a35a2f9d2fb6be (patch)
tree9e329bd819645e124e3f3108c59e3eda7d30b262
parentf8053ad46ea746e12e4ba6e24a6a3abe49040e48 (diff)
downloadaur-9c7d98baf640fbe83e24b05c77a35a2f9d2fb6be.tar.gz
Fixed sysroot
Signed-off-by: Marc Boocha <marcboocha@gmail.com> On branch master Your branch is up-to-date with 'origin/master'. Changes to be committed: modified: .SRCINFO modified: PKGBUILD
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD21
2 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3fd51115d9ac..4cb87d06ecbc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = x86_64-elf-binutils
pkgdesc = A set of programs to assemble and manipulate binary and object files for the x86_64-elf target
pkgver = 2.29
- pkgrel = 1
+ pkgrel = 2
url = http://www.gnu.org/software/binutils/
arch = x86_64
license = GPL
depends = zlib
+ options = !emptydirs
+ options = !docs
source = http://mirrors.kernel.org/gnu/binutils/binutils-2.29.tar.xz
source = libiberty-ignore-cflags.patch
sha256sums = 0b871e271c4c620444f8264f72143b4d224aa305306d85dd77ab8dce785b1e85
diff --git a/PKGBUILD b/PKGBUILD
index 92328279479b..d978c49b259a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,18 @@
# Maintainer: Marc Boocha <marcboocha@gmail.com>
_target=x86_64-elf
-pkgname=$_target-binutils
+_sysroot=/usr/lib/${_target}
+_pkgname=binutils
+
+pkgname=$_target-${_pkgname}
pkgver=2.29
-pkgrel=1
+pkgrel=2
pkgdesc='A set of programs to assemble and manipulate binary and object files for the x86_64-elf target'
arch=(x86_64)
url='http://www.gnu.org/software/binutils/'
license=(GPL)
depends=(zlib)
+options=(!emptydirs !docs)
source=("http://mirrors.kernel.org/gnu/binutils/binutils-$pkgver.tar.xz"
"libiberty-ignore-cflags.patch")
sha256sums=('0b871e271c4c620444f8264f72143b4d224aa305306d85dd77ab8dce785b1e85'
@@ -16,7 +20,7 @@ sha256sums=('0b871e271c4c620444f8264f72143b4d224aa305306d85dd77ab8dce785b1e85'
_basedir=binutils-$pkgver
prepare() {
- cd $_basedir
+ cd ${srcdir}/${_pkgname}-${pkgver}
patch -p1 -i $srcdir/libiberty-ignore-cflags.patch
@@ -28,8 +32,9 @@ build() {
$srcdir/$_basedir/configure \
--target=$_target \
- --with-sysroot=/usr/$_target \
- --prefix=/usr \
+ --prefix=${_sysroot} \
+ --bindir=/usr/bin \
+ --with-sysroot=${_sysroot} \
--disable-nls \
--disable-werror
@@ -39,7 +44,7 @@ build() {
check() {
cd binutils-build
- # do not abort on errors - manually check log files
+ # do not abort on errors - manually check log files
make -k check
}
@@ -48,6 +53,6 @@ package() {
make DESTDIR="$pkgdir" install
- # Remove info and make since it expected already present by host compiler
- rm -vr "$pkgdir"/usr/share/{info,man}
+ # Remove info and make since it expected already present by host compiler
+ rm -r ${pkgdir}/${_sysroot}/share/{info,man}
}