summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2015-09-30 15:19:45 +0200
committerChristian Hesse2015-09-30 15:19:45 +0200
commit537933965dfbb1e26024417b413a9aeb34112c4d (patch)
treed0e6138d920a9cd3ab6acab953666e9ea03ab1e7
downloadaur-537933965dfbb1e26024417b413a9aeb34112c4d.tar.gz
initial import of x86info 1.30.137-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD42
-rw-r--r--x86info.install10
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d50649669dff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = x86info
+ pkgdesc = A CPU identification utility. Provides more info than /proc/cpuinfo.
+ pkgver = 1.30.137
+ pkgrel = 1
+ url = http://www.codemonkey.org.uk/projects/x86info/
+ install = x86info.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ source = git://github.com/dankamongmen/x86info#commit=27ace37d
+ sha256sums = SKIP
+
+pkgname = x86info
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d9d1bd12e6c9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Christian Hesse <mail@eworm.de>
+# Contributor: Jakub Luzny <limoto94@gmail.com>
+
+pkgname=x86info
+_commit=27ace37d
+pkgver=1.30.137
+pkgrel=1
+pkgdesc='A CPU identification utility. Provides more info than /proc/cpuinfo.'
+arch=('i686' 'x86_64')
+url="http://www.codemonkey.org.uk/projects/x86info/"
+license=('GPL')
+install=x86info.install
+source=("git://github.com/dankamongmen/x86info#commit=${_commit}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}/"
+
+ # Version 1.30 is latest release, but it does not have a tag.
+ # So count from commit...
+ echo "1.30.$(git rev-list --count b69b850c50..)"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}/"
+
+ make
+
+ cd lsmsr/
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}/"
+
+ install -D -m0775 x86info "${pkgdir}/usr/bin/x86info"
+ install -D -m0775 lsmsr/lsmsr "${pkgdir}/usr/bin/lsmsr"
+ install -D -m0644 x86info.1 "${pkgdir}/usr/share/man/man1/x86info.1"
+ install -D -m0644 lsmsr/lsmsr.8 "${pkgdir}/usr/share/man/man8/lsmsr.8"
+}
+
diff --git a/x86info.install b/x86info.install
new file mode 100644
index 000000000000..1cd03102a374
--- /dev/null
+++ b/x86info.install
@@ -0,0 +1,10 @@
+post_install() {
+ echo "You must have loaded cpuid and msr modules to work."
+}
+
+op=$1
+shift
+[ "$(type -t "$op")" = "function" ] && $op "$@"
+
+# vim:set ts=2 sw=2 et:
+