summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXyne2015-06-21 02:21:18 +0000
committerXyne2015-06-21 02:21:18 +0000
commite58d1d938e09889b433dedfbed8d69e6c9eb7050 (patch)
tree7b3834c77ac9857902677561caf3472a054480a9
downloadaur-e58d1d938e09889b433dedfbed8d69e6c9eb7050.tar.gz
Initial import.
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD32
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..603db0d8cfb2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = xac
+ pkgdesc = A markdown- and Pandoc-based content management system (CMS).
+ pkgver = 2014.12
+ pkgrel = 1
+ url = http://xyne.archlinux.ca/projects/xac
+ arch = any
+ license = GPL
+ depends = python3
+ depends = haskell-pandoc
+ optdepends = graphviz: plugin support
+ optdepends = openbabel: plugin support
+ optdepends = tex2png: plugin support
+ optdepends = source-highlight: plugin support
+ source = http://xyne.archlinux.ca/projects/xac/src/xac-2014.12.tar.xz
+ source = http://xyne.archlinux.ca/projects/xac/src/xac-2014.12.tar.xz.sig
+ md5sums = 9f8cd934fc20ab20958a8224739e6588
+ md5sums = 4251d3264dacf31e6c3cd19cdae03c37
+ sha512sums = 6717766a87f4ab2699a5fdd43a781ab5752aa337a7a3fb07463bc2cbb2f1f0307e9a743d3253aabcb8aef957c8a59e5c7004634d7700e215574a1aa65dd7489b
+ sha512sums = 23949d6593e310bfde593ad007a82f2cc1c1cbcbc5eeabe0fa935c07a0482a9125aff090a5f2f4e67885cb1c16578dfb15e93b878ff8eb2fe053aca984823f30
+
+pkgname = xac
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..94c1e4c4ebea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+#Maintainer: Xyne <ac xunilhcra enyx, backwards>
+pkgname=xac
+pkgver=2014.12
+pkgrel=1
+pkgdesc='A markdown- and Pandoc-based content management system (CMS).'
+arch=(any)
+license=(GPL)
+url="http://xyne.archlinux.ca/projects/xac"
+depends=(python3 haskell-pandoc)
+optdepends=('graphviz: plugin support' 'openbabel: plugin support' 'tex2png: plugin support' 'source-highlight: plugin support')
+source=(
+ http://xyne.archlinux.ca/projects/xac/src/xac-2014.12.tar.xz
+ http://xyne.archlinux.ca/projects/xac/src/xac-2014.12.tar.xz.sig
+)
+sha512sums=(
+ 6717766a87f4ab2699a5fdd43a781ab5752aa337a7a3fb07463bc2cbb2f1f0307e9a743d3253aabcb8aef957c8a59e5c7004634d7700e215574a1aa65dd7489b
+ 23949d6593e310bfde593ad007a82f2cc1c1cbcbc5eeabe0fa935c07a0482a9125aff090a5f2f4e67885cb1c16578dfb15e93b878ff8eb2fe053aca984823f30
+)
+md5sums=(
+ 9f8cd934fc20ab20958a8224739e6588
+ 4251d3264dacf31e6c3cd19cdae03c37
+)
+validpgpkeys=('EC3CBE7F607D11E663149E811D1F0DC78F173680')
+
+package ()
+{
+ cd "$srcdir/$pkgname-$pkgver"
+ python3 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+}
+
+
+# vim: set ts=2 sw=2 et: