summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Schmidpeter2021-11-06 04:39:31 +0100
committerChristoph Schmidpeter2021-11-06 06:48:11 +0100
commitfa25a6964c99fdbb13aaf3fd90559bb575fda761 (patch)
tree17ec34810812f80f6267bfeebafd55ab16f56a28
parentd22ce48cc59b3e397604bac5a207c72f2dcca72d (diff)
downloadaur-fa25a6964c99fdbb13aaf3fd90559bb575fda761.tar.gz
Reworked the package to adapt to the new Azure build pipeline and create needed symlinks in /usr/lib/mono
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD39
2 files changed, 34 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8189c839aca3..d36bd389947c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = xamarin-android
pkgdesc = Xamarin android build from jenkins.mono-project
- pkgver = 9.2.99.172
- pkgrel = 3
+ pkgver = 11.4.99.0
+ pkgrel = 1
url = https://github.com/xamarin/xamarin-android
arch = x86_64
license = MIT
+ makedepends = tar
depends = mono>=5.0.0
depends = libzip
provides = xamarin-android
conflicts = xamarin-android
options = !strip
- source = xamarin.android-oss_9.2.99.172.deb::https://jenkins.mono-project.com/view/Xamarin.Android/job/xamarin-android-linux/lastSuccessfulBuild/Azure/processDownloadRequest/xamarin-android/xamarin.android-oss_9.2.99.172_amd64.deb
+ source = xamarin-android.zip::https://artprodcus3.artifacts.visualstudio.com/Ad0adf05a-e7d7-4b65-96fe-3f3884d42038/6fd3d886-57a5-4e31-8db7-52a1b47c07a8/_apis/artifact/cGlwZWxpbmVhcnRpZmFjdDovL3hhbWFyaW4vcHJvamVjdElkLzZmZDNkODg2LTU3YTUtNGUzMS04ZGI3LTUyYTFiNDdjMDdhOC9idWlsZElkLzQzNjU5L2FydGlmYWN0TmFtZS9pbnN0YWxsZXJzLXVuc2lnbmVkKy0rTGludXg1/content?format=zip
sha256sums = SKIP
pkgname = xamarin-android
-
diff --git a/PKGBUILD b/PKGBUILD
index 64178597906c..ebd5548bc466 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,43 @@
-
pkgname=xamarin-android
-_pkgver=9.2.99.172
-pkgver=${_pkgver//[+-]/_}
-pkgrel=3
+pkgver=11.4.99.0
+pkgrel=1
pkgdesc="Xamarin android build from jenkins.mono-project"
arch=('x86_64')
depends=('mono>=5.0.0' 'libzip')
+makedepends=('tar')
options=(!strip)
provides=('xamarin-android')
conflicts=('xamarin-android')
url="https://github.com/xamarin/xamarin-android"
license=('MIT')
-source=("xamarin.android-oss_${_pkgver}.deb::https://jenkins.mono-project.com/view/Xamarin.Android/job/xamarin-android-linux/lastSuccessfulBuild/Azure/processDownloadRequest/xamarin-android/xamarin.android-oss_${_pkgver}_amd64.deb")
+_pkgname="xamarin.android-oss-v${pkgver}_Linux-${arch}_main_5e1e5cb7-Release"
+source=("$pkgname.zip::https://artprodcus3.artifacts.visualstudio.com/Ad0adf05a-e7d7-4b65-96fe-3f3884d42038/6fd3d886-57a5-4e31-8db7-52a1b47c07a8/_apis/artifact/cGlwZWxpbmVhcnRpZmFjdDovL3hhbWFyaW4vcHJvamVjdElkLzZmZDNkODg2LTU3YTUtNGUzMS04ZGI3LTUyYTFiNDdjMDdhOC9idWlsZElkLzQzNjU5L2FydGlmYWN0TmFtZS9pbnN0YWxsZXJzLXVuc2lnbmVkKy0rTGludXg1/content?format=zip")
sha256sums=('SKIP')
+prepare() {
+ msg2 "Unpacking nested source folder. This may take a while..."
+ tar -xf "installers-unsigned - Linux/$_pkgname.tar.bz2" --strip-components=3
+
+ msg2 "Removing bin/tr folder, as it would clash with coreutil's tr command..."
+ rm -rf "bin/tr"
+
+ msg2 "Removing include/mono-2.0 folder, as it would clash with mono..."
+ rm -rf "include/mono-2.0"
+}
+
package() {
- cd "${srcdir}"
- bsdtar xf data.tar.xz
- chmod -R g-w usr
- mv usr "${pkgdir}"
+ # Install main folders
+ for folder in bin lib include; do
+ msg2 "Installing $folder folder..."
+ find "$folder" -type f -exec install -Dm755 {} "$pkgdir/usr/"{} \;
+ done
+
+ msg2 "Creating symlinks so that mono can find this package..."
+ mkdir -p $pkgdir/usr/lib/mono/{xbuild,xbuild-frameworks}
+ _linksrcdir=$pkgdir/usr/lib/xamarin.android
+ _linkdstdir=$pkgdir/usr/lib/mono
+ ln -sr "$_linksrcdir/xbuild/Novell" "$_linkdstdir/xbuild"
+ ln -sr "$_linksrcdir/xbuild/Xamarin" "$_linkdstdir/xbuild"
+ ln -sr "$_linksrcdir/xbuild-frameworks/Microsoft.Android" "$_linkdstdir/xbuild-frameworks"
+ ln -sr "$_linksrcdir/xbuild-frameworks/MonoAndroid" "$_linkdstdir/xbuild-frameworks"
}