summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorge Matthies2019-07-30 10:43:39 +0200
committerTorge Matthies2019-07-30 10:43:39 +0200
commita6d77453e709b4d4c627cced46d90c7c1ac4c80c (patch)
treefe6c221be4eb416a8072901f307e93339abee045
parent1bd368c7472afd1b3b3ca59049d6165a92957996 (diff)
downloadaur-a6d77453e709b4d4c627cced46d90c7c1ac4c80c.tar.gz
Version 9.4.99.r2284.gc2ff29f2-1
-rw-r--r--PKGBUILD20
-rw-r--r--runtime-xml.patch25
2 files changed, 30 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8cd61a5daadd..7111d2ee9e0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -202,10 +202,10 @@ sha256sums=('SKIP'
if [ true = "${_include_proprietary}" ]; then
pkgname=xamarin-android-proprietary-git
pkgdesc="$pkgdesc (Including proprietary components)"
- source+=('https://download.visualstudio.microsoft.com/download/pr/d78329f2-f4e6-440d-97d1-5a1b6b52a4ee/9595a9df7a9ceebe52c761cf18e68440/xamarin.android.sdk-9.4.0.34.vsix'
+ source+=('https://download.visualstudio.microsoft.com/download/pr/402a338a-8d27-4e64-b9c1-0d93e01e3183/3fe416138114726f3cdd74b85c8123dc/xamarin.android.sdk-9.5.0.27.vsix'
runtime-xml.patch)
- sha256sums+=('15a42e686b6491b4aaf2bfa7656bf3297908573968fb910095e52eeb7c9aaeb0'
- '48e5378c14adb3316d504df39e23c331fe9ff28ff3d1d9593ff995caa7d8eb69')
+ sha256sums+=('70de08a0afb7febe45f6147acf12d13aa7aa66ec14d93ddfb88d757e4a97316d'
+ '353d503f404294812040cbaf9c2183f25e62fd56f06cc205ae25eee5f3ae0887')
provides+=('xamarin-android-git')
conflicts+=('xamarin-android-git')
fi
@@ -248,7 +248,6 @@ _prepare_Java_Interop() {
_prepare_mono() {
local Submodules
- cd external/mono
Submodules=(Newtonsoft.Json
api-doc-tools
@@ -301,8 +300,6 @@ _prepare_mono() {
git submodule update "external/cecil"
cd ../..
-
- cd ../..
}
_prepare_submodules() {
@@ -313,7 +310,6 @@ _prepare_submodules() {
dlfcn-win32
libzip
mman-win32
- mono
mxe
nrefactory
opentk
@@ -331,6 +327,16 @@ _prepare_submodules() {
"_prepare_${Submodule//[^0-9A-Za-z_]/_}"
fi
done
+
+ if [ -e mono ]; then
+ cd mono
+ git fetch --all
+ else
+ git clone "${srcdir}/mono" mono
+ cd mono
+ fi
+ _prepare_mono
+ cd ..
}
prepare() {
diff --git a/runtime-xml.patch b/runtime-xml.patch
index 80647085325e..c9f3c69d5250 100644
--- a/runtime-xml.patch
+++ b/runtime-xml.patch
@@ -2,7 +2,7 @@ diff --git a/build-tools/proprietary/proprietary.projitems b/build-tools/proprie
index 9789a987..684212ea 100644
--- a/build-tools/proprietary/proprietary.projitems
+++ b/build-tools/proprietary/proprietary.projitems
-@@ -18,6 +18,10 @@
+@@ -18,6 +18,26 @@
<Link>$(_DestinationDir)%(Filename)%(Extension)</Link>
<CopyToOutputDirectory>PreserveNewest</CopyToOutputDirectory>
</Content>
@@ -10,13 +10,22 @@ index 9789a987..684212ea 100644
+ <Link>$(_DestinationDir)%(Filename)%(Extension)</Link>
+ <CopyToOutputDirectory>PreserveNewest</CopyToOutputDirectory>
+ </Content>
++ <Content Include="$(_SourceDir)ICSharpCode.SharpZipLib.dll">
++ <Link>$(_DestinationDir)%(Filename)%(Extension)</Link>
++ <CopyToOutputDirectory>PreserveNewest</CopyToOutputDirectory>
++ </Content>
++ <Content Include="$(_SourceDir)INIFileParser.dll">
++ <Link>$(_DestinationDir)%(Filename)%(Extension)</Link>
++ <CopyToOutputDirectory>PreserveNewest</CopyToOutputDirectory>
++ </Content>
++ <Content Include="$(_SourceDir)Xamarin.Android.Bindings.*.targets">
++ <Link>$(_DestinationDir)%(Filename)%(Extension)</Link>
++ <CopyToOutputDirectory>PreserveNewest</CopyToOutputDirectory>
++ </Content>
++ <Content Include="$(_SourceDir)Xamarin.Installer.*">
++ <Link>$(_DestinationDir)%(Filename)%(Extension)</Link>
++ <CopyToOutputDirectory>PreserveNewest</CopyToOutputDirectory>
++ </Content>
<Content Include="$(_SourceDir)Mono.AndroidTools.*">
<Link>$(_DestinationDir)%(Filename)%(Extension)</Link>
<CopyToOutputDirectory>PreserveNewest</CopyToOutputDirectory>
-@@ -43,4 +47,4 @@
- <CopyToOutputDirectory>PreserveNewest</CopyToOutputDirectory>
- </Content>
- </ItemGroup>
--</Project>
-\ No newline at end of file
-+</Project>