summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgrufo2019-03-02 18:57:09 +0000
committergrufo2019-03-02 18:57:09 +0000
commitd6ad7554e6195636f0422cb51cfc339077d4afa4 (patch)
treec35736ed4375163c87d4a9c39183a3df597ab829
parent89564b13acecb3818ac0e6252ee50dfb59e8c327 (diff)
downloadaur-d6ad7554e6195636f0422cb51cfc339077d4afa4.tar.gz
New release (7.3.2-0)
-rw-r--r--.SRCINFO6
-rwxr-xr-xPKGBUILD36
-rw-r--r--xampp.install6
3 files changed, 26 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 04ac2260ff11..93f8eb615bc9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xampp
pkgdesc = A free and open source cross-platform web server package (LAMP Stack), consisting mainly of the Apache HTTP Server, MySQL database, and interpreters for scripts written in the PHP and Perl programming languages
- pkgver = 7.2.10
+ pkgver = 7.3.2
pkgrel = 1
url = http://www.apachefriends.org/
install = xampp.install
@@ -17,10 +17,10 @@ pkgbase = xampp
sha256sums = 9aa2e9b2ec768b7e0d5394cf27653a7c9d0291a890d058293109f1aeace79150
sha256sums = 595de672753af57c4abf1b4549530bba02b004bd45dfa82054d58ea3a174a4e6
sha256sums = 3df1d2fa8a8dbba21944045503b94315e5b7bc38b968ca5a816a57b83c6fd77a
- source_x86_64 = https://www.apachefriends.org/xampp-files/7.2.10/xampp-linux-x64-7.2.10-0-installer.run
+ source_x86_64 = https://downloads.sourceforge.net/project/xampp/XAMPP%20Linux/7.3.2/xampp-linux-x64-7.3.2-0-installer.run
source_x86_64 = org.freedesktop.xampp-manager.policy
source_x86_64 = xampp-manager-polkit
- sha256sums_x86_64 = 7af597647957b84ba455c7298dc51ced04c713b6e1312d67f951d259e7bc7531
+ sha256sums_x86_64 = b2dd3d90e7286ec6334b1c471481d34a4cb6d909d4cd289cc9d2c6ccd71d3ea9
sha256sums_x86_64 = 4092631d86ec1c3a155bfec76ea2c8433426a13f12a7a5866f843a099f1ca418
sha256sums_x86_64 = 210beb9372baf79f01b783db6d93a0f9a07289af64dd72d9e09baecd0799a76b
diff --git a/PKGBUILD b/PKGBUILD
index 7f2f69eed64f..c4a799709a1a 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Contributor: alegotta <algottardi at disroot dot org>
pkgname='xampp'
-pkgver='7.2.10'
+pkgver='7.3.2'
pkgrel=1
pkgdesc="A free and open source cross-platform web server package (LAMP Stack), consisting mainly of the Apache HTTP Server, MySQL database, and interpreters for scripts written in the PHP and Perl programming languages"
url="http://www.apachefriends.org/"
@@ -18,7 +18,7 @@ makedepends=('fakeuser-git' 'proot')
source=('lampp.service'
'xampp-manager.desktop'
'xampp-manager.png')
-source_x86_64=("https://www.apachefriends.org/xampp-files/${pkgver}/${pkgname}-linux-x64-${pkgver}-0-installer.run"
+source_x86_64=("https://downloads.sourceforge.net/project/${pkgname}/XAMPP%20Linux/${pkgver}/${pkgname}-linux-x64-${pkgver}-0-installer.run"
'org.freedesktop.xampp-manager.policy'
'xampp-manager-polkit')
options=(!strip)
@@ -26,19 +26,25 @@ install='xampp.install'
sha256sums=('9aa2e9b2ec768b7e0d5394cf27653a7c9d0291a890d058293109f1aeace79150'
'595de672753af57c4abf1b4549530bba02b004bd45dfa82054d58ea3a174a4e6'
'3df1d2fa8a8dbba21944045503b94315e5b7bc38b968ca5a816a57b83c6fd77a')
-sha256sums_x86_64=('7af597647957b84ba455c7298dc51ced04c713b6e1312d67f951d259e7bc7531'
+sha256sums_x86_64=('b2dd3d90e7286ec6334b1c471481d34a4cb6d909d4cd289cc9d2c6ccd71d3ea9'
'4092631d86ec1c3a155bfec76ea2c8433426a13f12a7a5866f843a099f1ca418'
'210beb9372baf79f01b783db6d93a0f9a07289af64dd72d9e09baecd0799a76b')
+# Make sure to synchronize the UUID declared here with the one declared in `xampp.install`
+_mysql_uuid=992
+
_fakeadd_error() {
- echo 'Due to limitations of the .run file of this package, you must have a mysql user'
- echo 'in your system prior to its build.'
echo
- echo 'You can create a mysql user by doing:'
+ echo 'A problem occurred while attempting to launch fakeuser. Due to limitations of'
+ echo 'the .run file of this package, you must create a mysql user in your system'
+ echo 'before building the package.'
+ echo
+ echo 'You can create a mysql user by launching:'
+ echo
+ echo " groupadd mysql -g ${_mysql_uuid}"
+ echo " useradd -u ${_mysql_uuid} -r -g mysql -s /bin/false mysql"
echo
- echo ' groupadd mysql -g 992'
- echo ' useradd -u 992 -r -g mysql -s /bin/false mysql'
return 1
@@ -46,11 +52,6 @@ _fakeadd_error() {
prepare() {
- cd "${srcdir}"
-
- # Against proot error `proot info: pid XXXX: terminated with signal 11`
- export PROOT_NO_SECCOMP=1
-
# Enable fakeadd under fakeroot environment
export LD_PRELOAD='/usr/lib/fakeuser/libfakeuser.so'
@@ -65,15 +66,16 @@ package() {
msg 'Creating a temporary mysql user/group with fakeadd...'
getent group mysql > /dev/null || fakeadd -G -n mysql -g 992 || _fakeadd_error
- getent passwd mysql > /dev/null || fakeadd -U -n mysql -g 992 -u 992 -s /bin/false || _fakeadd_error
+ getent passwd mysql > /dev/null || fakeadd -U -n mysql -g 992 -u 992 || _fakeadd_error
msg 'Extracting package (this might take several minutes, don'\''t give up!)...'
chmod +x "${srcdir}/${pkgname}-linux-x64-${pkgver}-0-installer.run"
- proot -0 -b "${pkgdir}/opt/lampp:/opt/lampp" "${srcdir}/${pkgname}-linux-x64-${pkgver}-0-installer.run" \
- --mode unattended --disable-components 'xampp_developer_files' --debuglevel 4 --launchapps 0 \
- --debugtrace "${srcdir}/bitrock_debug.log"
+ PROOT_NO_SECCOMP=1 proot -0 \
+ -b "${pkgdir}/opt/lampp:/opt/lampp" \
+ "${srcdir}/${pkgname}-linux-x64-${pkgver}-0-installer.run" \
+ --mode unattended --disable-components 'xampp_developer_files' --debuglevel 4 --launchapps 0 --debugtrace 'bitrock_debug.log'
msg 'Copying executables and launcher...'
diff --git a/xampp.install b/xampp.install
index d58258302b82..61125ae77cde 100644
--- a/xampp.install
+++ b/xampp.install
@@ -1,10 +1,12 @@
+_mysql_uuid=992
+
post_install() {
if ! id -u mysql &> /dev/null; then
echo "Creating user 'mysql'..."
- groupadd mysql -g 992
- useradd -u 992 -r -g mysql -s /bin/false mysql
+ groupadd mysql -g "${_mysql_uuid}"
+ useradd -u "${_mysql_uuid}" -r -g mysql -s /bin/false mysql
fi