summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel M. Capella2023-09-04 22:18:05 -0400
committerDaniel M. Capella2023-09-04 22:18:22 -0400
commit202e02ddec8ded3bed2fa5cab2bb60dbbf82646e (patch)
treef59b9dbf029a5163628b766b3d47b1639b69a7a6
parente62fdeccd0dc7f0109c50b154800084256b254dd (diff)
downloadaur-202e02ddec8ded3bed2fa5cab2bb60dbbf82646e.tar.gz
Update and sync with stable package
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD63
-rw-r--r--xandikos.sysusers.conf1
-rw-r--r--xandikos.tmpfiles.conf1
4 files changed, 53 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca7459394e3c..1fd3222de4ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xandikos-git
pkgdesc = Lightweight yet complete CardDAV/CalDAV server that backs onto a Git repository
- pkgver = 0.2.8.r178.g7816c4f
+ pkgver = 0.2.10.r1.g5b98fc8
pkgrel = 1
url = https://www.xandikos.org
arch = any
@@ -18,10 +18,15 @@ pkgbase = xandikos-git
depends = python-multidict
depends = python-vobject
optdepends = python-aiohttp-openmetrics: for metrics with the standalone server
+ optdepends = python-systemd: for systemd socket activation
optdepends = uwsgi-plugin-python: for the WSGI interface
provides = xandikos
conflicts = xandikos
source = git+https://github.com/jelmer/xandikos.git
+ source = xandikos.sysusers.conf
+ source = xandikos.tmpfiles.conf
b2sums = SKIP
+ b2sums = 086423882a085cb7fbecad3f53ad60aa6c322a545c180fe8b4c9f2bba5331fa52d6fc3e96ec068c589d3ab3e0b8f215e1a94473c511560188bd873b7ff5780d6
+ b2sums = be8df371a3cdd55e2efd4549251b44cbb5699762f14aa3dcb0e85cdbb3710d75fae8e38b615057f6da37fe744019aabc2c366136ca577a152cd03d380db189c2
pkgname = xandikos-git
diff --git a/PKGBUILD b/PKGBUILD
index 7d54acaaedee..36a771b0cfbf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,70 @@
# Maintainer: Daniel M. Capella <polyzen@archlinux.org>
-_name=xandikos
pkgname=xandikos-git
-pkgver=0.2.8.r178.g7816c4f
+_name=${pkgname%-git}
+pkgver=0.2.10.r1.g5b98fc8
pkgrel=1
pkgdesc='Lightweight yet complete CardDAV/CalDAV server that backs onto a Git repository'
arch=('any')
url=https://www.xandikos.org
license=('GPL3')
-depends=('python-aiohttp' 'python-defusedxml' 'python-dulwich'
- 'python-icalendar' 'python-jinja' 'python-multidict' 'python-vobject')
-makedepends=('git' 'python-build' 'python-installer' 'python-setuptools'
- 'python-wheel')
-optdepends=('python-aiohttp-openmetrics: for metrics with the standalone server'
- 'uwsgi-plugin-python: for the WSGI interface')
+depends=(
+ 'python-aiohttp'
+ 'python-defusedxml'
+ 'python-dulwich'
+ 'python-icalendar'
+ 'python-jinja'
+ 'python-multidict'
+ 'python-vobject'
+)
+makedepends=(
+ 'git'
+ 'python-build'
+ 'python-installer'
+ 'python-setuptools'
+ 'python-wheel'
+)
+optdepends=(
+ 'python-aiohttp-openmetrics: for metrics with the standalone server'
+ 'python-systemd: for systemd socket activation'
+ 'uwsgi-plugin-python: for the WSGI interface'
+)
provides=("$_name")
conflicts=("$_name")
-source=('git+https://github.com/jelmer/xandikos.git')
-b2sums=('SKIP')
+source=(
+ "git+https://github.com/jelmer/$_name.git"
+ "$_name.sysusers.conf"
+ "$_name.tmpfiles.conf"
+)
+b2sums=('SKIP'
+ '086423882a085cb7fbecad3f53ad60aa6c322a545c180fe8b4c9f2bba5331fa52d6fc3e96ec068c589d3ab3e0b8f215e1a94473c511560188bd873b7ff5780d6'
+ 'be8df371a3cdd55e2efd4549251b44cbb5699762f14aa3dcb0e85cdbb3710d75fae8e38b615057f6da37fe744019aabc2c366136ca577a152cd03d380db189c2')
+#validpgpkeys=('DC837EE14A7E37347E87061700806F2BD729A457') # Jelmer Vernooij <jelmer@jelmer.uk>
pkgver() {
- cd $_name
+ cd "$_name"
git describe --long --tags --match v\* | sed 's/v//;s/-/.r/;s/-/./'
}
build() {
- cd $_name
+ cd "$_name"
python -m build --wheel --skip-dependency-check --no-isolation
}
check() {
- cd $_name
- python -m unittest xandikos.tests.test_suite
+ cd "$_name"
+ make check
}
package() {
- cd $_name
+ install -Dm644 "$_name".sysusers.conf \
+ "$pkgdir"/usr/lib/sysusers.d/"$_name".conf
+ install -Dm644 "$_name".tmpfiles.conf \
+ "$pkgdir"/usr/lib/tmpfiles.d/"$_name".conf
+
+ cd "$_name"
python -m installer --destdir="$pkgdir" dist/*.whl
- install -Dm644 -t "$pkgdir"/usr/share/doc/$_name README.rst
- install -Dm644 -t "$pkgdir"/usr/share/doc/$_name/examples examples/*
- install -Dm644 -t "$pkgdir"/usr/share/man/man8 man/xandikos.8
+ install -Dm644 -t "$pkgdir"/usr/share/doc/"$_name" README.rst
+ install -Dm644 -t "$pkgdir"/usr/share/doc/"$_name"/examples examples/*
+ install -Dm644 -t "$pkgdir"/usr/share/man/man8 man/"$_name".8
}
diff --git a/xandikos.sysusers.conf b/xandikos.sysusers.conf
new file mode 100644
index 000000000000..8b47e9fd717f
--- /dev/null
+++ b/xandikos.sysusers.conf
@@ -0,0 +1 @@
+u xandikos - "Xandikos user" /var/lib/xandikos
diff --git a/xandikos.tmpfiles.conf b/xandikos.tmpfiles.conf
new file mode 100644
index 000000000000..a45e3c969323
--- /dev/null
+++ b/xandikos.tmpfiles.conf
@@ -0,0 +1 @@
+d /var/lib/xandikos 0750 xandikos xandikos