summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoakim Reinert2016-04-18 11:05:15 +0200
committerJoakim Reinert2016-04-18 11:05:15 +0200
commit093729f9bdc968cd78f141d7b442594c2bc5da03 (patch)
treeb532f7847c93aee66305b66f9a4ee6fd2e1464b8
downloadaur-093729f9bdc968cd78f141d7b442594c2bc5da03.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD43
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..906989edf8d0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Mon Apr 18 09:05:01 UTC 2016
+pkgbase = xapian-core-git
+ pkgdesc = Open source search engine library
+ pkgver = v1.3.5.30.g3e31415
+ pkgrel = 1
+ url = https://github.com/xapian/xapian
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = automake
+ makedepends = autoconf
+ makedepends = libtool
+ makedepends = help2man
+ depends = zlib
+ provides = xapian-core
+ conflicts = xapian-core
+ source = git://github.com/xapian/xapian
+ sha512sums = SKIP
+
+pkgname = xapian-core-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cefd29b7276f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# See http://wiki.archlinux.org/index.php/VCS_PKGBUILD_Guidelines
+# for more information on packaging from GIT sources.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=xapian-core-git
+pkgver=v1.3.5.30.g3e31415
+pkgrel=1
+pkgdesc="Open source search engine library"
+arch=('i686' 'x86_64')
+url="https://github.com/xapian/xapian"
+license=('GPL')
+depends=('zlib')
+makedepends=('git' 'automake' 'autoconf' 'libtool' 'help2man')
+provides=('xapian-core')
+conflicts=('xapian-core')
+source=("git://github.com/xapian/xapian")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/xapian"
+ git describe --long | sed 's/Release_//;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/xapian"
+ ./bootstrap --without-autotools xapian-core
+
+ cd "$srcdir/xapian/${pkgname/-git/}"
+ ./configure --prefix=/usr --enable-maintainer-mode
+ make
+}
+
+package() {
+ cd "$srcdir/xapian/${pkgname/-git/}"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: