summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbert Graef2015-09-15 18:09:42 +0200
committerAlbert Graef2015-09-15 18:09:42 +0200
commita83d442c4719fadc639d89dbf8b160e90997997a (patch)
tree94c077a7742e8adb8cdff6e7ff337d750046b68e
downloadaur-a83d442c4719fadc639d89dbf8b160e90997997a.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ba3805835a54
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = xapian-tcl-bindings
+ pkgdesc = Bindings allowing Xapian to be used from Tcl
+ pkgver = 1.2.21
+ pkgrel = 1
+ url = http://xapian.org/docs/bindings/tcl/
+ arch = i686
+ arch = x86_64
+ groups = xapian
+ license = GPL
+ makedepends = gcc
+ depends = tcl
+ depends = xapian-core
+ source = http://oligarchy.co.uk/xapian/1.2.21/xapian-bindings-1.2.21.tar.xz
+ md5sums = 33c598a26fcf92ab15af6c65475ab8de
+
+pkgname = xapian-tcl-bindings
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..785568c101b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Charles Goyard <cg@fsck.fr>
+
+pkgname=xapian-tcl-bindings
+_realname=xapian-bindings
+pkgver=1.2.21
+pkgrel=1
+pkgdesc="Bindings allowing Xapian to be used from Tcl"
+arch=(i686 x86_64)
+url="http://xapian.org/docs/bindings/tcl/"
+license=('GPL')
+groups=(xapian)
+depends=('tcl' 'xapian-core')
+makedepends=('gcc')
+source=(http://oligarchy.co.uk/xapian/${pkgver}/${_realname}-$pkgver.tar.xz)
+md5sums=('33c598a26fcf92ab15af6c65475ab8de')
+
+build() {
+ cd "$srcdir/${_realname}-$pkgver"
+ ./configure --prefix=/usr --with-tcl TCL_LIB=/usr/lib/tcllib
+ make
+}
+
+package() {
+ cd "$srcdir/${_realname}-$pkgver"
+ make DESTDIR="$pkgdir" install
+}
+# vim:set ts=2 sw=2 et: