summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorquininer2017-08-20 20:22:49 +0800
committerquininer2017-08-20 20:22:49 +0800
commit0af35f11f43c3a579926251cb3ae16f6be537dad (patch)
tree4563e8018c4f31aa4bc21776fc9de27613b11a88
downloadaur-0af35f11f43c3a579926251cb3ae16f6be537dad.tar.gz
init
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD30
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b7662415c907
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Sun Aug 20 09:53:06 UTC 2017
+pkgbase = xargo-git
+ pkgdesc = The sysroot manager that lets you build and customize std
+ pkgver = 0.3.8.222
+ pkgrel = 1
+ url = https://github.com/japaric/xargo
+ arch = i686
+ arch = x86_64
+ license = Apache
+ license = MIT
+ makedepends = rust
+ makedepends = cargo
+ depends = rust
+ depends = cargo
+ optdepends = rust-src: rust std source code
+ provides = xargo
+ conflicts = xargo
+ source = xargo::git+https://github.com/japaric/xargo
+ sha256sums = SKIP
+
+pkgname = xargo-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dec40ab996c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+pkgname=xargo-git
+_pkgname=xargo
+pkgdesc="The sysroot manager that lets you build and customize std"
+pkgrel=1
+pkgver=0.3.8.222
+arch=('i686' 'x86_64')
+conflicts=("xargo")
+provides=("xargo")
+url="https://github.com/japaric/xargo"
+license=('Apache' 'MIT')
+depends=('rust' 'cargo')
+makedepends=('rust' 'cargo')
+optdepends=('rust-src: rust std source code')
+source=("$_pkgname::git+https://github.com/japaric/xargo")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ echo "$(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2).$(git rev-list --count HEAD)"
+}
+
+build() {
+ cd $_pkgname
+ env CARGO_INCREMENTAL=0 cargo build --release
+}
+
+package() {
+ cd $_pkgname
+ install -D -m755 "$srcdir/$_pkgname/target/release/xargo" "$pkgdir/usr/bin/xargo"
+}