summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2015-06-28 08:44:02 +0200
committeraksr2015-06-28 08:44:02 +0200
commit1c210583e26783b691698e8e7bd836d54745d76e (patch)
tree2bacc91a8fce677fda2beb0aaacfc13946afc25c
downloadaur-1c210583e26783b691698e8e7bd836d54745d76e.tar.gz
Start.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD46
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b1205cb6f5f7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = xaric-git
+ pkgdesc = An IRC client similar to ircII, BotchX, or ircII EPIC.
+ pkgver = 20100001
+ pkgrel = 1
+ url = https://github.com/laeos/xaric
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ conflicts = xaric
+ source = xaric-git::git+https://github.com/laeos/xaric.git
+ md5sums = SKIP
+
+pkgname = xaric-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d59d28d431b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=xaric-git
+pkgver=20100001
+pkgrel=1
+epoch=
+pkgdesc="An IRC client similar to ircII, BotchX, or ircII EPIC."
+arch=('i686' 'x86_64')
+url="http://xaric.org/"
+url="https://github.com/laeos/xaric"
+license=('GPL')
+groups=()
+depends=('')
+makedepends=('git')
+optdepends=()
+checkdepends=()
+provides=()
+conflicts=('xaric')
+replaces=()
+backup=()
+options=()
+changelog=
+install=
+source=("$pkgname::git+https://github.com/laeos/xaric.git")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ ./autogen.sh
+ ./configure --exec_prefix=/usr \
+ --prefix=/usr \
+ --datarootdir=/usr/share/doc \
+ --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir/" install
+}
+