summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGianluca Boiano2018-11-13 17:24:34 +0100
committerGianluca Boiano2018-11-13 17:24:34 +0100
commit20d35f4bb324f6b13a1ac807705af41585989981 (patch)
tree67da4719b76a9bf10776bb81fb02226c29e34edb
parent8d1e393ec9f6366e822f63df483ad481e9975072 (diff)
downloadaur-20d35f4bb324f6b13a1ac807705af41585989981.tar.gz
xash3d-git: updated with new assets and new dev engine
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD43
-rw-r--r--xash3d4
-rwxr-xr-xxash3d.conf.d5
-rw-r--r--xash3d.desktop11
-rw-r--r--xash3d.pngbin0 -> 10759 bytes
6 files changed, 54 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b348c140814f..ab3346407bcc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xash3d-git
pkgdesc = A custom Gold Source engine rewritten from scratch
- pkgver = v0.19.1.r117.g257b72a0
+ pkgver = r188.b1db062
pkgrel = 1
url = http://xash.su/
arch = i686
@@ -10,12 +10,20 @@ pkgbase = xash3d-git
arch = armv7h
license = GPL3
makedepends = gcc
- depends = sdl2
depends = freetype2
depends = fontconfig
- source = xash3d-git::git+https://github.com/FWGS/xash3d.git
+ depends = sdl2
+ depends = vgui
+ source = xash3d-git::git+https://github.com/FWGS/xash3d-fwgs.git
+ source = xash3d
+ source = xash3d.png
+ source = xash3d.conf.d
+ source = xash3d.desktop
md5sums = SKIP
- depends_i686 = vgui
+ md5sums = e2507dc0ca2fcd5de9c8d485fa0382ae
+ md5sums = d55c1a1fcb5a8a36d80f61712a77f291
+ md5sums = f4475bb569ad292f6a3711b74ced7bab
+ md5sums = 60d714544048b0383a7e79cfaed96d78
depends_x86_64 = lib32-freetype2
depends_x86_64 = lib32-fontconfig
depends_x86_64 = lib32-sdl2
diff --git a/PKGBUILD b/PKGBUILD
index b04cc6fbfa5d..37227ea5fb3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,52 @@
# Maintainer: robertfoster
pkgname=xash3d-git
-pkgver=v0.19.1.r117.g257b72a0
+pkgver=r188.b1db062
pkgrel=1
pkgdesc="A custom Gold Source engine rewritten from scratch"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
url="http://xash.su/"
license=('GPL3')
-depends=('sdl2' 'freetype2' 'fontconfig')
-depends_i686=('vgui')
+depends=('freetype2' 'fontconfig' 'sdl2' 'vgui')
depends_x86_64=('lib32-freetype2' 'lib32-fontconfig' 'lib32-sdl2' 'lib32-vgui')
makedepends=('make' 'binutils' 'cmake')
makedepends=('gcc')
makedepends_x86_64=('gcc-multilib' 'lib32-gcc-libs')
-source=("$pkgname::git+https://github.com/FWGS/xash3d.git")
+source=("$pkgname::git+https://github.com/FWGS/xash3d-fwgs.git"
+ ${pkgname%%-git}
+ ${pkgname%%-git}.png
+ ${pkgname%%-git}.conf.d
+ ${pkgname%%-git}.desktop
+)
pkgver() {
cd $srcdir/$pkgname
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
cd $srcdir/$pkgname
git submodule init && git submodule update
- mkdir -p build
+ ./waf configure --prefix=/usr --vgui https://github.com/FWGS/vgui-dev
}
build() {
cd $srcdir/$pkgname
- cd build
- if [ "$CARCH" == "x86_64" ]; then
- cmake ../. -DHL_SDK_DIR=/usr/include/vgui -DXASH_SDL=yes \
- -DXASH_VGUI=yes -DCMAKE_C_FLAGS="-m32" \
- -DCMAKE_CXX_FLAGS="-m32" -DCMAKE_EXE_LINKER_FLAGS="-m32" \
- -DCMAKE_INSTALL_PREFIX=/usr -DLIB_INSTALL_DIR=lib32
- else
- cmake ../. -DHL_SDK_DIR=/usr/include/vgui -DXASH_SDL=yes \
- -DXASH_VGUI=yes -DCMAKE_INSTALL_PREFIX=/usr -DLIB_INSTALL_DIR=lib
- fi
-
- make -j2
+ ./waf build
}
package() {
cd $srcdir/$pkgname/
- cd build
- make DESTDIR="$pkgdir" V=1 install
+ ./waf --destdir="$pkgdir" install
+ mv $pkgdir/usr/lib $pkgdir/usr/lib32
+ install -Dm644 ../${pkgname%%-git}.conf.d $pkgdir/etc/conf.d/${pkgname%%-git}
+ install -Dm755 ../${pkgname%%-git} $pkgdir/usr/bin/${pkgname%%-git}
+ install -Dm644 ../${pkgname%%-git}.desktop $pkgdir/usr/share/applications/${pkgname%%-git}.desktop
+ install -Dm644 ../${pkgname%%-git}.png $pkgdir/usr/share/pixmaps/${pkgname%%-git}.png
}
-md5sums=('SKIP')
+md5sums=('SKIP'
+ 'e2507dc0ca2fcd5de9c8d485fa0382ae'
+ 'd55c1a1fcb5a8a36d80f61712a77f291'
+ 'f4475bb569ad292f6a3711b74ced7bab'
+ '60d714544048b0383a7e79cfaed96d78')
diff --git a/xash3d b/xash3d
new file mode 100644
index 000000000000..2dfba51d3d36
--- /dev/null
+++ b/xash3d
@@ -0,0 +1,4 @@
+#!/bin/sh
+. /etc/conf.d/xash3d
+/usr/lib32/xash3d/xash3d
+
diff --git a/xash3d.conf.d b/xash3d.conf.d
new file mode 100755
index 000000000000..ec7be897c0fe
--- /dev/null
+++ b/xash3d.conf.d
@@ -0,0 +1,5 @@
+# Set here the path where valve folder is placed
+export XASH3D_BASEDIR="path where is placed valve folder (check /etc/conf.d/xash3d)"
+
+# Don't move it if you don't know what does it mean
+export LD_LIBRARY_PATH+="/usr/lib32/xash3d"
diff --git a/xash3d.desktop b/xash3d.desktop
new file mode 100644
index 000000000000..7c7b4399558e
--- /dev/null
+++ b/xash3d.desktop
@@ -0,0 +1,11 @@
+#!/usr/bin/env xdg-open
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Xash3D FWGS
+Comment=Fork of Xash3D engine that ported to Android. Allows play Half-Life out-of-box.
+Exec=/usr/bin/xash3d
+Icon=xash3d
+Terminal=false
+Categories=Game
+
diff --git a/xash3d.png b/xash3d.png
new file mode 100644
index 000000000000..7d51241f7868
--- /dev/null
+++ b/xash3d.png
Binary files differ