summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornot_anonymous2018-02-20 11:10:48 -0700
committernot_anonymous2018-02-20 11:10:48 -0700
commit6dfc9e3de288a7ddb7d6933fb16f39cbac130ee3 (patch)
tree1f616580c16e1163d041039b9e290b60c8508bc4
downloadaur-6dfc9e3de288a7ddb7d6933fb16f39cbac130ee3.tar.gz
New package
-rw-r--r--.SRCINFO47
-rw-r--r--PKGBUILD66
-rw-r--r--xastir-festival.desktop16
-rw-r--r--xastir-speech9
-rw-r--r--xastir.desktop16
-rw-r--r--xastir.pngbin0 -> 236 bytes
6 files changed, 154 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c41ab887acd2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,47 @@
+pkgbase = xastir-fix
+ pkgdesc = HAM RADIO - Full featured APRS Tracking/Information Reporting System
+ pkgver = 2.1.0
+ pkgrel = 2
+ url = http://www.xastir.org/
+ arch = armv7h
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ makedepends = autoconf
+ makedepends = automake
+ makedepends = printproto-fix
+ depends = python
+ depends = openmotif
+ depends = shapelib
+ depends = libax25
+ depends = gdal
+ depends = graphicsmagick
+ depends = libxpm
+ depends = hamradio-menus
+ optdepends = festival: for speech systhesis
+ provides = xastir
+ conflicts = xastir-cvs
+ conflicts = xastir
+ replaces = xastir
+ source = https://github.com/Xastir/Xastir/archive/Release-2.1.0.tar.gz
+ source = https://github.com/Xastir/xastir-sounds/archive/v1.0.tar.gz
+ source = xastir.desktop
+ source = xastir-festival.desktop
+ source = xastir-speech
+ source = xastir.png
+ md5sums = 1b1abde576f2ebcd64695d1416c62af3
+ md5sums = c314946788a828d42d804670ad23e646
+ md5sums = 2a06e041a0dc5f20c1427a130613d793
+ md5sums = 2f8af994b7f5086d4ca2d951ced9019a
+ md5sums = e56e55a1c43038d4488fbdd429a0a755
+ md5sums = 0a7269113052d3bd2711b84ff2fda9d6
+ sha256sums = a481e6a6c035954041904352ec58f52240c06874a30dfb810001da489d40f43a
+ sha256sums = fd7b0d60386964b8a35ec2e504238d8393f9217e32607a6ddfaeac6bde7d4f4a
+ sha256sums = 555ee695b83e59ebd270a001d7947bad7c5168ea319d80a3dc7842981975f6ec
+ sha256sums = 3452ca25072da4ccbaad2a8f07a61f1685872e1874cd6b28e5e5571f734fb47b
+ sha256sums = c99ef0816e0509b7549abdcc41253be2e50499345acd63a19b7b4a17396873b4
+ sha256sums = 4d140434ccadb2772a08a23543bf3692f413d88cb9a39e0a9cf8b8470230e8c6
+
+pkgname = xastir-fix
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c56076c9eebc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Fixed due to printproto being incorrectly succumbed into xorgproto
+# (Succumed without any files being incorporated...sigh.)
+# Maintainer: not_anonymous <nmlibertarian@gmail.com>
+
+# Previous Maintainer: Andreas Schreiner <andreas.schreiner@sonnenmulde.at>
+# Contributor: Ruslan Nabioullin <rnabioullin at gmail dot com>
+# Contributor: Gordon JC Pearce <gordon at gjcp dot net>
+
+pkgname=xastir-fix
+_pkgname=xastir
+pkgver=2.1.0
+pkgrel=2
+pkgdesc="HAM RADIO - Full featured APRS Tracking/Information Reporting System"
+arch=('armv7h' 'i686' 'x86_64')
+url="http://www.xastir.org/"
+license=('GPL' 'LGPL')
+depends=('python' 'openmotif' 'shapelib' 'libax25' 'gdal' 'graphicsmagick' 'libxpm' 'hamradio-menus')
+optdepends=('festival: for speech systhesis')
+makedepends=('autoconf' 'automake' 'printproto-fix')
+conflicts=('xastir-cvs' 'xastir')
+provides=('xastir')
+replaces=('xastir')
+source=(https://github.com/Xastir/Xastir/archive/Release-$pkgver.tar.gz
+ https://github.com/Xastir/${_pkgname}-sounds/archive/v1.0.tar.gz
+ ${_pkgname}.desktop
+ ${_pkgname}-festival.desktop
+ ${_pkgname}-speech
+ ${_pkgname}.png)
+
+build() {
+ cd $srcdir/Xastir-Release-$pkgver
+ ./bootstrap.sh
+ ./configure --prefix=/usr
+
+ sed -i -e s:doc/xastir:xastir/doc: Makefile
+
+ make
+}
+
+package() {
+ cd $srcdir/Xastir-Release-$pkgver
+ make DESTDIR=$pkgdir install
+
+ mkdir -p $pkgdir/usr/share/applications
+ mkdir -p $pkgdir/usr/share/pixmaps
+ cd $srcdir
+ install -m644 *.desktop $pkgdir/usr/share/applications/
+ install -m644 *.png $pkgdir/usr/share/pixmaps/
+ install -m755 ${_pkgname}-speech $pkgdir/usr/bin/
+ rm $pkgdir/usr/share/${_pkgname}/sounds/*
+ install -m644 $srcdir/${_pkgname}-sounds-1.0/sounds/* $pkgdir/usr/share/${_pkgname}/sounds/
+
+ chmod 4755 $pkgdir/usr/bin/${_pkgname}
+}
+md5sums=('1b1abde576f2ebcd64695d1416c62af3'
+ 'c314946788a828d42d804670ad23e646'
+ '2a06e041a0dc5f20c1427a130613d793'
+ '2f8af994b7f5086d4ca2d951ced9019a'
+ 'e56e55a1c43038d4488fbdd429a0a755'
+ '0a7269113052d3bd2711b84ff2fda9d6')
+sha256sums=('a481e6a6c035954041904352ec58f52240c06874a30dfb810001da489d40f43a'
+ 'fd7b0d60386964b8a35ec2e504238d8393f9217e32607a6ddfaeac6bde7d4f4a'
+ '555ee695b83e59ebd270a001d7947bad7c5168ea319d80a3dc7842981975f6ec'
+ '3452ca25072da4ccbaad2a8f07a61f1685872e1874cd6b28e5e5571f734fb47b'
+ 'c99ef0816e0509b7549abdcc41253be2e50499345acd63a19b7b4a17396873b4'
+ '4d140434ccadb2772a08a23543bf3692f413d88cb9a39e0a9cf8b8470230e8c6')
diff --git a/xastir-festival.desktop b/xastir-festival.desktop
new file mode 100644
index 000000000000..9bf8c4510350
--- /dev/null
+++ b/xastir-festival.desktop
@@ -0,0 +1,16 @@
+[Desktop Entry]
+Name=Xastir with Speech
+Name[en_US]=Xastir with Speech
+Comment=Full featured APRS client
+Comment[en_US]=Full featured APRS client
+Encoding=UTF-8
+Exec=xastir-speech
+Icon=xastir.png
+MimeType=text/plain
+StartupNotify=true
+Terminal=
+TerminalOptions=
+Type=Application
+Categories=Network;HamRadio;
+X-DCOP-ServiceType=none
+X-KDE-SubstituteUID=false
diff --git a/xastir-speech b/xastir-speech
new file mode 100644
index 000000000000..dde534a1d36e
--- /dev/null
+++ b/xastir-speech
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+if pgrep festival &> /dev/null
+ then
+ xastir
+ else
+ festival --server & xastir
+ pkill festival
+fi
diff --git a/xastir.desktop b/xastir.desktop
new file mode 100644
index 000000000000..a05fc7dcf6ea
--- /dev/null
+++ b/xastir.desktop
@@ -0,0 +1,16 @@
+[Desktop Entry]
+Name=Xastir
+Name[en_US]=Xastir
+Comment=Full featured APRS client
+Comment[en_US]=Full featured APRS client
+Encoding=UTF-8
+Exec=xastir
+Icon=xastir.png
+MimeType=text/plain
+StartupNotify=true
+Terminal=
+TerminalOptions=
+Type=Application
+Categories=Network;HamRadio;
+X-DCOP-ServiceType=none
+X-KDE-SubstituteUID=false
diff --git a/xastir.png b/xastir.png
new file mode 100644
index 000000000000..56d390af2714
--- /dev/null
+++ b/xastir.png
Binary files differ