summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornikp1232016-09-02 14:35:40 +0200
committernikp1232016-09-02 14:35:40 +0200
commitccaca74ca8836bbf2d6a04e4f9987eac56b40997 (patch)
tree69da99f8cf5c184795a084488c7b84c958628e1c
downloadaur-ccaca74ca8836bbf2d6a04e4f9987eac56b40997.tar.gz
first commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD33
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..467cc5c663f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Fri Sep 2 12:34:53 UTC 2016
+pkgbase = cava-gui-git
+ pkgdesc = SDL2 Audio Visualizer for Alsa/Pulseaudio
+ pkgver = r6.2669408
+ pkgrel = 1
+ url = https://github.com/nikp123/cava-gui
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = fftw
+ depends = alsa-lib
+ depends = iniparser
+ depends = sdl2
+ provides = cava-gui
+ conflicts = cava-gui
+ source = git+https://github.com/nikp123/cava-gui.git
+ sha1sums = SKIP
+
+pkgname = cava-gui-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..30a72e103b10
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+pkgname=cava-gui-git
+_pkgname=cava-gui
+pkgver=r6.2669408
+pkgrel=1
+pkgdesc='SDL2 Audio Visualizer for Alsa/Pulseaudio'
+arch=('i686' 'x86_64')
+url='https://github.com/nikp123/cava-gui'
+license=('MIT')
+depends=('fftw' 'alsa-lib' 'iniparser' 'sdl2')
+makedepends=('git')
+source=('git+https://github.com/nikp123/cava-gui.git')
+conflicts=($_pkgname)
+provides=($_pkgname)
+sha1sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ chmod +x $_pkgname/autogen.sh
+ cd $_pkgname
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $_pkgname
+ install -Dm755 cava "$pkgdir/usr/bin/cava"
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+}