summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-10-22 20:45:19 +0000
committerDaniel Bermond2018-10-22 20:45:19 +0000
commitc8f9f2c7666abf4f10d738f7271d89bf82127991 (patch)
treeeed5d3e1bcb65171aa62b36fe9dffb1d1f2c99ba
parent0f521ea433b1e9ff3bf312d9ff90d08af7c34f64 (diff)
downloadaur-c8f9f2c7666abf4f10d738f7271d89bf82127991.tar.gz
Fixes
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD20
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ddb1f9364ab..8a1e9395bccb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xavs2
pkgdesc = Open-Source encoder of AVS2-P2/IEEE1857.4 video coding standard
pkgver = 1.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/pkuvcl/xavs2/
arch = i686
arch = x86_64
@@ -13,9 +13,7 @@ pkgbase = xavs2
depends = liblsmash.so
provides = libxavs2
provides = libxavs2.so
- conflicts = xavs2-git
conflicts = libxavs2
- conflicts = libxavs2-git
replaces = libxavs2
source = xavs2-1.0.tar.gz::https://github.com/pkuvcl/xavs2/archive/1.0.tar.gz
source = xavs2-1.0-disable-10bit.patch
diff --git a/PKGBUILD b/PKGBUILD
index 4648bb8a4038..25004a1ce670 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
+# Maintainer : Daniel Bermond < gmail-com: danielbermond >
# NOTE:
# 10-bit depth currently fails to build
@@ -6,7 +6,7 @@
pkgname=xavs2
pkgver=1.0
-pkgrel=2
+pkgrel=3
arch=('i686' 'x86_64')
pkgdesc='Open-Source encoder of AVS2-P2/IEEE1857.4 video coding standard'
url='https://github.com/pkuvcl/xavs2/'
@@ -14,7 +14,7 @@ license=('GPL')
depends=('glibc' 'liblsmash.so')
makedepends=('gcc7' 'yasm' 'l-smash')
provides=('libxavs2' 'libxavs2.so')
-conflicts=('xavs2-git' 'libxavs2' 'libxavs2-git')
+conflicts=('libxavs2')
replaces=('libxavs2')
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/pkuvcl/${pkgname}/archive/${pkgver}.tar.gz"
'xavs2-1.0-disable-10bit.patch')
@@ -29,15 +29,15 @@ prepare() {
# disable 10-bit in configure to avoid misleading errors
patch -Np1 -i "${srcdir}/xavs2-1.0-disable-10bit.patch"
-}
-
-build() {
+
# must copy the entire source tree for each build or it will not work
cd "$srcdir"
cp -af "${pkgname}-${pkgver}" build-8bit
cp -af "${pkgname}-${pkgver}" build-10bit
-
- msg2 'Building for 8-bit...'
+}
+
+build() {
+ printf '%s\n' ' -> Building for 8-bit...'
cd build-8bit/build/linux
./configure \
--prefix='/usr' \
@@ -52,7 +52,7 @@ build() {
--disable-gpac
make
- msg2 'Building for 10-bit...'
+ printf '%s\n' ' -> Building for 10-bit...'
cd "${srcdir}/build-10bit/build/linux"
if ./configure \
--prefix='/usr' \
@@ -80,7 +80,7 @@ package() {
for _depth in 10 8
do
- msg2 "Installing for ${_depth}-bit..."
+ printf '%s\n' " -> Installing for ${_depth}-bit..."
if [ "$_depth" -eq '10' ] && ! [ -d 'build-10bit' ]
then